Level9.Net: Main Page

Level9.Net 0.9.6
Level9.Net Documentation

Generated by doxygen 1.7.4


Level9.Net: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
Level9::AboutForm | 'About' dialog with credits and version information
Level9::AttributedText | Represents text with attribute information
Level9::BitmapFont | Represents a bitmap font
Level9::BitmapFontPanel | A panel that displays text with a bitmap font
Level9::BitmapFontRenderer | Renders text with a bitmap fonts
Level9::BitmapFonts | Manages bitmap font resources
Level9::Config | Manages the Level9.Net configuration
Level9::ConfigChangedEventArgs | Provides data for the ConfigChanged event
Level9::ConfigForm | Configuration dialog for colors, fonts and graphics
Level9::ConfigXML | Allows XML serialization of miscellaneous configuration options
Level9::Dictionary | Handles dictionaries of Level 9 games
Level9::DictionaryProgressForm | Displays a progress bar while reading the dictionary of a Level 9 game
Level9::ErrorHandler | Error handler for Level9.Net. Displays error messages and appends error information to the application log file
Level9::FileUtils | Utilities for file handling
Level9::GameFileErrorEventArgs | Provides data for the GameFileError event
Level9::GameGraphics | Handles line drawn and bitmap graphics in a Level 9 game
Level9::GamePanel | Displays text and graphics provided by the Level 9 interpreter and handles user interaction
Level9::GameText | Manages a text buffer and provides methods necessary for text output and shell functionality in a Level 9 game
Level9::GameThread | Controls the main loop which executes opcodes of a Level 9 game
Level9::GraphicsOffEventArgs | Provides data for the GraphicsOff event
Level9::Images | Manages the application icons and bitmaps
Level9::InputFinishedEventArgs | Provides data for the InputFinished event
Level9::InputModeEventArgs | Provides data for the InputMode event
Level9::Interpreter | Callback and control functions of the Level 9 interpreter
Level9::Interpreter::L9BITMAP | The bitmap structure used in games with bitmap graphics
Level9::L9Cut | Controls the L9cut utility to extract datafiles and obtain the title of a game
Level9::L9CutForm | Dialog frontend for the L9cut utility
Level9::LexerError | Represents a grammar error that occurs while parsing a Level9.Net script file
Level9::ListViewItemClickedEventArgs | Provides data for the ListViewItemClicked event
Level9::Logger | Simple logging functionality for Level9.Net
Level9::MainForm | Main window of the Level9.Net application
Level9::NewGameFileEventArgs | Provides data for the NewGameFile event
Level9::OsClearGraphicsEventArgs | Provides data for the OsClearGraphics event
Level9::OsDrawLineEventArgs | Provides data for the OsDrawLine event
Level9::OsFillEventArgs | Provides data for the OsFill event
Level9::OsFlushEventArgs | Provides data for the OsFlush event
Level9::OsGetGameFileEventArgs | Provides data for the OsGetGameFile event
Level9::OsGraphicsEventArgs | Provides data for the OsGraphics event
Level9::OsInputEventArgs | Provides data for the OsInput event
Level9::OsLoadFileEventArgs | Provides data for the OsLoadFile event
Level9::OsReadcharEventArgs | Provides data for the OsReadchar event
Level9::OsSaveFileEventArgs | Provides data for the OsSaveFile event
Level9::OsSetColourEventArgs | Provides data for the OsSetColour event
Level9::OsShowBitmapEventArgs | Provides data for the OsShowBitmap event
Level9::PictureCreatedEventArgs | Provides data for the PictureCreated event
Level9::Script | Manages Level9.Net script files
Level9::ScriptChangedEventArgs | Provides data for the ScriptChanged event
Level9::ScriptEntry | Represents a Level9.Net script entry that consists of user input and a comment
Level9::ScriptForm | A dialog to create, edit, load and save Level9.Net script files
Level9::SimpleListView | Simple list view control with icons and captions
Level9::SimpleListViewItem | Represents a simple list view item
Level9::SimpleToolBar | Simple toolbar with icons and tooltips
Level9::SimpleToolBarButton | Represents a simple toolbar button
Level9::TextForm | Simple text viewer with search options
Level9::TextPosition | Represents a text position defined via paragraph and column
Level9::TextUtils | Utilities for text handling
Level9::ToolbarButtonClickedEventArgs | Provides data for the ToolbarButtonClicked event
Level9::Config::WindowSize | Represents the size of a window


Level9.Net: Level9::AboutForm Class Reference

  • Level9
  • AboutForm
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes
Level9::AboutForm Class Reference

'About' dialog with credits and version information. More...

List of all members.

Public Member Functions

AboutForm ()

Protected Member Functions

override void | Dispose (bool disposing)

Private Member Functions

void | LabelLinkLinkClicked (object sender, LinkLabelLinkClickedEventArgs e)
void | InitializeComponent ()

Private Attributes

System.ComponentModel.IContainer | components = null

Detailed Description

Constructor & Destructor Documentation

Level9::AboutForm::AboutForm ( ) [inline]

Initializes a new instance of the AboutForm class.

Member Function Documentation

void Level9::AboutForm::LabelLinkLinkClicked | ( | object | sender,
 |  | LinkLabelLinkClickedEventArgs | e
 | ) |  | [inline, private]

Invoked when the link label has been clicked.

Parameters:
sender | the object that originated the event
e | a LinkLabelLinkClickedEventArgs that contains the event data
override void Level9::AboutForm::Dispose ( bool disposing ) [inline, protected]

Disposes resources used by the form.

Parameters:
disposing true if managed resources should be disposed; otherwise, false.
void Level9::AboutForm::InitializeComponent ( ) [inline, private]

This method is required for Windows Forms designer support. Do not change the method contents inside the source code editor. The Forms designer might not be able to load this method if it was changed manually.

Member Data Documentation

System.ComponentModel.IContainer Level9::AboutForm::components = null [private]

Designer variable used to keep track of non-visual components.


Level9.Net: Member List

  • AboutForm
Level9::AboutForm Member List
This is the complete list of members for Level9::AboutForm, including all inherited members.
AboutForm() | Level9::AboutForm | [inline]
components | Level9::AboutForm | [private]
Dispose(bool disposing) | Level9::AboutForm | [inline, protected]
InitializeComponent() | Level9::AboutForm | [inline, private]
LabelLinkLinkClicked(object sender, LinkLabelLinkClickedEventArgs e) | Level9::AboutForm | [inline, private]


Level9.Net: Level9::AttributedText Class Reference

  • AttributedText
Public Member Functions | Public Attributes | Properties | Private Attributes
Level9::AttributedText Class Reference

Represents text with attribute information. More...

Collaboration diagram for Level9::AttributedText:
[legend]

List of all members.

Public Member Functions

AttributedText (string text)
AttributedText (char[] text)
void | Append (string append)
void | Append (char[] append)
void | Insert (string insert, int pos)
void | Insert (char[] insert, int pos)
void | RemoveRange (int start, int end)
AttributedText | GetRange (int start, int end)
void | TrimEnd ()
void | AddAttribute (uint attribute, int pos)
void | RemoveAttribute (uint attribute, int pos)
int | GetLength ()
override bool | Equals (Object obj)
override int | GetHashCode ()
override string | ToString ()

Public Attributes

const uint | ATTR_INPUT_START = 0x00000001
const uint | ATTR_INPUT_END = 0x00000002
const uint | ATTR_INPUT_CARET = 0x00000004

Properties

uint[] | Attributes [get]
char[] | Text [get]
TextPosition | Origin [get]

Private Attributes

char[] | text = null
uint[] | attributes = null
TextPosition | origin = new TextPosition()

Detailed Description

Constructor & Destructor Documentation

Level9::AttributedText::AttributedText ( string text ) [inline]

Initializes a new instance of the AttributedText class.

Parameters:
text the text associated with this instance
Level9::AttributedText::AttributedText ( char[] text ) [inline]

Initializes a new instance of the AttributedText class.

Parameters:
text the text associated with this instance

Member Function Documentation

void Level9::AttributedText::Append ( string append ) [inline]

Appends a string to the attributed text.

Parameters:
append the string to append
void Level9::AttributedText::Append ( char[] append ) [inline]

Appends a character array to the attributed text.

Parameters:
append the character array to append
void Level9::AttributedText::Insert | ( | string | insert,
 |  | int | pos
 | ) |  | [inline]

Inserts a string in the attributed text.

Parameters:
insert | the string to insert
pos | the insert position
void Level9::AttributedText::Insert | ( | char[] | insert,
 |  | int | pos
 | ) |  | [inline]

Inserts a character array in the attributed text.

Parameters:
insert | the character array to insert
pos | the insert position
void Level9::AttributedText::RemoveRange | ( | int | start,
 |  | int | end
 | ) |  | [inline]

Removes a range of the attributed text.

Parameters:
start | the start position
end | the end position
AttributedText Level9::AttributedText::GetRange | ( | int | start,
 |  | int | end
 | ) |  | [inline]

Provides a range of the attributed text.

Parameters:
start | the start position
end | the end position
Returns:
a range of the attributed text or null if an error occurred
void Level9::AttributedText::TrimEnd ( ) [inline]

Removes blanks at the attributed text's end.

void Level9::AttributedText::AddAttribute | ( | uint | attribute,
 |  | int | pos
 | ) |  | [inline]

Adds an attribute at the given position.

Parameters:
attribute | a text attribute
pos | the text position
void Level9::AttributedText::RemoveAttribute | ( | uint | attribute,
 |  | int | pos
 | ) |  | [inline]

Removes an attribute at the given position.

Parameters:
attribute | a text attribute
pos | the text position
int Level9::AttributedText::GetLength ( ) [inline]

Provides the text's length.

Returns:
the text's lenght
override bool Level9::AttributedText::Equals ( Object obj ) [inline]

Determines whether the specified Object is equal to the current Object.

Parameters:
obj the Object to compare with the current Object
Returns:
true if the specified Object is equal to the current Object; otherwise, false
override int Level9::AttributedText::GetHashCode ( ) [inline]

Serves as a hash function for a particular type.

Returns:
a hash code for the current Object
override string Level9::AttributedText::ToString ( ) [inline]

Returns a String that represents the current Object.

Returns:
a String that represents the current Object

Member Data Documentation

const uint Level9::AttributedText::ATTR_INPUT_START = 0x00000001

The text attribute that indicates the start of user input.

const uint Level9::AttributedText::ATTR_INPUT_END = 0x00000002

The text attribute that indicates the end of user input.

const uint Level9::AttributedText::ATTR_INPUT_CARET = 0x00000004

The text attribute that indicates the caret position.

char [] Level9::AttributedText::text = null [private]

The text associated with this instance.

uint [] Level9::AttributedText::attributes = null [private]

An array with text attributes. The indices correspond to the indices of the AttributedText.text array.

TextPosition Level9::AttributedText::origin = new TextPosition() [private]

The text position this attributed text came from.

Property Documentation

uint [] Level9::AttributedText::Attributes [get]

Gets the text attributes.

char [] Level9::AttributedText::Text [get]

Gets the text associated with this instance.

TextPosition Level9::AttributedText::Origin [get]

Gets the text position this attributed text came from.


Level9.Net: Member List

  • AttributedText
Level9::AttributedText Member List
This is the complete list of members for Level9::AttributedText, including all inherited members.
AddAttribute(uint attribute, int pos) | Level9::AttributedText | [inline]
Append(string append) | Level9::AttributedText | [inline]
Append(char[] append) | Level9::AttributedText | [inline]
ATTR_INPUT_CARET | Level9::AttributedText |
ATTR_INPUT_END | Level9::AttributedText |
ATTR_INPUT_START | Level9::AttributedText |
AttributedText(string text) | Level9::AttributedText | [inline]
AttributedText(char[] text) | Level9::AttributedText | [inline]
attributes | Level9::AttributedText | [private]
Attributes | Level9::AttributedText |
Equals(Object obj) | Level9::AttributedText | [inline]
GetHashCode() | Level9::AttributedText | [inline]
GetLength() | Level9::AttributedText | [inline]
GetRange(int start, int end) | Level9::AttributedText | [inline]
Insert(string insert, int pos) | Level9::AttributedText | [inline]
Insert(char[] insert, int pos) | Level9::AttributedText | [inline]
origin | Level9::AttributedText | [private]
Origin | Level9::AttributedText |
RemoveAttribute(uint attribute, int pos) | Level9::AttributedText | [inline]
RemoveRange(int start, int end) | Level9::AttributedText | [inline]
Text | Level9::AttributedText |
text | Level9::AttributedText | [private]
ToString() | Level9::AttributedText | [inline]
TrimEnd() | Level9::AttributedText | [inline]


Level9.Net: Level9::BitmapFont Class Reference

  • BitmapFont
Public Member Functions | Properties | Private Attributes
Level9::BitmapFont Class Reference

Represents a bitmap font. More...

List of all members.

Public Member Functions

BitmapFont (string type, Size size, Bitmap bitmap)
override bool | Equals (Object obj)
override int | GetHashCode ()

Properties

string | Type [get]
Size | Size [get]
int | Height [get]
int | Width [get]
Bitmap | Bitmap [get]

Private Attributes

Size | size
int | height
int | width
Bitmap | bitmap
string | type

Detailed Description

Constructor & Destructor Documentation

Level9::BitmapFont::BitmapFont | ( | string | type,
 |  | Size | size,
 |  | Bitmap | bitmap
 | ) |  | [inline]

Initializes a new instance of the BitmapFont class.

Parameters:
type | the font type
size | the font size in pixels
bitmap | a bitmap that contains the font data

Member Function Documentation

override bool Level9::BitmapFont::Equals ( Object obj ) [inline]

Determines whether the specified Object is equal to the current Object.

Parameters:
obj the Object to compare with the current Object
Returns:
true if the specified Object is equal to the current Object; otherwise, false
override int Level9::BitmapFont::GetHashCode ( ) [inline]

Serves as a hash function for a particular type.

Returns:
a hash code for the current Object

Member Data Documentation

Size Level9::BitmapFont::size [private]

The font size in pixels.

int Level9::BitmapFont::height [private]

The font height in pixels.

int Level9::BitmapFont::width [private]

The font width in pixels.

Bitmap Level9::BitmapFont::bitmap [private]

The bitmap that contains font data.

string Level9::BitmapFont::type [private]

The font type.

Property Documentation

string Level9::BitmapFont::Type [get]

Gets the font type.

Size Level9::BitmapFont::Size [get]

Gets the font size in pixels.

int Level9::BitmapFont::Height [get]

Gets the font height in pixels.

int Level9::BitmapFont::Width [get]

Gets the font width in pixels.

Bitmap Level9::BitmapFont::Bitmap [get]

Gets the bitmap that contains font data.


Level9.Net: Member List

  • BitmapFont
Level9::BitmapFont Member List
This is the complete list of members for Level9::BitmapFont, including all inherited members.
bitmap | Level9::BitmapFont | [private]
Bitmap | Level9::BitmapFont |
BitmapFont(string type, Size size, Bitmap bitmap) | Level9::BitmapFont | [inline]
Equals(Object obj) | Level9::BitmapFont | [inline]
GetHashCode() | Level9::BitmapFont | [inline]
Height | Level9::BitmapFont |
height | Level9::BitmapFont | [private]
size | Level9::BitmapFont | [private]
Size | Level9::BitmapFont |
Type | Level9::BitmapFont |
type | Level9::BitmapFont | [private]
width | Level9::BitmapFont | [private]
Width | Level9::BitmapFont |


Level9.Net: Level9::BitmapFontPanel Class Reference

  • BitmapFontPanel
Public Member Functions | Protected Member Functions | Properties | Private Attributes
Level9::BitmapFontPanel Class Reference

A panel that displays text with a bitmap font. More...

Collaboration diagram for Level9::BitmapFontPanel:
[legend]

List of all members.

Public Member Functions

BitmapFontPanel ()

Protected Member Functions

override void | OnPaint (PaintEventArgs e)
override void | Dispose (bool disposing)

Properties

Color | InputColor [get, set]
Color | TitleBarForeColor [get, set]
Color | TitleBarBackColor [get, set]
BitmapFont | BitmapFont [get, set]
int | LineSpacing [get, set]
List< AttributedText > | Paragraphs [get, set]
override string | Text [get, set]
string | TitleBarText [get, set]

Private Attributes

const int | BAR_XY_SPACING = 2
const int | TEXT_Y_SPACING = 2
const int | TEXT_X_SPACING = 2
BitmapFont bitmapFont
int | lineSpacing = 2
List< AttributedText > | paragraphs
string | titleBarText
Color | inputColor
Color | titleBarForeColor
Color | titleBarBackColor
Bitmap | titleBitmap = null
Bitmap | textBitmap = null
BitmapFontRenderer | titleRenderer = new BitmapFontRenderer()
BitmapFontRenderer | fontRenderer = new BitmapFontRenderer()

Detailed Description

Constructor & Destructor Documentation

Level9::BitmapFontPanel::BitmapFontPanel ( ) [inline]

Initializes a new instance of the BitmapFontPanel class.

Member Function Documentation

override void Level9::BitmapFontPanel::OnPaint ( PaintEventArgs e ) [inline, protected]

Handles the Paint event.

Parameters:
e a PaintEventArgs that contains the event data
override void Level9::BitmapFontPanel::Dispose ( bool disposing ) [inline, protected]

Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.

Parameters:
disposing true to release both managed and unmanaged resources; false to release only unmanaged resources.

Member Data Documentation

const int Level9::BitmapFontPanel::BAR_XY_SPACING = 2 [private]

The width of the borders around a title bar or status bar.

const int Level9::BitmapFontPanel::TEXT_Y_SPACING = 2 [private]

The width of the upper and lower borders around a text area.

const int Level9::BitmapFontPanel::TEXT_X_SPACING = 2 [private]

The width of the left and right borders around a text area.

BitmapFont Level9::BitmapFontPanel::bitmapFont [private]

The bitmap font.

int Level9::BitmapFontPanel::lineSpacing = 2 [private]

The spacing between lines, in pixels.

List<AttributedText> Level9::BitmapFontPanel::paragraphs [private]

A list of paragraphs associated with this control.

string Level9::BitmapFontPanel::titleBarText [private]

The title bar text associated with this control.

Color Level9::BitmapFontPanel::inputColor [private]

The input text color.

Color Level9::BitmapFontPanel::titleBarForeColor [private]

The title bar foreground color.

Color Level9::BitmapFontPanel::titleBarBackColor [private]

The title bar background color.

Bitmap Level9::BitmapFontPanel::titleBitmap = null [private]

A bitmap that contains the rendered title bar text.

Bitmap Level9::BitmapFontPanel::textBitmap = null [private]

A bitmap that contains the rendered text.

BitmapFontRenderer Level9::BitmapFontPanel::titleRenderer = new BitmapFontRenderer() [private]

A renderer that draws the title bar text with a bitmap font.

BitmapFontRenderer Level9::BitmapFontPanel::fontRenderer = new BitmapFontRenderer() [private]

A renderer that draws the text with a bitmap font.

Property Documentation

Color Level9::BitmapFontPanel::InputColor [get, set]

Gets or sets the input text color.

Color Level9::BitmapFontPanel::TitleBarForeColor [get, set]

Gets or sets the title bar foreground color.

Color Level9::BitmapFontPanel::TitleBarBackColor [get, set]

Gets or sets the title bar background color.

BitmapFont Level9::BitmapFontPanel::BitmapFont [get, set]

Gets or sets the bitmap font.

int Level9::BitmapFontPanel::LineSpacing [get, set]

Gets or sets the spacing between lines, in pixels.

List<AttributedText> Level9::BitmapFontPanel::Paragraphs [get, set]

Gets or sets the list of paragraphs associated with this control.

override string Level9::BitmapFontPanel::Text [get, set]

Gets or sets the text associated with this control.

string Level9::BitmapFontPanel::TitleBarText [get, set]

Gets or sets the title bar text associated with this control.


Level9.Net: Member List

  • BitmapFontPanel
Level9::BitmapFontPanel Member List
This is the complete list of members for Level9::BitmapFontPanel, including all inherited members.
BAR_XY_SPACING | Level9::BitmapFontPanel | [private]
bitmapFont | Level9::BitmapFontPanel | [private]
BitmapFont | Level9::BitmapFontPanel |
BitmapFontPanel() | Level9::BitmapFontPanel | [inline]
Dispose(bool disposing) | Level9::BitmapFontPanel | [inline, protected]
fontRenderer | Level9::BitmapFontPanel | [private]
inputColor | Level9::BitmapFontPanel | [private]
InputColor | Level9::BitmapFontPanel |
LineSpacing | Level9::BitmapFontPanel |
lineSpacing | Level9::BitmapFontPanel | [private]
OnPaint(PaintEventArgs e) | Level9::BitmapFontPanel | [inline, protected]
Paragraphs | Level9::BitmapFontPanel |
paragraphs | Level9::BitmapFontPanel | [private]
Text | Level9::BitmapFontPanel |
TEXT_X_SPACING | Level9::BitmapFontPanel | [private]
TEXT_Y_SPACING | Level9::BitmapFontPanel | [private]
textBitmap | Level9::BitmapFontPanel | [private]
titleBarBackColor | Level9::BitmapFontPanel | [private]
TitleBarBackColor | Level9::BitmapFontPanel |
TitleBarForeColor | Level9::BitmapFontPanel |
titleBarForeColor | Level9::BitmapFontPanel | [private]
titleBarText | Level9::BitmapFontPanel | [private]
TitleBarText | Level9::BitmapFontPanel |
titleBitmap | Level9::BitmapFontPanel | [private]
titleRenderer | Level9::BitmapFontPanel | [private]


Level9.Net: Level9::BitmapFontRenderer Class Reference

  • BitmapFontRenderer
Public Member Functions | Private Member Functions | Private Attributes
Level9::BitmapFontRenderer Class Reference

Renders text with a bitmap fonts. More...

Collaboration diagram for Level9::BitmapFontRenderer:
[legend]

List of all members.

Public Member Functions

Bitmap | RenderText (string text, BitmapFont font, Color backColor, Color foreColor)
Bitmap | RenderText (List< AttributedText > outputLines, BitmapFont font, int lineSpacing, int linesOffset, Color backColor, Color foreColor, Color inputColor)

Private Member Functions

bool | UpdateTextBitmap (Size bitmapSize, BitmapFont font, int lineSpacing, Color backColor, Color foreColor, Color inputColor)

Private Attributes

int | MASK_FORECOLOR = 0x00000000
int | MASK_INPUTCOLOR = 0x03030303
int | MASK_INPUTCOLOR_INV = 0x02020202
Bitmap | textBitmap = null
BitmapFont | font = null
int | lineSpacing = 0

Detailed Description

Member Function Documentation

Bitmap Level9::BitmapFontRenderer::RenderText | ( | string | text,
 |  | BitmapFont | font,
 |  | Color | backColor,
 |  | Color | foreColor
 | ) |  | [inline]

Creates a bitmap (8 bit per pixel, indexed) and draws the given text with a bitmap font into it. The bitmap must be disposed after use.

Parameters:
text | the text to be drawn
font | the bitmap font
backColor | the background color
foreColor | the foreground color
Returns:
a text bitmap, or null if an error occurred
Bitmap Level9::BitmapFontRenderer::RenderText | ( | List< AttributedText > | outputLines,
 |  | BitmapFont | font,
 |  | int | lineSpacing,
 |  | int | linesOffset,
 |  | Color | backColor,
 |  | Color | foreColor,
 |  | Color | inputColor
 | ) |  | [inline]

Creates a bitmap (8 bit per pixel, indexed) and draws the given text with a bitmap font into it. The bitmap must be disposed after use.

Parameters:
outputLines | a list of lines to be drawn
font | the bitmap font
lineSpacing | the line spacing in pixels
linesOffset | the offset position in outputLines
backColor | the background color
foreColor | the foreground color
inputColor | the user input color
Returns:
a text bitmap, or null if an error occurred
bool Level9::BitmapFontRenderer::UpdateTextBitmap | ( | Size | bitmapSize,
 |  | BitmapFont | font,
 |  | int | lineSpacing,
 |  | Color | backColor,
 |  | Color | foreColor,
 |  | Color | inputColor
 | ) |  | [inline, private]

Updates the text bitmap and its palette.

Parameters:
bitmapSize | the Bitmap to draw the text into
font | the bitmap font
lineSpacing | the line spacing in pixels
backColor | the background color
foreColor | the foreground color
inputColor | the user input color
Returns:
true if a new bitmap was created; otherwise, false

Member Data Documentation

int Level9::BitmapFontRenderer::MASK_FORECOLOR = 0x00000000 [private]

The XOR mask for rendering text with the foreground color.

int Level9::BitmapFontRenderer::MASK_INPUTCOLOR = 0x03030303 [private]

The XOR mask for rendering text with the input color.

int Level9::BitmapFontRenderer::MASK_INPUTCOLOR_INV = 0x02020202 [private]

The XOR mask for rendering text with the inverse input color.

Bitmap Level9::BitmapFontRenderer::textBitmap = null [private]

The Bitmap to draw the text into.

BitmapFont Level9::BitmapFontRenderer::font = null [private]

The bitmap font.

int Level9::BitmapFontRenderer::lineSpacing = 0 [private]

The spacing between lines, in pixels.


Level9.Net: Member List

  • BitmapFontRenderer
Level9::BitmapFontRenderer Member List
This is the complete list of members for Level9::BitmapFontRenderer, including all inherited members.
font | Level9::BitmapFontRenderer | [private]
lineSpacing | Level9::BitmapFontRenderer | [private]
MASK_FORECOLOR | Level9::BitmapFontRenderer | [private]
MASK_INPUTCOLOR | Level9::BitmapFontRenderer | [private]
MASK_INPUTCOLOR_INV | Level9::BitmapFontRenderer | [private]
RenderText(string text, BitmapFont font, Color backColor, Color foreColor) | Level9::BitmapFontRenderer | [inline]
RenderText(List< AttributedText > outputLines, BitmapFont font, int lineSpacing, int linesOffset, Color backColor, Color foreColor, Color inputColor) | Level9::BitmapFontRenderer | [inline]
textBitmap | Level9::BitmapFontRenderer | [private]
UpdateTextBitmap(Size bitmapSize, BitmapFont font, int lineSpacing, Color backColor, Color foreColor, Color inputColor) | Level9::BitmapFontRenderer | [inline, private]


Level9.Net: Level9::BitmapFonts Class Reference

  • BitmapFonts
Static Public Member Functions | Properties | Static Private Member Functions | Static Private Attributes
Level9::BitmapFonts Class Reference

Manages bitmap font resources. More...

Collaboration diagram for Level9::BitmapFonts:
[legend]

List of all members.

Static Public Member Functions

static BitmapFont | Get (string type, int scaling)

Properties

static string[] | FontTypes [get]
static int[] | FontScalings [get]

Static Private Member Functions

static | BitmapFonts ()

Static Private Attributes

static string[] | fontTypes
static int[] | fontScalings
static string[] | resources
static Size[] | sizes
static BitmapFont[] | bitmapFonts

Detailed Description

Constructor & Destructor Documentation

static Level9::BitmapFonts::BitmapFonts ( ) [inline, static, private]

Initializes static members of the BitmapFonts class.

Member Function Documentation

static BitmapFont Level9::BitmapFonts::Get | ( | string | type,
 |  | int | scaling
 | ) |  | [inline, static]

Provides a bitmap font for the given font type and scaling factor. The available font types are:

  • Amiga
  • Amstrad CPC
  • Atari ST
  • Atari 8-bit
  • BBC Micro
  • C64
  • Enterprise 64
  • IBM PC
  • Macintosh
  • Memotech MTX
  • Nascom
  • MSX
  • Spectrum

The available scaling factors are: 1, 2, 3.

Parameters:
type | the font type
scaling | the font scaling factor
Returns:
a bitmap font

Member Data Documentation

string [] Level9::BitmapFonts::fontTypes [static, private]
Initial value:
                {
                        "Amiga",
                        "Amstrad CPC",
                        "Atari ST",
                        "Atari 8-bit",
                        "BBC Micro",
                        "C64",
                        "Enterprise 64",
                        "IBM PC",
                        "Macintosh",
                        "Memotech MTX",
                        "Nascom",
                        "MSX",
                        "Spectrum"
                }

The available font types.

int [] Level9::BitmapFonts::fontScalings [static, private]
Initial value:
                {
                        1, 2, 3
                }

The available font scaling factors.

string [] Level9::BitmapFonts::resources [static, private]

The font resource names.

Size [] Level9::BitmapFonts::sizes [static, private]

The font sizes.

BitmapFont [] Level9::BitmapFonts::bitmapFonts [static, private]

A list with BitmapFont elements.

Property Documentation

string [] Level9::BitmapFonts::FontTypes [static, get]

Gets the available font types.

int [] Level9::BitmapFonts::FontScalings [static, get]

Gets the avialiable font scaling factors.


Level9.Net: Member List

  • BitmapFonts
Level9::BitmapFonts Member List
This is the complete list of members for Level9::BitmapFonts, including all inherited members.
bitmapFonts | Level9::BitmapFonts | [private, static]
BitmapFonts() | Level9::BitmapFonts | [inline, private, static]
fontScalings | Level9::BitmapFonts | [private, static]
FontScalings | Level9::BitmapFonts | [static]
fontTypes | Level9::BitmapFonts | [private, static]
FontTypes | Level9::BitmapFonts | [static]
Get(string type, int scaling) | Level9::BitmapFonts | [inline, static]
resources | Level9::BitmapFonts | [private, static]
sizes | Level9::BitmapFonts | [private, static]


Level9.Net: Level9::Config Class Reference

  • Config
Classes | Public Types | Public Member Functions | Static Public Member Functions | Public Attributes | Properties | Events | Private Member Functions | Private Attributes | Static Private Attributes
Level9::Config Class Reference

Manages the Level9.Net configuration. More...

Collaboration diagram for Level9::Config:
[legend]

List of all members.

Classes

class | WindowSize
Represents the size of a window. More...

Public Types

enum | Palette { UserDefined, Amiga, Spectrum }

Public Member Functions

Color[] | GetActivePalette ()
void | AddToRecentFiles (string file)
void | FireConfigChanged ()
void | WriteSettings ()

Static Public Member Functions

static bool | IsInitialized ()
static string | GetAppDataPath ()
static string | GetConfigFilePath ()
static string | GetLevel9DLLPath ()
static string | GetAntlrPath ()
static string | GetL9CutPath ()
static string | GetLogFilePath ()
static string | GetHelpFilePath ()

Public Attributes

const string | PROGRAM_NAME = "Level9.Net"
const string | PROGRAM_VERSION = "0.9.6"
const string | LEVEL9_DLL = "Level9.dll"
const string | ANTLR_DLL = "Antlr3.Runtime.dll"
const string | SETTINGS_FILE = "settings.xml"
const string | LOG_FILE = "level9net.log"
const string | L9CUT_EXE = "L9cut.exe"
const string | HELP_FILE = "Level9Net.chm"

Properties

static Config | Instance [get]
WindowSize | ClientSize [get]
WindowSize | ScriptEditorSize [get]
WindowSize | TextViewerSize [get]
WindowSize | DictViewerSize [get]
bool | ShowToolbar [get, set]
bool | ShowStatusBar [get, set]
bool | ShowTitleBar [get, set]
bool | ShowScriptPlayback [get, set]
bool | ShowTimer [get, set]
Color | TextColor [get, set]
Color | BackColor [get, set]
Color | InputColor [get, set]
Color | BarTextColor [get, set]
Color | BarBackColor [get, set]
Color[] | AmigaPalette [get]
Color[] | SpectrumPalette [get]
Color[] | UserPalette [get, set]
Palette | PaletteSelection [get, set]
BitmapFont | Font [get, set]
int | FontScaling [get, set]
int | LineSpacing [get, set]
int[] | LineSpacings [get]
int | ImageScaling [get, set]
int[] | ImageScalings [get]
bool | ScriptIncludeComments [get, set]
bool | ScriptOneEntryPerLine [get, set]
int | ScriptInputDelay [get, set]
int[] | ScriptInputDelays [get]
string[] | RecentFiles [get, set]
static bool | LoggingEnabled [get, set]

Events

ConfigChangedEventHandler | ConfigChanged

Private Member Functions

Config ()
void | ReadSettings ()
void | SetMembers (ConfigXML xml)

Private Attributes

const int | MAX_RECENT_FILES = 10
WindowSize | clientSize = new WindowSize(644, 600)
WindowSize | scriptEditorSize = new WindowSize(600, 440)
WindowSize | textViewerSize = new WindowSize(600, 440)
WindowSize | dictViewerSize = new WindowSize(600, 440)
bool | showToolbar = true
bool | showStatusBar = true
bool | showTitleBar = true
bool | showTimer = true
bool | showScriptPlayback = true
Color | textColor = Color.LightGray
Color | inputColor = Color.Yellow
Color | backColor = Color.Black
Color | barTextColor = Color.Black
Color | barBackColor = Color.LightGray
Color[] | amigaPalette
Color[] | spectrumPalette
Color[] | userPalette
Palette | paletteSelection = Palette.Amiga
int[] | imageScalings
int | imageScaling = 2
BitmapFont | font = BitmapFonts.Get("Atari ST", 1)
int | fontScaling = 1
int[] | lineSpacings
int | lineSpacing = 1
string[] | recentFiles
bool | scriptIncludeComments = false
bool | scriptOneEntryPerLine = false
int | scriptInputDelay = 2
int[] | scriptInputDelays

Static Private Attributes

static Config | instance = null
static bool | loggingEnabled = false

Detailed Description

Member Enumeration Documentation

enum Level9::Config::Palette

The palette options for line drawn graphics.

Enumerator:
UserDefined

User defined palette.

Amiga

Amiga palette.

Spectrum

Spectrum palette.

Constructor & Destructor Documentation

Level9::Config::Config ( ) [inline, private]

Initializes a new instance of the Config class.

Member Function Documentation

Color [] Level9::Config::GetActivePalette ( ) [inline]

Gets the current palette colors for line drawn graphics.

void Level9::Config::AddToRecentFiles ( string file ) [inline]

Adds a file to the 'recent files' list.

Parameters:
file the file path path
void Level9::Config::FireConfigChanged ( ) [inline]

Notifies listeners that the configuration has changed.

void Level9::Config::WriteSettings ( ) [inline]

Writes a XML settings file. The file path is given by GetConfigFilePath().

void Level9::Config::ReadSettings ( ) [inline, private]

Reads a XML settings file. The file path is given by GetConfigFilePath().

void Level9::Config::SetMembers ( ConfigXML xml ) [inline, private]

Checks the values of a ConfigXML instance and applies the settings to the current Config instance.

Parameters:
xml a ConfigXML instance
static bool Level9::Config::IsInitialized ( ) [inline, static]

Provides the initialization state of the configuration.

Returns:
true, if the configuration has been initialized; otherwise, false
static string Level9::Config::GetAppDataPath ( ) [inline, static]

Provides the application data path.

Returns:
the configuration file path
static string Level9::Config::GetConfigFilePath ( ) [inline, static]

Provides the configuration file path.

Returns:
the configuration file path
static string Level9::Config::GetLevel9DLLPath ( ) [inline, static]

Provides the Level 9 DLL path.

Returns:
the Level 9 DLL path
static string Level9::Config::GetAntlrPath ( ) [inline, static]

Provides the ANTLRv3 DLL path.

Returns:
the ANTLRv3 DLL path
static string Level9::Config::GetL9CutPath ( ) [inline, static]

Provides the L9cut executable path.

Returns:
the L9cut executable path
static string Level9::Config::GetLogFilePath ( ) [inline, static]

Provides the log file path.

Returns:
the log file path
static string Level9::Config::GetHelpFilePath ( ) [inline, static]

Provides the help file path.

Returns:
the help file path

Member Data Documentation

const string Level9::Config::PROGRAM_NAME = "Level9.Net"

The program name.

const string Level9::Config::PROGRAM_VERSION = "0.9.6"

The program version.

const string Level9::Config::LEVEL9_DLL = "Level9.dll"

The Level 9 interpreter DLL filename.

const string Level9::Config::ANTLR_DLL = "Antlr3.Runtime.dll"

The ANTLRv3 DLL filename.

const string Level9::Config::SETTINGS_FILE = "settings.xml"

The settings filename.

const string Level9::Config::LOG_FILE = "level9net.log"

The log filename.

const string Level9::Config::L9CUT_EXE = "L9cut.exe"

The L9cut executable filename.

const string Level9::Config::HELP_FILE = "Level9Net.chm"

The Level9.Net help filename.

const int Level9::Config::MAX_RECENT_FILES = 10 [private]

The maximum number of 'recent files' in the main menu.

Config Level9::Config::instance = null [static, private]

The one and only Config instance (singleton).

bool Level9::Config::loggingEnabled = false [static, private]

This property indicates whether logging is enabled or disabled.

WindowSize Level9::Config::clientSize = new WindowSize(644, 600) [private]

The application window size.

WindowSize Level9::Config::scriptEditorSize = new WindowSize(600, 440) [private]

The window size of the script editor dialog.

WindowSize Level9::Config::textViewerSize = new WindowSize(600, 440) [private]

The window size of the text viewer dialog.

WindowSize Level9::Config::dictViewerSize = new WindowSize(600, 440) [private]

The window size of the dictionary viewer dialog.

bool Level9::Config::showToolbar = true [private]

This property indicates whether the toolbar is visible or hidden.

bool Level9::Config::showStatusBar = true [private]

This property indicates whether the status bar is visible or hidden.

bool Level9::Config::showTitleBar = true [private]

This property indicates whether the title bar is visible or hidden.

bool Level9::Config::showTimer = true [private]

This property indicates whether the timer is visible or hidden.

bool Level9::Config::showScriptPlayback = true [private]

This property indicates whether the script playback toolbar is visible or hidden.

Color Level9::Config::textColor = Color.LightGray [private]

The text color.

Color Level9::Config::inputColor = Color.Yellow [private]

The input text color.

Color Level9::Config::backColor = Color.Black [private]

The background color.

Color Level9::Config::barTextColor = Color.Black [private]

The title/status bar text color.

Color Level9::Config::barBackColor = Color.LightGray [private]

The title/status bar background color.

Color [] Level9::Config::amigaPalette [private]
Initial value:
                {
                        Color.FromArgb(0x00,0x00,0x00),
                        Color.FromArgb(0xff,0x00,0x00),
                        Color.FromArgb(0x30,0xe8,0x30),
                        Color.FromArgb(0xff,0xff,0x00),
                        Color.FromArgb(0x00,0x00,0xff),
                        Color.FromArgb(0xa0,0x68,0x00),
                        Color.FromArgb(0x00,0xff,0xff),
                        Color.FromArgb(0xff,0xff,0xff)
                }

The Amiga palette colors.

Color [] Level9::Config::spectrumPalette [private]
Initial value:
                {
                        Color.FromArgb(0x00,0x00,0x00),
                        Color.FromArgb(0x00,0x00,0xfc),
                        Color.FromArgb(0x00,0xfc,0x00),
                        Color.FromArgb(0x00,0xfc,0xfc),
                        Color.FromArgb(0xfc,0x00,0x00),
                        Color.FromArgb(0xf0,0x00,0xfc),
                        Color.FromArgb(0xfc,0xfc,0x00),
                        Color.FromArgb(0xfc,0xfc,0xfc),
                }

The Spectrum palette colors.

Color [] Level9::Config::userPalette [private]
Initial value:
                {
                        Color.FromArgb(0x00,0x00,0x00),
                        Color.FromArgb(0xff,0x00,0x00),
                        Color.FromArgb(0x30,0xe8,0x30),
                        Color.FromArgb(0xff,0xff,0x00),
                        Color.FromArgb(0x00,0x00,0xff),
                        Color.FromArgb(0xa0,0x68,0x00),
                        Color.FromArgb(0x00,0xff,0xff),
                        Color.FromArgb(0xff,0xff,0xff)
                }

The user defined palette colors.

Palette Level9::Config::paletteSelection = Palette.Amiga [private]

The selected color palette for line drawn graphics.

int [] Level9::Config::imageScalings [private]
Initial value:
                {
                        1, 2, 3, 4
                }

The available image scaling factors for line drawn and bitmap graphics.

int Level9::Config::imageScaling = 2 [private]

The selected image scaling factor.

BitmapFont Level9::Config::font = BitmapFonts.Get("Atari ST", 1) [private]

The in-game bitmap font.

int Level9::Config::fontScaling = 1 [private]

The selected font scaling factor.

int [] Level9::Config::lineSpacings [private]
Initial value:
                {
                        1, 2, 3, 4, 5, 6, 7, 8, 9, 10
                }

The available line spacings.

int Level9::Config::lineSpacing = 1 [private]

The selected line spacing.

string [] Level9::Config::recentFiles [private]

The list of 'recent files' in the main menu.

bool Level9::Config::scriptIncludeComments = false [private]

This property indicates whether or not Level9.Net scripts include comments.

bool Level9::Config::scriptOneEntryPerLine = false [private]

This property indicates whether Level9.Net scripts contain one or multiple entries per line.

int Level9::Config::scriptInputDelay = 2 [private]

The input delay for script playback (seconds).

int [] Level9::Config::scriptInputDelays [private]
Initial value:
                {
                        0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10
                }

The available script input delays.

Property Documentation

Config Level9::Config::Instance [static, get]

Gets the one and only Config instance (singleton).

WindowSize Level9::Config::ClientSize [get]

Gets or sets the application window size.

WindowSize Level9::Config::ScriptEditorSize [get]

Gets or sets the window size of the script editor dialog.

WindowSize Level9::Config::TextViewerSize [get]

Gets or sets the window size of the text viewer dialog.

WindowSize Level9::Config::DictViewerSize [get]

Gets or sets the window size of the dictionary viewer dialog.

bool Level9::Config::ShowToolbar [get, set]

Gets or sets a value that indicates whether the toolbar is visible or hidden.

bool Level9::Config::ShowStatusBar [get, set]

Gets or sets a value that indicates whether the status bar is visible or hidden.

bool Level9::Config::ShowTitleBar [get, set]

Gets or sets a value that indicates whether the title bar is visible or hidden.

bool Level9::Config::ShowScriptPlayback [get, set]

Gets or sets a value that indicates whether the script playback toolbar is visible or hidden.

bool Level9::Config::ShowTimer [get, set]

Gets or sets a value that indicates whether the timer is visible or hidden.

Color Level9::Config::TextColor [get, set]

Gets or sets the text color.

Color Level9::Config::BackColor [get, set]

Gets or sets the background color.

Color Level9::Config::InputColor [get, set]

Gets or sets the input text color.

Color Level9::Config::BarTextColor [get, set]

Gets or sets the title/status bar text color.

Color Level9::Config::BarBackColor [get, set]

Gets or sets the title/status bar background color.

Color [] Level9::Config::AmigaPalette [get]

Gets the Amiga palette colors.

Color [] Level9::Config::SpectrumPalette [get]

Gets the Spectrum palette colors.

Color [] Level9::Config::UserPalette [get, set]

Gets or sets the user defined palette colors.

Palette Level9::Config::PaletteSelection [get, set]

Gets or sets the selected color palette for line drawn graphics.

BitmapFont Level9::Config::Font [get, set]

Gets or sets the in-game bitmap font.

int Level9::Config::FontScaling [get, set]

Gets or sets the selected font scaling factor.

int Level9::Config::LineSpacing [get, set]

Gets or sets the selected lines spacing.

int [] Level9::Config::LineSpacings [get]

Gets the available line spacings.

int Level9::Config::ImageScaling [get, set]

Gets or sets the selected image scaling factor.

int [] Level9::Config::ImageScalings [get]

Gets the available image scaling factors for line drawn and bitmap graphics.

bool Level9::Config::ScriptIncludeComments [get, set]

Gets or sets a value that indicates whether or not Level9.Net scripts include comments.

bool Level9::Config::ScriptOneEntryPerLine [get, set]

Gets or sets a value that indicates whether Level9.Net scripts contain one or multiple entries per line.

int Level9::Config::ScriptInputDelay [get, set]

Gets or sets the input delay for script playback (seconds).

int [] Level9::Config::ScriptInputDelays [get]

Gets the available script playback delays.

string [] Level9::Config::RecentFiles [get, set]

Gets or sets the list of 'recent files' in the main menu.

bool Level9::Config::LoggingEnabled [static, get, set]

Gets or sets a value that indicates whether logging is enabled or disabled.

Event Documentation

ConfigChangedEventHandler Level9::Config::ConfigChanged

Occurs when the configuration has changed.


Level9.Net: Member List

  • Config
Level9::Config Member List
This is the complete list of members for Level9::Config, including all inherited members.
AddToRecentFiles(string file) | Level9::Config | [inline]
amigaPalette | Level9::Config | [private]
AmigaPalette | Level9::Config |
ANTLR_DLL | Level9::Config |
backColor | Level9::Config | [private]
BackColor | Level9::Config |
barBackColor | Level9::Config | [private]
BarBackColor | Level9::Config |
barTextColor | Level9::Config | [private]
BarTextColor | Level9::Config |
ClientSize | Level9::Config |
clientSize | Level9::Config | [private]
Config() | Level9::Config | [inline, private]
ConfigChanged | Level9::Config |
dictViewerSize | Level9::Config | [private]
DictViewerSize | Level9::Config |
FireConfigChanged() | Level9::Config | [inline]
font | Level9::Config | [private]
Font | Level9::Config |
fontScaling | Level9::Config | [private]
FontScaling | Level9::Config |
GetActivePalette() | Level9::Config | [inline]
GetAntlrPath() | Level9::Config | [inline, static]
GetAppDataPath() | Level9::Config | [inline, static]
GetConfigFilePath() | Level9::Config | [inline, static]
GetHelpFilePath() | Level9::Config | [inline, static]
GetL9CutPath() | Level9::Config | [inline, static]
GetLevel9DLLPath() | Level9::Config | [inline, static]
GetLogFilePath() | Level9::Config | [inline, static]
HELP_FILE | Level9::Config |
imageScaling | Level9::Config | [private]
ImageScaling | Level9::Config |
ImageScalings | Level9::Config |
imageScalings | Level9::Config | [private]
inputColor | Level9::Config | [private]
InputColor | Level9::Config |
instance | Level9::Config | [private, static]
Instance | Level9::Config | [static]
IsInitialized() | Level9::Config | [inline, static]
L9CUT_EXE | Level9::Config |
LEVEL9_DLL | Level9::Config |
LineSpacing | Level9::Config |
lineSpacing | Level9::Config | [private]
lineSpacings | Level9::Config | [private]
LineSpacings | Level9::Config |
LOG_FILE | Level9::Config |
LoggingEnabled | Level9::Config | [static]
loggingEnabled | Level9::Config | [private, static]
MAX_RECENT_FILES | Level9::Config | [private]
Palette enum name | Level9::Config |
PaletteSelection | Level9::Config |
paletteSelection | Level9::Config | [private]
PROGRAM_NAME | Level9::Config |
PROGRAM_VERSION | Level9::Config |
ReadSettings() | Level9::Config | [inline, private]
RecentFiles | Level9::Config |
recentFiles | Level9::Config | [private]
ScriptEditorSize | Level9::Config |
scriptEditorSize | Level9::Config | [private]
ScriptIncludeComments | Level9::Config |
scriptIncludeComments | Level9::Config | [private]
scriptInputDelay | Level9::Config | [private]
ScriptInputDelay | Level9::Config |
scriptInputDelays | Level9::Config | [private]
ScriptInputDelays | Level9::Config |
ScriptOneEntryPerLine | Level9::Config |
scriptOneEntryPerLine | Level9::Config | [private]
SetMembers(ConfigXML xml) | Level9::Config | [inline, private]
SETTINGS_FILE | Level9::Config |
showScriptPlayback | Level9::Config | [private]
ShowScriptPlayback | Level9::Config |
ShowStatusBar | Level9::Config |
showStatusBar | Level9::Config | [private]
showTimer | Level9::Config | [private]
ShowTimer | Level9::Config |
ShowTitleBar | Level9::Config |
showTitleBar | Level9::Config | [private]
showToolbar | Level9::Config | [private]
ShowToolbar | Level9::Config |
SpectrumPalette | Level9::Config |
spectrumPalette | Level9::Config | [private]
textColor | Level9::Config | [private]
TextColor | Level9::Config |
TextViewerSize | Level9::Config |
textViewerSize | Level9::Config | [private]
userPalette | Level9::Config | [private]
UserPalette | Level9::Config |
WriteSettings() | Level9::Config | [inline]


Level9.Net: Level9::ConfigChangedEventArgs Class Reference

  • ConfigChangedEventArgs
Public Member Functions
Level9::ConfigChangedEventArgs Class Reference

Provides data for the ConfigChanged event. More...

List of all members.

Public Member Functions

ConfigChangedEventArgs ()

Detailed Description

Constructor & Destructor Documentation

Level9::ConfigChangedEventArgs::ConfigChangedEventArgs ( ) [inline]

Initializes a new instance of the ConfigChangedEventArgs class.


Level9.Net: Member List

  • ConfigChangedEventArgs
Level9::ConfigChangedEventArgs Member List
This is the complete list of members for Level9::ConfigChangedEventArgs, including all inherited members.
ConfigChangedEventArgs() Level9::ConfigChangedEventArgs [inline]


Level9.Net: Level9::ConfigForm Class Reference

  • ConfigForm
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes
Level9::ConfigForm Class Reference

Configuration dialog for colors, fonts and graphics. More...

Collaboration diagram for Level9::ConfigForm:
[legend]

List of all members.

Public Member Functions

ConfigForm ()

Protected Member Functions

override void | Dispose (bool disposing)

Private Member Functions

void | SimpleListViewButtonClicked (object sender, ListViewItemClickedEventArgs e)
void | ButtonOKClick (object sender, EventArgs e)
void | ButtonCancelClick (object sender, EventArgs e)
void | LabelTextColorPreviewClick (object sender, EventArgs e)
void | ComboBoxFontTypeSelectedIndexChanged (object sender, EventArgs e)
void | DomainUpDownFontScalingSelectedItemChanged (object sender, EventArgs e)
void | DomainUpDownLineSpacingSelectedItemChanged (object sender, EventArgs e)
void | LabelUserColorClick (object sender, EventArgs e)
void | SetConfigurationValues ()
void | StoreConfig ()
void | InitializeComponent ()

Private Attributes

SimpleListViewItem listViewButtonFont
SimpleListViewItem listViewButtonGraphics
SimpleListViewItem listViewButtonColors
System.ComponentModel.IContainer | components = null

Detailed Description

Constructor & Destructor Documentation

Level9::ConfigForm::ConfigForm ( ) [inline]

Initializes a new instance of the ConfigForm class.

Member Function Documentation

void Level9::ConfigForm::SimpleListViewButtonClicked | ( | object | sender,
 |  | ListViewItemClickedEventArgs | e
 | ) |  | [inline, private]

Invoked when a button has been pressed on the list view.

Parameters:
sender | the object that originated the event
e | a ListViewButtonClickedEventArgs that contains the event data
void Level9::ConfigForm::ButtonOKClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'OK' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ConfigForm::ButtonCancelClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Cancel' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ConfigForm::LabelTextColorPreviewClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when a text color has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ConfigForm::ComboBoxFontTypeSelectedIndexChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when a font type has been selected.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ConfigForm::DomainUpDownFontScalingSelectedItemChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the font scaling factor has been changed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ConfigForm::DomainUpDownLineSpacingSelectedItemChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the line spacing has been changed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ConfigForm::LabelUserColorClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when a user defined color for line drawn graphics has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ConfigForm::SetConfigurationValues ( ) [inline, private]

Imports configuration values from a Config instance.

void Level9::ConfigForm::StoreConfig ( ) [inline, private]

Sets the configuration values of a Config instance according to the dialog settings.

override void Level9::ConfigForm::Dispose ( bool disposing ) [inline, protected]

Disposes resources used by the form.

Parameters:
disposing true if managed resources should be disposed; otherwise, false.
void Level9::ConfigForm::InitializeComponent ( ) [inline, private]

This method is required for Windows Forms designer support. Do not change the method contents inside the source code editor. The Forms designer might not be able to load this method if it was changed manually.

Member Data Documentation

SimpleListViewItem Level9::ConfigForm::listViewButtonFont [private]

A list view button for the 'Font' configuration.

SimpleListViewItem Level9::ConfigForm::listViewButtonGraphics [private]

A list view button for the 'Graphics' configuration.

SimpleListViewItem Level9::ConfigForm::listViewButtonColors [private]

A list view button for the 'Colors' configuration.

System.ComponentModel.IContainer Level9::ConfigForm::components = null [private]

Designer variable used to keep track of non-visual components.


Level9.Net: Member List

  • ConfigForm
Level9::ConfigForm Member List
This is the complete list of members for Level9::ConfigForm, including all inherited members.
ButtonCancelClick(object sender, EventArgs e) | Level9::ConfigForm | [inline, private]
ButtonOKClick(object sender, EventArgs e) | Level9::ConfigForm | [inline, private]
ComboBoxFontTypeSelectedIndexChanged(object sender, EventArgs e) | Level9::ConfigForm | [inline, private]
components | Level9::ConfigForm | [private]
ConfigForm() | Level9::ConfigForm | [inline]
Dispose(bool disposing) | Level9::ConfigForm | [inline, protected]
DomainUpDownFontScalingSelectedItemChanged(object sender, EventArgs e) | Level9::ConfigForm | [inline, private]
DomainUpDownLineSpacingSelectedItemChanged(object sender, EventArgs e) | Level9::ConfigForm | [inline, private]
InitializeComponent() | Level9::ConfigForm | [inline, private]
LabelTextColorPreviewClick(object sender, EventArgs e) | Level9::ConfigForm | [inline, private]
LabelUserColorClick(object sender, EventArgs e) | Level9::ConfigForm | [inline, private]
listViewButtonColors | Level9::ConfigForm | [private]
listViewButtonFont | Level9::ConfigForm | [private]
listViewButtonGraphics | Level9::ConfigForm | [private]
SetConfigurationValues() | Level9::ConfigForm | [inline, private]
SimpleListViewButtonClicked(object sender, ListViewItemClickedEventArgs e) | Level9::ConfigForm | [inline, private]
StoreConfig() | Level9::ConfigForm | [inline, private]


Level9.Net: Level9::ConfigXML Class Reference

  • ConfigXML
Public Member Functions | Public Attributes
Level9::ConfigXML Class Reference

Allows XML serialization of miscellaneous configuration options. More...

List of all members.

Public Member Functions

ConfigXML ()
ConfigXML (Config config)

Public Attributes

int | client_width
int | client_height
int | script_editor_width
int | script_editor_height
int | text_viewer_width
int | text_viewer_height
int | dict_viewer_width
int | dict_viewer_height
bool | show_toolbar
bool | show_status_bar
bool | show_script_playback
bool | show_timer
bool | show_title_bar
int | back_color
int | text_color
int | input_color
int | bar_text_color
int | bar_back_color
int[] | user_palette
string | font_type
int | font_scaling
int | line_spacing
int | image_scaling
int | palette_selection
string[] | recent_files
bool | script_include_comments
bool | script_one_entry_per_line
int | script_input_delay

Detailed Description

Constructor & Destructor Documentation

Level9::ConfigXML::ConfigXML ( ) [inline]

Parameterless constructor for serialization.

Level9::ConfigXML::ConfigXML ( Config config ) [inline]

Initializes a new instance of the ConfigXML class.

Parameters:
config a Config instance

Member Data Documentation

int Level9::ConfigXML::client_width

See Config.clientSize.

int Level9::ConfigXML::client_height

See Config.clientSize.

int Level9::ConfigXML::script_editor_width

See Config.scriptEditorSize.

int Level9::ConfigXML::script_editor_height

See Config.scriptEditorSize.

int Level9::ConfigXML::text_viewer_width

See Config.textViewerSize.

int Level9::ConfigXML::text_viewer_height

See Config.textViewerSize.

int Level9::ConfigXML::dict_viewer_width

See Config.dictViewerSize.

int Level9::ConfigXML::dict_viewer_height

See Config.dictViewerSize.

bool Level9::ConfigXML::show_toolbar

See Config.showToolbar.

bool Level9::ConfigXML::show_status_bar

See Config.showStatusBar.

bool Level9::ConfigXML::show_script_playback

See Config.showScriptPlayback.

bool Level9::ConfigXML::show_timer

See Config.showTimer.

bool Level9::ConfigXML::show_title_bar

See Config.showTitleBar.

int Level9::ConfigXML::back_color

See Config.backColor.

int Level9::ConfigXML::text_color

See Config.textColor.

int Level9::ConfigXML::input_color

See Config.inputColor.

int Level9::ConfigXML::bar_text_color

See Config.barTextColor.

int Level9::ConfigXML::bar_back_color

See Config.barBackColor.

int [] Level9::ConfigXML::user_palette

See Config.userPalette.

string Level9::ConfigXML::font_type

See Config.font.

int Level9::ConfigXML::font_scaling

See Config.fontScaling.

int Level9::ConfigXML::line_spacing

See Config.lineSpacing.

int Level9::ConfigXML::image_scaling

See Config.imageScaling.

int Level9::ConfigXML::palette_selection

See Config.paletteSelection.

string [] Level9::ConfigXML::recent_files

See Config.recentFiles.

bool Level9::ConfigXML::script_include_comments

See Config.scriptIncludeComments.

bool Level9::ConfigXML::script_one_entry_per_line

See Config.scriptOneEntryPerLine.

int Level9::ConfigXML::script_input_delay

See Config.scriptInputDelay.


Level9.Net: Member List

  • ConfigXML
Level9::ConfigXML Member List
This is the complete list of members for Level9::ConfigXML, including all inherited members.
back_color | Level9::ConfigXML |
bar_back_color | Level9::ConfigXML |
bar_text_color | Level9::ConfigXML |
client_height | Level9::ConfigXML |
client_width | Level9::ConfigXML |
ConfigXML() | Level9::ConfigXML | [inline]
ConfigXML(Config config) | Level9::ConfigXML | [inline]
dict_viewer_height | Level9::ConfigXML |
dict_viewer_width | Level9::ConfigXML |
font_scaling | Level9::ConfigXML |
font_type | Level9::ConfigXML |
image_scaling | Level9::ConfigXML |
input_color | Level9::ConfigXML |
line_spacing | Level9::ConfigXML |
palette_selection | Level9::ConfigXML |
recent_files | Level9::ConfigXML |
script_editor_height | Level9::ConfigXML |
script_editor_width | Level9::ConfigXML |
script_include_comments | Level9::ConfigXML |
script_input_delay | Level9::ConfigXML |
script_one_entry_per_line | Level9::ConfigXML |
show_script_playback | Level9::ConfigXML |
show_status_bar | Level9::ConfigXML |
show_timer | Level9::ConfigXML |
show_title_bar | Level9::ConfigXML |
show_toolbar | Level9::ConfigXML |
text_color | Level9::ConfigXML |
text_viewer_height | Level9::ConfigXML |
text_viewer_width | Level9::ConfigXML |
user_palette | Level9::ConfigXML |


Level9.Net: Level9::Dictionary Class Reference

  • Dictionary
Public Member Functions | Properties | Private Member Functions | Private Attributes | Static Private Attributes
Level9::Dictionary Class Reference

Handles dictionaries of Level 9 games. More...

Collaboration diagram for Level9::Dictionary:
[legend]

List of all members.

Public Member Functions

void | Add (string words)
void | Show (IWin32Window owner)

Properties

static Dictionary | Instance [get]

Private Member Functions

Dictionary ()
void | InterpreterNewGameFile (NewGameFileEventArgs e)
string | CreateOutput ()

Private Attributes

Dictionary< char, ArrayList > | dictionary
char[] | keys
bool | empty = true
char[] | split = new char[] {' ', '\r', '\n'}
string | output = null
TextForm | dictionaryView = null

Static Private Attributes

static Dictionary | instance = null

Detailed Description

Constructor & Destructor Documentation

Level9::Dictionary::Dictionary ( ) [inline, private]

Initializes a new instance of the Dictionary class.

Member Function Documentation

void Level9::Dictionary::InterpreterNewGameFile ( NewGameFileEventArgs e ) [inline, private]

Invoked when a new game file has been loaded.

Parameters:
e a NewGameFileEventArgs that contains the event data
void Level9::Dictionary::Add ( string words ) [inline]

Imports dictionary entries from the given string.

Parameters:
words a string with dictionary entries
void Level9::Dictionary::Show ( IWin32Window owner ) [inline]

Initiates the dictionary import, displays a progress form and opens a text viewer for dictionary examination.

Parameters:
owner the dialog owner window to be set for the text viewer
string Level9::Dictionary::CreateOutput ( ) [inline, private]

Creates a string representation of the dictionary.

Returns:
a string representation of the dictionary

Member Data Documentation

Dictionary Level9::Dictionary::instance = null [static, private]

The one and only Dictionary instance (singleton).

Dictionary<char, ArrayList> Level9::Dictionary::dictionary [private]

The dictionary hash table (one bucket per character).

char [] Level9::Dictionary::keys [private]
Initial value:
                {
                        '0', '1', '2', '3', '4', '5', '6', '7', '8', '9',
                        'a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i', 'j', 'k', 'l', 'm',
                        'n', 'o', 'p', 'q', 'r', 's', 't', 'u', 'v', 'w', 'x', 'y', 'z'
                }

The dictionary hash table keys.

bool Level9::Dictionary::empty = true [private]

This property indicates whether the dictionary has no entries.

char [] Level9::Dictionary::split = new char[] {' ', '\r', '\n'} [private]

The split characters for strings containing dictionary entries.

string Level9::Dictionary::output = null [private]

The Dictionary representation as a string.

TextForm Level9::Dictionary::dictionaryView = null [private]

The text viewer component that displays the dictionary.

Property Documentation

Dictionary Level9::Dictionary::Instance [static, get]

Gets the one and only Dictionary instance (singleton).


Level9.Net: Member List

  • Dictionary
Level9::Dictionary Member List
This is the complete list of members for Level9::Dictionary, including all inherited members.
Add(string words) | Level9::Dictionary | [inline]
CreateOutput() | Level9::Dictionary | [inline, private]
dictionary | Level9::Dictionary | [private]
Dictionary() | Level9::Dictionary | [inline, private]
dictionaryView | Level9::Dictionary | [private]
empty | Level9::Dictionary | [private]
instance | Level9::Dictionary | [private, static]
Instance | Level9::Dictionary | [static]
InterpreterNewGameFile(NewGameFileEventArgs e) | Level9::Dictionary | [inline, private]
keys | Level9::Dictionary | [private]
output | Level9::Dictionary | [private]
Show(IWin32Window owner) | Level9::Dictionary | [inline]
split | Level9::Dictionary | [private]


Level9.Net: Level9::DictionaryProgressForm Class Reference

  • DictionaryProgressForm
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes
Level9::DictionaryProgressForm Class Reference

Displays a progress bar while reading the dictionary of a Level 9 game. More...

List of all members.

Public Member Functions

DictionaryProgressForm ()

Public Attributes

const int | WATCHDOG_TIMEOUT = 20000

Protected Member Functions

override void | Dispose (bool disposing)

Private Member Functions

void | InterpreterOsFlush (OsFlushEventArgs e)
void | WatchdogTimerTick (Object sender, EventArgs e)
void | InitializeComponent ()

Private Attributes

System.Windows.Forms.Timer | watchdogTimer
OsFlushEventHandler | osFlushHandler
System.ComponentModel.IContainer | components = null

Detailed Description

Constructor & Destructor Documentation

Level9::DictionaryProgressForm::DictionaryProgressForm ( ) [inline]

Initializes a new instance of the DictionaryProgressForm class.

Member Function Documentation

void Level9::DictionaryProgressForm::InterpreterOsFlush ( OsFlushEventArgs e ) [inline, private]

Invoked when the interpreter flushes a portion of text.

Parameters:
e an OsFlushEventArgs that contains the event data
void Level9::DictionaryProgressForm::WatchdogTimerTick | ( | Object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when a watchdog timer interval has expired.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
override void Level9::DictionaryProgressForm::Dispose ( bool disposing ) [inline, protected]

Disposes resources used by the form.

Parameters:
disposing true if managed resources should be disposed; otherwise, false.
void Level9::DictionaryProgressForm::InitializeComponent ( ) [inline, private]

This method is required for Windows Forms designer support. Do not change the method contents inside the source code editor. The Forms designer might not be able to load this method if it was changed manually.

Member Data Documentation

const int Level9::DictionaryProgressForm::WATCHDOG_TIMEOUT = 20000

The maximum time for a dictionary import in milliseconds.

System.Windows.Forms.Timer Level9::DictionaryProgressForm::watchdogTimer [private]
Initial value:
                        new System.Windows.Forms.Timer()

A watchdog timer to control the dictionary import.

OsFlushEventHandler Level9::DictionaryProgressForm::osFlushHandler [private]

A handler for OsFlush events raised by the interpreter.

System.ComponentModel.IContainer Level9::DictionaryProgressForm::components = null [private]

Designer variable used to keep track of non-visual components.


Level9.Net: Member List

  • DictionaryProgressForm
Level9::DictionaryProgressForm Member List
This is the complete list of members for Level9::DictionaryProgressForm, including all inherited members.
components | Level9::DictionaryProgressForm | [private]
DictionaryProgressForm() | Level9::DictionaryProgressForm | [inline]
Dispose(bool disposing) | Level9::DictionaryProgressForm | [inline, protected]
InitializeComponent() | Level9::DictionaryProgressForm | [inline, private]
InterpreterOsFlush(OsFlushEventArgs e) | Level9::DictionaryProgressForm | [inline, private]
osFlushHandler | Level9::DictionaryProgressForm | [private]
WATCHDOG_TIMEOUT | Level9::DictionaryProgressForm |
watchdogTimer | Level9::DictionaryProgressForm | [private]
WatchdogTimerTick(Object sender, EventArgs e) | Level9::DictionaryProgressForm | [inline, private]


Level9.Net: Level9::ErrorHandler Class Reference

  • ErrorHandler
Static Public Member Functions
Level9::ErrorHandler Class Reference

Error handler for Level9.Net. Displays error messages and appends error information to the application log file. More...

List of all members.

Static Public Member Functions

static void | Handle (Type type, string message, Exception e)
static void | Handle (Object obj, string message, Exception e)
static void | Handle (Type type, string message)
static void | Handle (Object obj, string message)

Detailed Description

Member Function Documentation

static void Level9::ErrorHandler::Handle | ( | Type | type,
 |  | string | message,
 |  | Exception | e
 | ) |  | [inline, static]

Displays an error message and appends a log message to the application logfile.

Parameters:
type | the object type that raises the error
message | a log message
e | an Exception, or null if none occurred
static void Level9::ErrorHandler::Handle | ( | Object | obj,
 |  | string | message,
 |  | Exception | e
 | ) |  | [inline, static]

Displays an error message and appends a log message to the application logfile.

Parameters:
obj | the object that raises the error
message | a log message
e | an Exception, or null if none occurred
static void Level9::ErrorHandler::Handle | ( | Type | type,
 |  | string | message
 | ) |  | [inline, static]

Displays an error message and appends a log message to the application logfile.

Parameters:
type | the object type that raises the error
message | a log message
static void Level9::ErrorHandler::Handle | ( | Object | obj,
 |  | string | message
 | ) |  | [inline, static]

Displays an error message and appends a log message to the application logfile.

Parameters:
obj | the object that raises the error
message | a log message


Level9.Net: Member List

  • ErrorHandler
Level9::ErrorHandler Member List
This is the complete list of members for Level9::ErrorHandler, including all inherited members.
Handle(Type type, string message, Exception e) | Level9::ErrorHandler | [inline, static]
Handle(Object obj, string message, Exception e) | Level9::ErrorHandler | [inline, static]
Handle(Type type, string message) | Level9::ErrorHandler | [inline, static]
Handle(Object obj, string message) | Level9::ErrorHandler | [inline, static]


Level9.Net: Level9::FileUtils Class Reference

  • FileUtils
Static Public Member Functions | Static Private Member Functions | Private Attributes
Level9::FileUtils Class Reference

Utilities for file handling. More...

List of all members.

Static Public Member Functions

static string | OFDGameFiles (string title)
static string | OFDSavedGameFiles (string title)
static string | OFDTextFiles (string title)
static string | OFDDataFiles (string title)
static string | SFDSavedGameFiles (string title)
static string | SFDDataFiles (string title)
static string | SFDTextFiles (string title)
static string | SFDPngFiles (string title)

Static Private Member Functions

static string | GetOpenFile (string title, string filter)
static string | GetSaveFile (string title, string filter)

Private Attributes

const string | FILTER_DATA_FILES = "|Level 9 Data Files (*.dat)|*.dat"
const string | FILTER_GAME_FILES = "|Level 9 Game Files (*.dat; *.sna)|*.dat; *.sna"
const string | FILTER_SAVED_GAME_FILES = "Saved Game Files (*.sav)|*.sav|All Files (*.*)|*.*"
const string | FILTER_TXT_FILES = "|All Files (*.*)|*.*"
const string | FILTER_PNG_FILES = "|All Files (*.*)|*.*"

Detailed Description

Member Function Documentation

static string Level9::FileUtils::OFDGameFiles ( string title ) [inline, static]

Displays a Open File dialog for Level 9 game files.

Parameters:
title the dialog title
Returns:
the selected filename, or null
static string Level9::FileUtils::OFDSavedGameFiles ( string title ) [inline, static]

Displays a Open File dialog for saved game files.

Parameters:
title the dialog title
Returns:
the selected filename, or null
static string Level9::FileUtils::OFDTextFiles ( string title ) [inline, static]

Displays a Open File dialog for saved game files.

Parameters:
title the dialog title
Returns:
the selected filename, or null
static string Level9::FileUtils::OFDDataFiles ( string title ) [inline, static]

Displays a Open File dialog for Level 9 datafiles.

Parameters:
title the dialog title
Returns:
the selected filename, or null
static string Level9::FileUtils::SFDSavedGameFiles ( string title ) [inline, static]

Displays a Save File dialog for saved game files.

Parameters:
title the dialog title
Returns:
the selected filename, or null
static string Level9::FileUtils::SFDDataFiles ( string title ) [inline, static]

Displays a Save File dialog for Level 9 datafiles.

Parameters:
title the dialog title
Returns:
the selected filename, or null
static string Level9::FileUtils::SFDTextFiles ( string title ) [inline, static]

Displays a Save File dialog for text files.

Parameters:
title the dialog title
Returns:
the selected filename, or null
static string Level9::FileUtils::SFDPngFiles ( string title ) [inline, static]

Displays a Save File dialog for PNG files.

Parameters:
title the dialog title
Returns:
the selected filename, or null
static string Level9::FileUtils::GetOpenFile | ( | string | title,
 |  | string | filter
 | ) |  | [inline, static, private]

Displays a Open File dialog with the given title and filter.

Parameters:
title | the dialog title
filter | a file dialog filter
Returns:
the selected filename, or null
static string Level9::FileUtils::GetSaveFile | ( | string | title,
 |  | string | filter
 | ) |  | [inline, static, private]

Displays a Save File dialog with the given title and filter.

Parameters:
title | the dialog title
filter | a file dialog filter
Returns:
the selected filename, or null

Member Data Documentation

const string Level9::FileUtils::FILTER_DATA_FILES = "|Level 9 Data Files (*.dat)|*.dat" [private]

A file dialog filter for Level 9 data files.

const string Level9::FileUtils::FILTER_GAME_FILES = "|Level 9 Game Files (*.dat; *.sna)|*.dat; *.sna" [private]

A file dialog filter for Level 9 game files.

const string Level9::FileUtils::FILTER_SAVED_GAME_FILES = "Saved Game Files (*.sav)|*.sav|All Files (*.*)|*.*" [private]

A dialog filter for saved game files.

const string Level9::FileUtils::FILTER_TXT_FILES = "|All Files (*.*)|*.*" [private]

A file dialog filter for text files.

const string Level9::FileUtils::FILTER_PNG_FILES = "|All Files (*.*)|*.*" [private]

A file dialog filter for PNG files.


Level9.Net: Member List

  • FileUtils
Level9::FileUtils Member List
This is the complete list of members for Level9::FileUtils, including all inherited members.
FILTER_DATA_FILES | Level9::FileUtils | [private]
FILTER_GAME_FILES | Level9::FileUtils | [private]
FILTER_PNG_FILES | Level9::FileUtils | [private]
FILTER_SAVED_GAME_FILES | Level9::FileUtils | [private]
FILTER_TXT_FILES | Level9::FileUtils | [private]
GetOpenFile(string title, string filter) | Level9::FileUtils | [inline, private, static]
GetSaveFile(string title, string filter) | Level9::FileUtils | [inline, private, static]
OFDDataFiles(string title) | Level9::FileUtils | [inline, static]
OFDGameFiles(string title) | Level9::FileUtils | [inline, static]
OFDSavedGameFiles(string title) | Level9::FileUtils | [inline, static]
OFDTextFiles(string title) | Level9::FileUtils | [inline, static]
SFDDataFiles(string title) | Level9::FileUtils | [inline, static]
SFDPngFiles(string title) | Level9::FileUtils | [inline, static]
SFDSavedGameFiles(string title) | Level9::FileUtils | [inline, static]
SFDTextFiles(string title) | Level9::FileUtils | [inline, static]


Level9.Net: Level9::GameFileErrorEventArgs Class Reference

  • GameFileErrorEventArgs
Public Member Functions
Level9::GameFileErrorEventArgs Class Reference

Provides data for the GameFileError event. More...

List of all members.

Public Member Functions

GameFileErrorEventArgs ()

Detailed Description

Constructor & Destructor Documentation

Level9::GameFileErrorEventArgs::GameFileErrorEventArgs ( ) [inline]

Initializes a new instance of the GameFileErrorEventArgs class.


Level9.Net: Member List

  • GameFileErrorEventArgs
Level9::GameFileErrorEventArgs Member List
This is the complete list of members for Level9::GameFileErrorEventArgs, including all inherited members.
GameFileErrorEventArgs() Level9::GameFileErrorEventArgs [inline]


Level9.Net: Level9::GameGraphics Class Reference

  • GameGraphics
Public Types | Public Member Functions | Events | Private Member Functions | Private Attributes
Level9::GameGraphics Class Reference

Handles line drawn and bitmap graphics in a Level 9 game. More...

List of all members.

Public Types

enum | GraphicsMode { None = 0, LineDrawn = 1, Bitmap = 2 }

Public Member Functions

GameGraphics ()

Events

PictureCreatedEventHandler | PictureCreated
GraphicsOffEventHandler | GraphicsOff

Private Member Functions

void | InterpreterOsInput (OsInputEventArgs e)
void | InterpreterOsReadchar (OsReadcharEventArgs e)
void | InterpreterOsGraphics (OsGraphicsEventArgs e)
void | InterpreterOsClearGraphics (OsClearGraphicsEventArgs e)
void | InterpreterOsSetColour (OsSetColourEventArgs e)
void | InterpreterOsDrawLine (OsDrawLineEventArgs e)
void | InterpreterOsFill (OsFillEventArgs e)
void | InterpreterOsShowBitmap (OsShowBitmapEventArgs e)
void | InterpreterNewGameFile (NewGameFileEventArgs e)
void | ApplicationExit (object sender, EventArgs e)
void | ConfigChanged (ConfigChangedEventArgs e)
void | DrawingThreadProc ()
void | StartDrawingThread ()
void | StopDrawingThread ()
unsafe Bitmap | CreateBitmapImage (int number)
unsafe Bitmap | CreateLineDrawnImage ()
unsafe Bitmap | ScaleBitmap (byte *data, int width, int height)
void | DrawLineIf (int x1, int y1, int x2, int y2, byte colour1, byte colour2)
void | FloodFillIf (int x, int y, byte colour1, byte colour2)

Private Attributes

GraphicsMode | graphicsMode = GraphicsMode.None
Thread | drawingThread = null
bool | threadStopSignal = false
Size | pictureSize
byte[] | pixels = new byte[0]
int[] | palette = new int[8]
bool | showTitle = false
bool | bitmapsDetected = false
int | bitmapNumber = -1

Detailed Description

Member Enumeration Documentation

enum Level9::GameGraphics::GraphicsMode

The available graphics modes.

Enumerator:
None

No graphics.

LineDrawn

Line drawn graphics.

Bitmap

Bitmap graphics.

Constructor & Destructor Documentation

Level9::GameGraphics::GameGraphics ( ) [inline]

Initializes a new instance of the GameGraphics class.

Member Function Documentation

void Level9::GameGraphics::InterpreterOsInput ( OsInputEventArgs e ) [inline, private]

Invoked when a running game waits for user input.

Parameters:
e an OsInputEventArgs that contains the event data
void Level9::GameGraphics::InterpreterOsReadchar ( OsReadcharEventArgs e ) [inline, private]

Invoked when a running game waits for a key press.

Parameters:
e an OsInputEventArgs that contains the event data
void Level9::GameGraphics::InterpreterOsGraphics ( OsGraphicsEventArgs e ) [inline, private]

Invoked when graphics are turned on or off in a running game.

Parameters:
e an OsGraphicsEventArgs that contains the event data
void Level9::GameGraphics::InterpreterOsClearGraphics ( OsClearGraphicsEventArgs e ) [inline, private]

Invoked when the graphics area must be cleared in a running game.

Parameters:
e an OsClearGraphicsEventArgs that contains the event data
void Level9::GameGraphics::InterpreterOsSetColour ( OsSetColourEventArgs e ) [inline, private]

Invoked when a palette color must be set in a running game.

Parameters:
e an OsSetColourEventArgs that contains the event data
void Level9::GameGraphics::InterpreterOsDrawLine ( OsDrawLineEventArgs e ) [inline, private]

Invoked when a line must be drawn in a running game.

Parameters:
e an OsDrawLineEventArgs that contains the event data
void Level9::GameGraphics::InterpreterOsFill ( OsFillEventArgs e ) [inline, private]

Invoked when an area must be filled in a running game.

Parameters:
e an OsFillEventArgs that contains the event data
void Level9::GameGraphics::InterpreterOsShowBitmap ( OsShowBitmapEventArgs e ) [inline, private]

Invoked when a bitmap must be displayed in a running game.

Parameters:
e an OsShowBitmapEventArgs that contains the event data
void Level9::GameGraphics::InterpreterNewGameFile ( NewGameFileEventArgs e ) [inline, private]

Invoked when a new game has been loaded.

Parameters:
e a NewGameFileEventArgs that contains the event data
void Level9::GameGraphics::ApplicationExit | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the application exits.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::GameGraphics::ConfigChanged ( ConfigChangedEventArgs e ) [inline, private]

Invoked when the configuration has been changed.

Parameters:
e a ConfigChangedEventArgs that contains the event data
void Level9::GameGraphics::DrawingThreadProc ( ) [inline, private]

The thread procedure for line drawn graphics. Executes graphics opcodes and notifies the listeners when a picture is ready for display.

void Level9::GameGraphics::StartDrawingThread ( ) [inline, private]

Starts a drawing thread in line drawn graphics mode.

void Level9::GameGraphics::StopDrawingThread ( ) [inline, private]

Stops a drawing thread in line drawn graphics mode.

unsafe Bitmap Level9::GameGraphics::CreateBitmapImage ( int number ) [inline, private]

Creates a scaled bitmap image for the given number.

Parameters:
number the bitmap number
Returns:
the bitmap, or null if an error occurred
unsafe Bitmap Level9::GameGraphics::CreateLineDrawnImage ( ) [inline, private]

Creates a scaled bitmap from the pixels buffer.

Returns:
the bitmap, or null if an error occurred
unsafe Bitmap Level9::GameGraphics::ScaleBitmap | ( | byte * | data,
 |  | int | width,
 |  | int | height
 | ) |  | [inline, private]

Scales a bitmap according to the configuration settings.

Parameters:
data | the bitmap data
width | the bitmap's width
height | the bitmap's height
Returns:
void Level9::GameGraphics::DrawLineIf | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | byte | colour1,
 |  | byte | colour2
 | ) |  | [inline, private]

Draw a line on the graphics bitmap between (x1,y1) and (x2,y2). Note that either point may lie outside of the bitmap, and that it is the responsibility of the routine to clip to the appropriate coordinates. For each point on the line, if the colour at that point is equal to colour2 the pixel's colour should be changed to colour1, else it should not be modified.

Parameters:
x1 | the x coordinate of (x1,y1)
y1 | the y coordinate of (x1,y1)
x2 | the x coordinate of (x2,y2)
y2 | the y coordinate of (x2,y2)
colour1 | the index of colour 1
colour2 | the index of colour 2
void Level9::GameGraphics::FloodFillIf | ( | int | x,
 |  | int | y,
 |  | byte | colour1,
 |  | byte | colour2
 | ) |  | [inline, private]

If the pixel's colour at (x,y) is equal to colour2, fill the region containing (x,y) with colour1. The boundaries of the region are defined as those areas of the bitmap with a colour other than colour2.

Parameters:
x | the x coordinate of pixel (x,y)
y | the y coordinate of pixel (x,y)
colour1 | the index of colour 1
colour2 | the index of colour 2

Member Data Documentation

GraphicsMode Level9::GameGraphics::graphicsMode = GraphicsMode.None [private]

The current graphics mode.

Thread Level9::GameGraphics::drawingThread = null [private]

A background thread for drawing line drawn graphics.

bool Level9::GameGraphics::threadStopSignal = false [private]

This property indicates whether the drawing thread should be stopped.

Size Level9::GameGraphics::pictureSize [private]

The current picture size.

byte [] Level9::GameGraphics::pixels = new byte[0] [private]

A pixel buffer for line drawn graphics.

int [] Level9::GameGraphics::palette = new int[8] [private]

A palette for line drawn graphics. Each entry is an index in the active palette.

bool Level9::GameGraphics::showTitle = false [private]

This property indicates whether the title screen shows up in a game with bitmap graphics.

bool Level9::GameGraphics::bitmapsDetected = false [private]

This property indicates whether bitmaps have been detected in the game directory.

int Level9::GameGraphics::bitmapNumber = -1 [private]

The current image number in bitmap graphics mode.

Event Documentation

PictureCreatedEventHandler Level9::GameGraphics::PictureCreated

Occurs when a picture has been created.

GraphicsOffEventHandler Level9::GameGraphics::GraphicsOff

Occurs when graphics have been turned off.


Level9.Net: Member List

  • GameGraphics
Level9::GameGraphics Member List
This is the complete list of members for Level9::GameGraphics, including all inherited members.
ApplicationExit(object sender, EventArgs e) | Level9::GameGraphics | [inline, private]
bitmapNumber | Level9::GameGraphics | [private]
bitmapsDetected | Level9::GameGraphics | [private]
ConfigChanged(ConfigChangedEventArgs e) | Level9::GameGraphics | [inline, private]
CreateBitmapImage(int number) | Level9::GameGraphics | [inline, private]
CreateLineDrawnImage() | Level9::GameGraphics | [inline, private]
drawingThread | Level9::GameGraphics | [private]
DrawingThreadProc() | Level9::GameGraphics | [inline, private]
DrawLineIf(int x1, int y1, int x2, int y2, byte colour1, byte colour2) | Level9::GameGraphics | [inline, private]
FloodFillIf(int x, int y, byte colour1, byte colour2) | Level9::GameGraphics | [inline, private]
GameGraphics() | Level9::GameGraphics | [inline]
graphicsMode | Level9::GameGraphics | [private]
GraphicsMode enum name | Level9::GameGraphics |
GraphicsOff | Level9::GameGraphics |
InterpreterNewGameFile(NewGameFileEventArgs e) | Level9::GameGraphics | [inline, private]
InterpreterOsClearGraphics(OsClearGraphicsEventArgs e) | Level9::GameGraphics | [inline, private]
InterpreterOsDrawLine(OsDrawLineEventArgs e) | Level9::GameGraphics | [inline, private]
InterpreterOsFill(OsFillEventArgs e) | Level9::GameGraphics | [inline, private]
InterpreterOsGraphics(OsGraphicsEventArgs e) | Level9::GameGraphics | [inline, private]
InterpreterOsInput(OsInputEventArgs e) | Level9::GameGraphics | [inline, private]
InterpreterOsReadchar(OsReadcharEventArgs e) | Level9::GameGraphics | [inline, private]
InterpreterOsSetColour(OsSetColourEventArgs e) | Level9::GameGraphics | [inline, private]
InterpreterOsShowBitmap(OsShowBitmapEventArgs e) | Level9::GameGraphics | [inline, private]
palette | Level9::GameGraphics | [private]
PictureCreated | Level9::GameGraphics |
pictureSize | Level9::GameGraphics | [private]
pixels | Level9::GameGraphics | [private]
ScaleBitmap(byte *data, int width, int height) | Level9::GameGraphics | [inline, private]
showTitle | Level9::GameGraphics | [private]
StartDrawingThread() | Level9::GameGraphics | [inline, private]
StopDrawingThread() | Level9::GameGraphics | [inline, private]
threadStopSignal | Level9::GameGraphics | [private]


Level9.Net: Level9::GamePanel Class Reference

  • GamePanel
Public Member Functions | Protected Member Functions | Events | Private Member Functions | Private Attributes
Level9::GamePanel Class Reference

Displays text and graphics provided by the Level 9 interpreter and handles user interaction. More...

Collaboration diagram for Level9::GamePanel:
[legend]

List of all members.

Public Member Functions

GamePanel ()
void | SimulateKeys (string keys)
void | SimulateKey (char key)
void | ShowScrollback ()
void | SaveScreenshot ()

Protected Member Functions

override void | Dispose (bool disposing)
override void | OnLostFocus (EventArgs e)
override void | OnGotFocus (EventArgs e)
override void | OnKeyDown (KeyEventArgs e)
override void | OnKeyPress (KeyPressEventArgs e)
override void | OnSizeChanged (EventArgs e)
override void | OnPaintBackground (PaintEventArgs e)
override void | OnPaint (PaintEventArgs e)

Events

InputModeEventHandler | InputMode

Private Member Functions

delegate void | FireInputModeEventDelegate (bool active)
void | UpdateScreen (int region)
void | TimerTick (Object sender, EventArgs e)
void | InterpreterOsInput (OsInputEventArgs e)
void | InterpreterOsReadchar (OsReadcharEventArgs e)
void | InterpreterOsFlush (OsFlushEventArgs e)
void | InterpreterNewGameFile (NewGameFileEventArgs e)
void | InterpreterGameFileError (GameFileErrorEventArgs e)
void | GameGraphicsPictureCreated (PictureCreatedEventArgs e)
void | GameGraphicsGraphicsOff (GraphicsOffEventArgs e)
void | ConfigChanged (ConfigChangedEventArgs e)
void | FireInputModeEvent (bool active)
string | GetTimerString ()
string | GetStatusString ()
string | GetClientSizeString ()
string | GetClipboardText ()

Private Attributes

const int | BAR_XY_SPACING = 2
const int | BAR_ELEMENT_SPACING = 10
const int | TEXT_Y_SPACING = 5
const int | TEXT_X_SPACING = 2
const string | TITLE_ERROR = "*ERROR*"
const int | REGION_ALL = 0x001F
const int | REGION_TITLE_BAR = 0x0001
const int | REGION_TIMER = 0x0002
const int | REGION_PICTURE = 0x0004
const int | REGION_TEXT = 0x0008
const int | REGION_STATUS = 0x0010
GameText | gameText = null
GameGraphics | gameGraphics = null
string | title = null
DateTime | gameStart
string | timerString = null
Bitmap | picture = null
System.Windows.Forms.Timer | gameTimer = new System.Windows.Forms.Timer()
OsInputEventArgs | inputArgs = null
OsReadcharEventArgs | readcharArgs = null
InputModeEventArgs | inputModeArgs = null
bool | moreLines = false
bool | inputMode = false
Bitmap | titleBitmap = null
Bitmap | timerBitmap = null
Bitmap | textBitmap = null
Bitmap | statusBitmap = null
Bitmap | sizeBitmap = null
Bitmap | screenBitmap = null
BitmapFontRenderer | titleRenderer = new BitmapFontRenderer()
BitmapFontRenderer | timerRenderer = new BitmapFontRenderer()
BitmapFontRenderer | textRenderer = new BitmapFontRenderer()
BitmapFontRenderer | statusRenderer = new BitmapFontRenderer()
BitmapFontRenderer | sizeRenderer = new BitmapFontRenderer()

Detailed Description

Constructor & Destructor Documentation

Level9::GamePanel::GamePanel ( ) [inline]

Initializes a new instance of the GamePanel class.

Member Function Documentation

delegate void Level9::GamePanel::FireInputModeEventDelegate ( bool active ) [private]

Represents the method that fires an InputMode event.

override void Level9::GamePanel::Dispose ( bool disposing ) [inline, protected]

Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.

Parameters:
disposing true to release both managed and unmanaged resources; false to release only unmanaged resources
override void Level9::GamePanel::OnLostFocus ( EventArgs e ) [inline, protected]

Handles the LostFocus event.

Parameters:
e an EventArgs that contains the event data
override void Level9::GamePanel::OnGotFocus ( EventArgs e ) [inline, protected]

Handles the GotFocus event.

Parameters:
e an EventArgs that contains the event data
override void Level9::GamePanel::OnKeyDown ( KeyEventArgs e ) [inline, protected]

Handles the KeyDown event.

Parameters:
e a KeyEventArgs that contains the event data
override void Level9::GamePanel::OnKeyPress ( KeyPressEventArgs e ) [inline, protected]

Handles the KeyPress event.

Parameters:
e a KeyPressEventArgs that contains the event data
override void Level9::GamePanel::OnSizeChanged ( EventArgs e ) [inline, protected]

Handles the SizeChanged event.

Parameters:
e a EventArgs that contains the event data
override void Level9::GamePanel::OnPaintBackground ( PaintEventArgs e ) [inline, protected]

Handles the PaintBackground event.

Parameters:
e a PaintEventArgs that contains the event data
override void Level9::GamePanel::OnPaint ( PaintEventArgs e ) [inline, protected]

Handles the Paint event.

Parameters:
e a PaintEventArgs that contains the event data
void Level9::GamePanel::UpdateScreen ( int region ) [inline, private]

Updates screen regions.

Parameters:
region the screen region identifier
void Level9::GamePanel::TimerTick | ( | Object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when an interval of the game timer has expired.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::GamePanel::InterpreterOsInput ( OsInputEventArgs e ) [inline, private]

Invoked when a running game waits for user input.

Parameters:
e an OsInputEventArgs that contains the event data
void Level9::GamePanel::InterpreterOsReadchar ( OsReadcharEventArgs e ) [inline, private]

Invoked when a running game waits for a key press.

Parameters:
e an OsInputEventArgs that contains the event data
void Level9::GamePanel::InterpreterOsFlush ( OsFlushEventArgs e ) [inline, private]

Invoked when the interpreter flushes a portion of text.

Parameters:
e an OsFlushEventArgs that contains the event data
void Level9::GamePanel::InterpreterNewGameFile ( NewGameFileEventArgs e ) [inline, private]

Invoked when a new game has been loaded.

Parameters:
e a NewGameFileEventArgs that contains the event data
void Level9::GamePanel::InterpreterGameFileError ( GameFileErrorEventArgs e ) [inline, private]

Invoked when the interpreter detects an error.

Parameters:
e a GameFileErrorEventArgs that contains the event data
void Level9::GamePanel::GameGraphicsPictureCreated ( PictureCreatedEventArgs e ) [inline, private]

Invoked when a picture is ready for display.

Parameters:
e a GameGraphicsPictureCreated that contains the event data
void Level9::GamePanel::GameGraphicsGraphicsOff ( GraphicsOffEventArgs e ) [inline, private]

Invoked when game graphics have been turned off.

Parameters:
e a GraphicsOffEventArgs that contains the event data
void Level9::GamePanel::ConfigChanged ( ConfigChangedEventArgs e ) [inline, private]

Invoked when the configuration has been changed.

Parameters:
e a ConfigChangedEventArgs that contains the event data
void Level9::GamePanel::FireInputModeEvent ( bool active ) [inline, private]

Notifies the input mode event listeners.

Parameters:
active true if the Level 9 interpreter waits for user input, else false
void Level9::GamePanel::SimulateKeys ( string keys ) [inline]

Simulates key presses as if they have been done with the keyboard.

Parameters:
keys the keys to 'press'
void Level9::GamePanel::SimulateKey ( char key ) [inline]

Simulates a key press as if it has been done with the keyboard.

Parameters:
key the key to 'press'
string Level9::GamePanel::GetTimerString ( ) [inline, private]

Provides the timer string.

Returns:
the timer string, or null if no game is running
string Level9::GamePanel::GetStatusString ( ) [inline, private]

Provides the status message string.

Returns:
the status message string
string Level9::GamePanel::GetClientSizeString ( ) [inline, private]

Provides the client size string.

Returns:
the client size string
string Level9::GamePanel::GetClipboardText ( ) [inline, private]

Gets text from the system clipboard.

Returns:
the clipboard text, or null if none exists
void Level9::GamePanel::ShowScrollback ( ) [inline]

Displays the scrollback window.

void Level9::GamePanel::SaveScreenshot ( ) [inline]

Saves a screenshot of the game area.

Member Data Documentation

const int Level9::GamePanel::BAR_XY_SPACING = 2 [private]

The width of the borders around a title bar or status bar.

const int Level9::GamePanel::BAR_ELEMENT_SPACING = 10 [private]

The distance between adjacent elements in the title bar or status bar.

const int Level9::GamePanel::TEXT_Y_SPACING = 5 [private]

The width of the upper and lower borders around a text area.

const int Level9::GamePanel::TEXT_X_SPACING = 2 [private]

The width of the left and right borders around a text area.

const string Level9::GamePanel::TITLE_ERROR = "*ERROR*" [private]

The title info displayed on game file errors.

const int Level9::GamePanel::REGION_ALL = 0x001F [private]

The update region identifier for all regions.

const int Level9::GamePanel::REGION_TITLE_BAR = 0x0001 [private]

The update region identifier for the title bar.

const int Level9::GamePanel::REGION_TIMER = 0x0002 [private]

The update region identifier for the timer.

const int Level9::GamePanel::REGION_PICTURE = 0x0004 [private]

The update region identifier for the picture area.

const int Level9::GamePanel::REGION_TEXT = 0x0008 [private]

The update region identifier for the text area.

const int Level9::GamePanel::REGION_STATUS = 0x0010 [private]

The update region identifier for the status bar.

GameText Level9::GamePanel::gameText = null [private]

A handler for text provided by the Level 9 interpreter.

GameGraphics Level9::GamePanel::gameGraphics = null [private]

A handler for graphics provided by the Level 9 interpreter.

string Level9::GamePanel::title = null [private]

The current game title.

DateTime Level9::GamePanel::gameStart [private]

This property stores the starting time of a new game.

string Level9::GamePanel::timerString = null [private]

A textual representation of the game timer.

Bitmap Level9::GamePanel::picture = null [private]

The currently displayed picture.

System.Windows.Forms.Timer Level9::GamePanel::gameTimer = new System.Windows.Forms.Timer() [private]

A timer to control the in-game time display.

OsInputEventArgs Level9::GamePanel::inputArgs = null [private]

The event data of the last OsInput event.

OsReadcharEventArgs Level9::GamePanel::readcharArgs = null [private]

The event data of the last OsReadchar event.

InputModeEventArgs Level9::GamePanel::inputModeArgs = null [private]

The event data of the last InputMode event.

bool Level9::GamePanel::moreLines = false [private]

This property indicates whether the text area is too small to display all the available lines provided by the Level 9 interpreter.

bool Level9::GamePanel::inputMode = false [private]

This property indicates whether the Level 9 interpreter waits for user input.

Bitmap Level9::GamePanel::titleBitmap = null [private]

A bitmap that contains the rendered game title.

Bitmap Level9::GamePanel::timerBitmap = null [private]

A bitmap that contains the rendered game timer.

Bitmap Level9::GamePanel::textBitmap = null [private]

A bitmap that contains the rendered in-game text.

Bitmap Level9::GamePanel::statusBitmap = null [private]

A bitmap that contains the rendered status information.

Bitmap Level9::GamePanel::sizeBitmap = null [private]

A bitmap that contains the rendered client area size.

Bitmap Level9::GamePanel::screenBitmap = null [private]

A bitmap that contains the client area.

BitmapFontRenderer Level9::GamePanel::titleRenderer = new BitmapFontRenderer() [private]

A renderer that draws the game title with a bitmap font.

BitmapFontRenderer Level9::GamePanel::timerRenderer = new BitmapFontRenderer() [private]

A renderer that draws the game timer with a bitmap font.

BitmapFontRenderer Level9::GamePanel::textRenderer = new BitmapFontRenderer() [private]

A renderer that draws in-game text with a bitmap font.

BitmapFontRenderer Level9::GamePanel::statusRenderer = new BitmapFontRenderer() [private]

A renderer that draws status information with a bitmap font.

BitmapFontRenderer Level9::GamePanel::sizeRenderer = new BitmapFontRenderer() [private]

A renderer that draws the client area size with a bitmap font.

Event Documentation

InputModeEventHandler Level9::GamePanel::InputMode

Occurs when the Level 9 interpreter waits for user input.


Level9.Net: Member List

  • GamePanel
Level9::GamePanel Member List
This is the complete list of members for Level9::GamePanel, including all inherited members.
BAR_ELEMENT_SPACING | Level9::GamePanel | [private]
BAR_XY_SPACING | Level9::GamePanel | [private]
ConfigChanged(ConfigChangedEventArgs e) | Level9::GamePanel | [inline, private]
Dispose(bool disposing) | Level9::GamePanel | [inline, protected]
FireInputModeEvent(bool active) | Level9::GamePanel | [inline, private]
FireInputModeEventDelegate(bool active) | Level9::GamePanel | [private]
gameGraphics | Level9::GamePanel | [private]
GameGraphicsGraphicsOff(GraphicsOffEventArgs e) | Level9::GamePanel | [inline, private]
GameGraphicsPictureCreated(PictureCreatedEventArgs e) | Level9::GamePanel | [inline, private]
GamePanel() | Level9::GamePanel | [inline]
gameStart | Level9::GamePanel | [private]
gameText | Level9::GamePanel | [private]
gameTimer | Level9::GamePanel | [private]
GetClientSizeString() | Level9::GamePanel | [inline, private]
GetClipboardText() | Level9::GamePanel | [inline, private]
GetStatusString() | Level9::GamePanel | [inline, private]
GetTimerString() | Level9::GamePanel | [inline, private]
inputArgs | Level9::GamePanel | [private]
InputMode | Level9::GamePanel |
inputMode | Level9::GamePanel | [private]
inputModeArgs | Level9::GamePanel | [private]
InterpreterGameFileError(GameFileErrorEventArgs e) | Level9::GamePanel | [inline, private]
InterpreterNewGameFile(NewGameFileEventArgs e) | Level9::GamePanel | [inline, private]
InterpreterOsFlush(OsFlushEventArgs e) | Level9::GamePanel | [inline, private]
InterpreterOsInput(OsInputEventArgs e) | Level9::GamePanel | [inline, private]
InterpreterOsReadchar(OsReadcharEventArgs e) | Level9::GamePanel | [inline, private]
moreLines | Level9::GamePanel | [private]
OnGotFocus(EventArgs e) | Level9::GamePanel | [inline, protected]
OnKeyDown(KeyEventArgs e) | Level9::GamePanel | [inline, protected]
OnKeyPress(KeyPressEventArgs e) | Level9::GamePanel | [inline, protected]
OnLostFocus(EventArgs e) | Level9::GamePanel | [inline, protected]
OnPaint(PaintEventArgs e) | Level9::GamePanel | [inline, protected]
OnPaintBackground(PaintEventArgs e) | Level9::GamePanel | [inline, protected]
OnSizeChanged(EventArgs e) | Level9::GamePanel | [inline, protected]
picture | Level9::GamePanel | [private]
readcharArgs | Level9::GamePanel | [private]
REGION_ALL | Level9::GamePanel | [private]
REGION_PICTURE | Level9::GamePanel | [private]
REGION_STATUS | Level9::GamePanel | [private]
REGION_TEXT | Level9::GamePanel | [private]
REGION_TIMER | Level9::GamePanel | [private]
REGION_TITLE_BAR | Level9::GamePanel | [private]
SaveScreenshot() | Level9::GamePanel | [inline]
screenBitmap | Level9::GamePanel | [private]
ShowScrollback() | Level9::GamePanel | [inline]
SimulateKey(char key) | Level9::GamePanel | [inline]
SimulateKeys(string keys) | Level9::GamePanel | [inline]
sizeBitmap | Level9::GamePanel | [private]
sizeRenderer | Level9::GamePanel | [private]
statusBitmap | Level9::GamePanel | [private]
statusRenderer | Level9::GamePanel | [private]
TEXT_X_SPACING | Level9::GamePanel | [private]
TEXT_Y_SPACING | Level9::GamePanel | [private]
textBitmap | Level9::GamePanel | [private]
textRenderer | Level9::GamePanel | [private]
timerBitmap | Level9::GamePanel | [private]
timerRenderer | Level9::GamePanel | [private]
timerString | Level9::GamePanel | [private]
TimerTick(Object sender, EventArgs e) | Level9::GamePanel | [inline, private]
title | Level9::GamePanel | [private]
TITLE_ERROR | Level9::GamePanel | [private]
titleBitmap | Level9::GamePanel | [private]
titleRenderer | Level9::GamePanel | [private]
UpdateScreen(int region) | Level9::GamePanel | [inline, private]


Level9.Net: Level9::GameText Class Reference

  • GameText
Public Member Functions | Properties | Private Member Functions | Private Attributes
Level9::GameText Class Reference

Manages a text buffer and provides methods necessary for text output and shell functionality in a Level 9 game. More...

Collaboration diagram for Level9::GameText:
[legend]

List of all members.

Public Member Functions

GameText ()
void | Append (string text)
List< AttributedText > | GetOutput (int lines, int columns, out bool moreLines, out int changeOffset)
void | SetTextOffset ()
void | SetInputPosition ()
string | GetInput ()
void | CaretIns (char character)
void | CaretIns (string text)
void | CaretHome ()
void | CaretEnd ()
void | CaretRight ()
void | CaretLeft ()
void | CaretDelete ()
void | CaretBack ()
void | HideCaret ()
void | ShowCaret ()
void | HistoryUp ()
void | HistoryDown ()
void | ShowScrollback (IWin32Window parent)
void | Clear ()
int | GetParagraphCount ()
int | GetOutputLinesCount ()

Properties

List< AttributedText > | Paragraphs [get]

Private Member Functions

void | RecallCommand ()
void | ClearCaretInParagraphs ()
void | SetCaretInParagraphs ()

Private Attributes

const int | MAX_COMMANDS_HISTORY = 100
const int | MAX_LENGTH_INPUT = 160
List< AttributedText > | paragraphs = new List<AttributedText>()
List< AttributedText > | output = new List<AttributedText>()
TextPosition | offsetPos = new TextPosition()
TextPosition | caretPos = new TextPosition()
TextPosition | inputPos = new TextPosition()
List< string > | commandHistory = new List<string>()
int | commandHistoryPos = 0
TextForm | scrollbackView = null

Detailed Description

Constructor & Destructor Documentation

Level9::GameText::GameText ( ) [inline]

Initializes a new instance of the GamePanel class.

Member Function Documentation

void Level9::GameText::Append ( string text ) [inline]

Appends text to the list of paragraphs.

Parameters:
text the text to append
List<AttributedText> Level9::GameText::GetOutput | ( | int | lines,
 |  | int | columns,
 |  | out bool | moreLines,
 |  | out int | changeOffset
 | ) |  | [inline]

Provides output lines for the given number of lines and columns.

Parameters:
lines | the number of lines
columns | the number of columns per line
moreLines | true if more lines are avialable, else false
changeOffset | provides the offset at which lines have changed in comparison to the last GetOutput() call.
Returns:
a list of output lines
void Level9::GameText::SetTextOffset ( ) [inline]

Sets the text offset position to the last character in the list of output lines.

void Level9::GameText::SetInputPosition ( ) [inline]

Sets the caret and input position to the last character in the list of paragraphs.

string Level9::GameText::GetInput ( ) [inline]

Provides user input corresponding to the input text position.

Returns:
an input line, or null if the list of paragraphs is empty
void Level9::GameText::CaretIns ( char character ) [inline]

Inserts a character at the caret position.

Parameters:
character the character to insert
void Level9::GameText::CaretIns ( string text ) [inline]

Inserts text at the caret position.

Parameters:
text the text to insert
void Level9::GameText::CaretHome ( ) [inline]

Sets the caret to the home position.

void Level9::GameText::CaretEnd ( ) [inline]

Sets the caret to the end position.

void Level9::GameText::CaretRight ( ) [inline]

Moves the caret right.

void Level9::GameText::CaretLeft ( ) [inline]

Moves the caret left.

void Level9::GameText::CaretDelete ( ) [inline]

Deletes a character at the caret position.

void Level9::GameText::CaretBack ( ) [inline]

Moves the caret left and deletes a character.

void Level9::GameText::HideCaret ( ) [inline]

Hides the caret.

void Level9::GameText::ShowCaret ( ) [inline]

Shows the caret.

void Level9::GameText::HistoryUp ( ) [inline]

Moves backward in the command history.

void Level9::GameText::HistoryDown ( ) [inline]

Moves forward in the command history.

void Level9::GameText::RecallCommand ( ) [inline, private]

Recalls a command in the command history.

void Level9::GameText::ClearCaretInParagraphs ( ) [inline, private]

Removes the caret at the position indicated by caretPos.

void Level9::GameText::SetCaretInParagraphs ( ) [inline, private]

Sets the caret to the position indicated by caretPos.

void Level9::GameText::ShowScrollback ( IWin32Window parent ) [inline]

Displays a text viewer that represents the scollback buffer.

Parameters:
parent the dialog owner window to be set for the text viewer
void Level9::GameText::Clear ( ) [inline]

Clears the text information.

int Level9::GameText::GetParagraphCount ( ) [inline]

Provides the number of paragraphs.

Returns:
the number of paragraphs
int Level9::GameText::GetOutputLinesCount ( ) [inline]

Provides the number of output lines.

Returns:
the number of output lines

Member Data Documentation

const int Level9::GameText::MAX_COMMANDS_HISTORY = 100 [private]

The maximum number of commands for the command history.

const int Level9::GameText::MAX_LENGTH_INPUT = 160 [private]

The maximum length of user input.

List<AttributedText> Level9::GameText::paragraphs = new List<AttributedText>() [private]

The list of paragraphs associated with this GameText instance.

List<AttributedText> Level9::GameText::output = new List<AttributedText>() [private]

A list of output lines. Stores the text provided by the last call to GetOutput().

TextPosition Level9::GameText::offsetPos = new TextPosition() [private]

The text offset position in the list of paragraphs.

TextPosition Level9::GameText::caretPos = new TextPosition() [private]

The caret position in the list of paragraphs.

TextPosition Level9::GameText::inputPos = new TextPosition() [private]

User input position in the list of paragraphs.

List<string> Level9::GameText::commandHistory = new List<string>() [private]

The command history.

int Level9::GameText::commandHistoryPos = 0 [private]

The current position in the command history.

TextForm Level9::GameText::scrollbackView = null [private]

The text viewer component that displays the scrollback buffer.

Property Documentation

List<AttributedText> Level9::GameText::Paragraphs [get]

Gets the list of paragraphs associated with this GameText instance.


Level9.Net: Member List

  • GameText
Level9::GameText Member List
This is the complete list of members for Level9::GameText, including all inherited members.
Append(string text) | Level9::GameText | [inline]
CaretBack() | Level9::GameText | [inline]
CaretDelete() | Level9::GameText | [inline]
CaretEnd() | Level9::GameText | [inline]
CaretHome() | Level9::GameText | [inline]
CaretIns(char character) | Level9::GameText | [inline]
CaretIns(string text) | Level9::GameText | [inline]
CaretLeft() | Level9::GameText | [inline]
caretPos | Level9::GameText | [private]
CaretRight() | Level9::GameText | [inline]
Clear() | Level9::GameText | [inline]
ClearCaretInParagraphs() | Level9::GameText | [inline, private]
commandHistory | Level9::GameText | [private]
commandHistoryPos | Level9::GameText | [private]
GameText() | Level9::GameText | [inline]
GetInput() | Level9::GameText | [inline]
GetOutput(int lines, int columns, out bool moreLines, out int changeOffset) | Level9::GameText | [inline]
GetOutputLinesCount() | Level9::GameText | [inline]
GetParagraphCount() | Level9::GameText | [inline]
HideCaret() | Level9::GameText | [inline]
HistoryDown() | Level9::GameText | [inline]
HistoryUp() | Level9::GameText | [inline]
inputPos | Level9::GameText | [private]
MAX_COMMANDS_HISTORY | Level9::GameText | [private]
MAX_LENGTH_INPUT | Level9::GameText | [private]
offsetPos | Level9::GameText | [private]
output | Level9::GameText | [private]
paragraphs | Level9::GameText | [private]
Paragraphs | Level9::GameText |
RecallCommand() | Level9::GameText | [inline, private]
scrollbackView | Level9::GameText | [private]
SetCaretInParagraphs() | Level9::GameText | [inline, private]
SetInputPosition() | Level9::GameText | [inline]
SetTextOffset() | Level9::GameText | [inline]
ShowCaret() | Level9::GameText | [inline]
ShowScrollback(IWin32Window parent) | Level9::GameText | [inline]


Level9.Net: Level9::GameThread Class Reference

  • GameThread
Static Public Member Functions | Properties | Static Private Member Functions | Static Private Attributes
Level9::GameThread Class Reference

Controls the main loop which executes opcodes of a Level 9 game. More...

List of all members.

Static Public Member Functions

static void | Start ()
static void | Stop ()
static void | Sleep ()
static void | Resume ()
static void | Join ()

Properties

static bool | StopRequest [get]
static bool | IsRunning [get]
static bool | IsSleeping [get]

Static Private Member Functions

static void | ThreadProc ()

Static Private Attributes

static Thread | gameThread = null
static bool | isRunning = false
static bool | isSleeping = false
static bool | stopRequest = false

Detailed Description

Member Function Documentation

static void Level9::GameThread::Start ( ) [inline, static]

Starts a new game thread.

static void Level9::GameThread::Stop ( ) [inline, static]

Stops a game thread.

static void Level9::GameThread::Sleep ( ) [inline, static]

Interrupts a running game thread.

static void Level9::GameThread::Resume ( ) [inline, static]

Resumes a sleeping game thread.

static void Level9::GameThread::Join ( ) [inline, static]

Joins a game thread.

static void Level9::GameThread::ThreadProc ( ) [inline, static, private]

The thread procedure.

Member Data Documentation

Thread Level9::GameThread::gameThread = null [static, private]

The current game thread instance.

bool Level9::GameThread::isRunning = false [static, private]

This property indicates whether the game thread is running.

bool Level9::GameThread::isSleeping = false [static, private]

This property indicates whether the game thread is sleeping.

bool Level9::GameThread::stopRequest = false [static, private]

This property indicates whether the game thread should be stopped.

Property Documentation

bool Level9::GameThread::StopRequest [static, get]

Gets a value that indicates whether the game thread should be stopped.

bool Level9::GameThread::IsRunning [static, get]

Gets a value that indicates whether the game thread is running.

bool Level9::GameThread::IsSleeping [static, get]

Gets a value that indicates whether the game thread is sleeping.


Level9.Net: Member List

  • GameThread
Level9::GameThread Member List
This is the complete list of members for Level9::GameThread, including all inherited members.
gameThread | Level9::GameThread | [private, static]
isRunning | Level9::GameThread | [private, static]
IsRunning | Level9::GameThread | [static]
isSleeping | Level9::GameThread | [private, static]
IsSleeping | Level9::GameThread | [static]
Join() | Level9::GameThread | [inline, static]
Resume() | Level9::GameThread | [inline, static]
Sleep() | Level9::GameThread | [inline, static]
Start() | Level9::GameThread | [inline, static]
Stop() | Level9::GameThread | [inline, static]
StopRequest | Level9::GameThread | [static]
stopRequest | Level9::GameThread | [private, static]
ThreadProc() | Level9::GameThread | [inline, private, static]


Level9.Net: Level9::GraphicsOffEventArgs Class Reference

  • GraphicsOffEventArgs
Public Member Functions
Level9::GraphicsOffEventArgs Class Reference

Provides data for the GraphicsOff event. More...

List of all members.

Public Member Functions

GraphicsOffEventArgs ()

Detailed Description

Constructor & Destructor Documentation

Level9::GraphicsOffEventArgs::GraphicsOffEventArgs ( ) [inline]

Initializes a new instance of the GraphicsOffEventArgs class.


Level9.Net: Member List

  • GraphicsOffEventArgs
Level9::GraphicsOffEventArgs Member List
This is the complete list of members for Level9::GraphicsOffEventArgs, including all inherited members.
GraphicsOffEventArgs() Level9::GraphicsOffEventArgs [inline]


Level9.Net: Level9::Images Class Reference

  • Images
Public Types | Static Public Member Functions | Static Private Member Functions | Static Private Attributes
Level9::Images Class Reference

Manages the application icons and bitmaps. More...

List of all members.

Public Types

enum Stock {
About_16x16, Accept_16x16, Close_16x16, Copy_16x16,
Dictionary_16x16, Down_16x16, Execute_16x16, Exit_16x16,
Fullscreen_16x16, Help_16x16, L9cut_16x16, Null_16x16,
Open_16x16, Pause_16x16, Play_16x16, Restore_16x16,
Save_16x16, Savepos_16x16, Scripts_16x16, Script_Play_16x16,
Script_Stop_16x16, Script_Pause_16x16, Script_Remove_Control_16x16, Script_Insert_Row_16x16,
Script_Delete_Rows_16x16, Scrollback_16x16, Settings_16x16, Stop_16x16,
Trash_16x16, Up_16x16, Record_48x48, Record_Grey_48x48,
Colors_48x48, Font_48x48, Graphics_48x48, L9cut_48x48,
Splash_300x93
}

Static Public Member Functions

static Image | Get (Stock imageName)

Static Private Member Functions

static | Images ()

Static Private Attributes

static string[] | resources
static Image[] | images

Detailed Description

Member Enumeration Documentation

enum Level9::Images::Stock

The available image names.

Enumerator:
About_16x16

'About' icon; size: 16 x 16 pixels.

Accept_16x16

'Accept' icon; size: 16 x 16 pixels.

Close_16x16

'Close' icon; size: 16 x 16 pixels.

Copy_16x16

'Copy' icon; size: 16 x 16 pixels.

Dictionary_16x16

'Dictionary' icon; size: 16 x 16 pixels.

Down_16x16

'Down' icon; size: 16 x 16 pixels.

Execute_16x16

'Execute' icon; size: 16 x 16 pixels.

Exit_16x16

'Exit' icon; size: 16 x 16 pixels.

Fullscreen_16x16

'Fullscreen' icon; size: 16 x 16 pixels.

Help_16x16

'Help' icon; size: 16 x 16 pixels.

L9cut_16x16

'L9Cut' icon; size: 16 x 16 pixels.

Null_16x16

Blank icon; size: 16 x 16 pixels.

Open_16x16

'Open' icon; size: 16 x 16 pixels.

Pause_16x16

'Pause' icon; size: 16 x 16 pixels.

Play_16x16

'Play' icon; size: 16 x 16 pixels.

Restore_16x16

'Restore' icon; size: 16 x 16 pixels.

Save_16x16

'Save' icon; size: 16 x 16 pixels.

Savepos_16x16

'Save position' icon; size: 16 x 16 pixels.

Scripts_16x16

'Scripts' icon; size: 16 x 16 pixels.

Script_Play_16x16

Script editor: 'Control: Play' icon; size: 16 x 16 pixels.

Script_Stop_16x16

Script editor: 'Control: Stop' icon; size: 16 x 16 pixels.

Script_Pause_16x16

Script editor: 'Control: Pause' icon; size: 16 x 16 pixels.

Script_Remove_Control_16x16

Script editor: 'Remove Control' icon; size: 16 x 16 pixels.

Script_Insert_Row_16x16

Script editor: 'Insert row' icon; size: 16 x 16 pixels.

Script_Delete_Rows_16x16

Script editor: 'Delete row(s)' icon; size: 16 x 16 pixels.

Scrollback_16x16

'Scrollback' icon; size: 16 x 16 pixels.

Settings_16x16

'Settings' icon; size: 16 x 16 pixels.

Stop_16x16

'Stop' icon; size: 16 x 16 pixels.

Trash_16x16

'Trash' icon; size: 16 x 16 pixels.

Up_16x16

'Up' icon; size: 16 x 16 pixels.

Record_48x48

'Record' icon (active); size: 16 x 16 pixels.

Record_Grey_48x48

'Record' icon (inactive); size: 16 x 16 pixels.

Colors_48x48

'Colors' icon; size: 48 x 48 pixels.

Font_48x48

'Font' icon; size: 48 x 48 pixels.

Graphics_48x48

'Graphics' icon; size: 48 x 48 pixels.

L9cut_48x48

'L9Cut' icon; size: 48 x 48 pixels.

Splash_300x93

Splash image; size: 300 x 93 pixels.

Constructor & Destructor Documentation

static Level9::Images::Images ( ) [inline, static, private]

Initializes static members of the Images class.

Member Function Documentation

static Image Level9::Images::Get ( Stock imageName ) [inline, static]

Provides an image for the given name.

Parameters:
imageName the image name
Returns:
the image, or null if an error occurred

Member Data Documentation

string [] Level9::Images::resources [static, private]

The image resource names.

Image [] Level9::Images::images [static, private]

A list with Image elements.


Level9.Net: Member List

  • Images
Level9::Images Member List
This is the complete list of members for Level9::Images, including all inherited members.
Get(Stock imageName) | Level9::Images | [inline, static]
Images() | Level9::Images | [inline, private, static]
images | Level9::Images | [private, static]
resources | Level9::Images | [private, static]
Stock enum name | Level9::Images |


Level9.Net: Level9::InputFinishedEventArgs Class Reference

  • InputFinishedEventArgs
Public Member Functions | Properties | Private Attributes
Level9::InputFinishedEventArgs Class Reference

Provides data for the InputFinished event. More...

List of all members.

Public Member Functions

InputFinishedEventArgs (string input)

Properties

string | Input [get, set]

Private Attributes

string | input = null

Detailed Description

Constructor & Destructor Documentation

Level9::InputFinishedEventArgs::InputFinishedEventArgs ( string input ) [inline]

Initializes a new instance of the InputFinishedEventArgs class.

Parameters:
input the input line

Member Data Documentation

string Level9::InputFinishedEventArgs::input = null [private]

The input line.

Property Documentation

string Level9::InputFinishedEventArgs::Input [get, set]

Gets or sets the input line.


Level9.Net: Member List

  • InputFinishedEventArgs
Level9::InputFinishedEventArgs Member List
This is the complete list of members for Level9::InputFinishedEventArgs, including all inherited members.
input | Level9::InputFinishedEventArgs | [private]
Input | Level9::InputFinishedEventArgs |
InputFinishedEventArgs(string input) | Level9::InputFinishedEventArgs | [inline]


Level9.Net: Level9::InputModeEventArgs Class Reference

  • InputModeEventArgs
Public Member Functions | Properties | Private Attributes
Level9::InputModeEventArgs Class Reference

Provides data for the InputMode event. More...

List of all members.

Public Member Functions

InputModeEventArgs (bool active, bool moreLines)

Properties

bool | Active [get, set]
bool | MoreLines [get, set]
DateTime | Timestamp [get]

Private Attributes

bool | active = false
bool | moreLines = false
DateTime | timestamp

Detailed Description

Constructor & Destructor Documentation

Level9::InputModeEventArgs::InputModeEventArgs | ( | bool | active,
 |  | bool | moreLines
 | ) |  | [inline]

Initializes a new instance of the InputModeEventArgs class.

Parameters:
active | true if the Level 9 interpreter waits for user input, else false
moreLines | true if the text area is too small to display all the available lines provided by the Level 9 interpreter

Member Data Documentation

bool Level9::InputModeEventArgs::active = false [private]

This property indicates whether the Level 9 interpreter waits for user input.

bool Level9::InputModeEventArgs::moreLines = false [private]

This property indicates whether the text area is too small to display all the available lines provided by the Level 9 interpreter.

DateTime Level9::InputModeEventArgs::timestamp [private]

Timestamp of the InputMode event.

Property Documentation

bool Level9::InputModeEventArgs::Active [get, set]

Gets or sets a value that indicates whether the Level 9 interpreter waits for user input.

bool Level9::InputModeEventArgs::MoreLines [get, set]

Gets or sets a value that indicates whether the text area is too small to display all the available lines provided by the Level 9 interpreter.

DateTime Level9::InputModeEventArgs::Timestamp [get]

Gets the timestamp of the InputMode event.


Level9.Net: Member List

  • InputModeEventArgs
Level9::InputModeEventArgs Member List
This is the complete list of members for Level9::InputModeEventArgs, including all inherited members.
active | Level9::InputModeEventArgs | [private]
Active | Level9::InputModeEventArgs |
InputModeEventArgs(bool active, bool moreLines) | Level9::InputModeEventArgs | [inline]
MoreLines | Level9::InputModeEventArgs |
moreLines | Level9::InputModeEventArgs | [private]
Timestamp | Level9::InputModeEventArgs |
timestamp | Level9::InputModeEventArgs | [private]


Level9.Net: Level9::Interpreter Class Reference

  • Interpreter
Classes | Public Types | Static Public Member Functions | Properties | Events | Private Member Functions | Static Private Member Functions | Private Attributes | Static Private Attributes
Level9::Interpreter Class Reference

Callback and control functions of the Level 9 interpreter. More...

Collaboration diagram for Level9::Interpreter:
[legend]

List of all members.

Classes

class | L9BITMAP
The bitmap structure used in games with bitmap graphics. More...

Public Types

enum Commands {
None = -1, Save = 0, Restore, Quit,
Cheat, Dictionary
}

Static Public Member Functions

static void | os_printchar (char c)
static bool | os_input (byte *ibuff, int size)
static byte | os_readchar (int millis)
static void | os_flush ()
static bool | os_save_file (byte *Ptr, int Bytes)
static bool | os_load_file (byte *Ptr, int *Bytes, int Max)
static bool | os_get_game_file (byte *NewName, int Size)
static void | os_set_filenumber (byte *NewName, int Size, int n)
static void | os_graphics (int mode)
static void | os_cleargraphics ()
static void | os_setcolour (int colour, int index)
static void | os_drawline (int x1, int y1, int x2, int y2, byte colour1, byte colour2)
static void | os_fill (int x, int y, byte colour1, byte colour2)
static void | os_show_bitmap (int pic, int x, int y)
static bool | LoadGame (string filename, string picname)
static bool | RunGame ()
static void | StopGame ()
static void | RestoreGame (string inFile)
static void | FreeMemory ()
static void | GetPictureSize (ref int width, ref int height)
static bool | RunGraphics ()
static bool | DetectBitmaps (string path)
static IntPtr | DecodeBitmap (int n)
static void | AddInputRequest (Commands command)
static void | SetGameFile (string filePath)

Properties

static string | GameFilePath [get]
static string | GameTitle [get]

Events

static OsFlushEventHandler | OsFlush
static OsInputEventHandler | OsInput
static OsReadcharEventHandler | OsReadchar
static OsSaveFileEventHandler | OsSaveFile
static OsLoadFileEventHandler | OsLoadFile
static OsGetGameFileEventHandler | OsGetGameFile
static OsGraphicsEventHandler | OsGraphics
static OsClearGraphicsEventHandler | OsClearGraphics
static OsDrawLineEventHandler | OsDrawLine
static OsFillEventHandler | OsFill
static OsSetColourEventHandler | OsSetColour
static OsShowBitmapEventHandler | OsShowBitmap
static NewGameFileEventHandler | NewGameFile
static GameFileErrorEventHandler | GameFileError
static InputFinishedEventHandler | InputFinished

Private Member Functions

delegate void | OS_PRINTCHAR (char c)
delegate bool | OS_INPUT (byte *ibuff, int size)
delegate byte | OS_READCHAR (int millis)
delegate void | OS_FLUSH ()
delegate bool | OS_SAVE_FILE (byte *Ptr, int Bytes)
delegate bool | OS_LOAD_FILE (byte *Ptr, int *Bytes, int Max)
delegate bool | OS_GET_GAME_FILE (byte *NewName, int Size)
delegate void | OS_SET_FILENUMBER (byte *NewName, int Size, int n)
delegate void | OS_GRAPHICS (int mode)
delegate void | OS_CLEARGRAPHICS ()
delegate void | OS_SETCOLOUR (int colour, int index)
delegate void | OS_FILL (int x, int y, byte colour1, byte colour2)
delegate void | OS_SHOW_BITMAP (int pic, int x, int y)
delegate void | OS_DRAWLINE (int x1, int y1, int x2, int y2, byte colour1, byte colour2)
static bool | L9_LoadGame (string filename, string picname)
static bool | L9_RunGame ()
static void | L9_StopGame ()
static void | L9_RestoreGame (string inFile)
static void | L9_FreeMemory ()
static void | L9_GetPictureSize (ref int width, ref int height)
static bool | L9_RunGraphics ()
static bool | L9_DetectBitmaps (string path)
static IntPtr | L9_DecodeBitmap (int n)
static void | L9_SetCallbackFunctions (OS_PRINTCHAR os_printchar, OS_INPUT os_input, OS_READCHAR os_readchar, OS_FLUSH os_flush, OS_SAVE_FILE os_save_file, OS_LOAD_FILE os_load_file, OS_GET_GAME_FILE os_get_game_file, OS_SET_FILENUMBER os_set_filenumber, OS_GRAPHICS os_graphics, OS_CLEARGRAPHICS os_cleargraphics, OS_SETCOLOUR os_setcolour, OS_DRAWLINE os_drawline, OS_FILL os_fill, OS_SHOW_BITMAP os_show_bitmap)

Static Private Member Functions

static | Interpreter ()
static string | BytesToString (byte *source, int size)
static void | StringToBytes (String source, byte *target, int max)

Private Attributes

const int | DICTIONARY_FLUSH = 256

Static Private Attributes

static Delegate[] | callbacks
static string[] | commands
static Commands | currentCommand = Commands.None
static ArrayList | inputRequests = new ArrayList()
static StringBuilder | outputBuffer = new StringBuilder()
static string | gameFilePath
static string | gameTitle
static OsReadcharEventArgs | readcharArgs = new OsReadcharEventArgs(0)

Detailed Description

Member Enumeration Documentation

enum Level9::Interpreter::Commands

An enumeration of special interpreter commands.

Enumerator:
None

No command.

Save

Saves position file directly (bypasses any disk change prompts).

Restore

Restores position file directly (bypasses any protection code).

Quit

Terminates current game, RunGame() will return false.

Cheat

Tries to bypass restore protection on v3,4 games (can be slow).

Dictionary

Lists the game dictionary.

Constructor & Destructor Documentation

static Level9::Interpreter::Interpreter ( ) [inline, static, private]

Initializes static members of the Interpreter class.

Member Function Documentation

delegate void Level9::Interpreter::OS_PRINTCHAR ( char c ) [private]

Represents the method that handles calls to os_printchar(). See Interpreter.os_printchar for details.

delegate bool Level9::Interpreter::OS_INPUT | ( | byte * | ibuff,
 |  | int | size
 | ) |  | [private]

Represents the method that handles calls to os_input(). See Interpreter.os_input for details.

delegate byte Level9::Interpreter::OS_READCHAR ( int millis ) [private]

Represents the method that handles calls to os_readchar(). See Interpreter.os_readchar for details.

delegate void Level9::Interpreter::OS_FLUSH ( ) [private]

Represents the method that handles calls to os_flush(). See Interpreter.os_flush for details.

delegate bool Level9::Interpreter::OS_SAVE_FILE | ( | byte * | Ptr,
 |  | int | Bytes
 | ) |  | [private]

Represents the method that handles calls to os_save_file(). See Interpreter.os_save_file for details.

delegate bool Level9::Interpreter::OS_LOAD_FILE | ( | byte * | Ptr,
 |  | int * | Bytes,
 |  | int | Max
 | ) |  | [private]

Represents the method that handles calls to os_load_file(). See Interpreter.os_load_file for details.

delegate bool Level9::Interpreter::OS_GET_GAME_FILE | ( | byte * | NewName,
 |  | int | Size
 | ) |  | [private]

Represents the method that handles calls to os_get_game_file(). See Interpreter.os_get_game_file for details.

delegate void Level9::Interpreter::OS_SET_FILENUMBER | ( | byte * | NewName,
 |  | int | Size,
 |  | int | n
 | ) |  | [private]

Represents the method that handles calls to os_set_filenumber(). See Interpreter.os_set_filenumber for details.

delegate void Level9::Interpreter::OS_GRAPHICS ( int mode ) [private]

Represents the method that handles calls to os_graphics(). See Interpreter.os_graphics for details.

delegate void Level9::Interpreter::OS_CLEARGRAPHICS ( ) [private]

Represents the method that handles calls to os_cleargraphics(). See Interpreter.os_cleargraphics for details.

delegate void Level9::Interpreter::OS_SETCOLOUR | ( | int | colour,
 |  | int | index
 | ) |  | [private]

Represents the method that handles calls to os_setcolour(). See Interpreter.os_setcolour for details.

delegate void Level9::Interpreter::OS_FILL | ( | int | x,
 |  | int | y,
 |  | byte | colour1,
 |  | byte | colour2
 | ) |  | [private]

Represents the method that handles calls to os_fill(). See Interpreter.os_fill for details.

delegate void Level9::Interpreter::OS_SHOW_BITMAP | ( | int | pic,
 |  | int | x,
 |  | int | y
 | ) |  | [private]

Represents the method that handles calls to os_show_bitmap(). See Interpreter.os_show_bitmap for details.

delegate void Level9::Interpreter::OS_DRAWLINE | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | byte | colour1,
 |  | byte | colour2
 | ) |  | [private]

Represents the method that handles calls to os_drawline(). See Interpreter.os_drawline for details.

static bool Level9::Interpreter::L9_LoadGame | ( | string | filename,
 |  | string | picname
 | ) |  | [private]

Import declaration of the L9_LoadGame method. See Interpreter.LoadGame for details.

static bool Level9::Interpreter::L9_RunGame ( ) [private]

Import declaration of the L9_RunGame method. See Interpreter.RunGame for details.

static void Level9::Interpreter::L9_StopGame ( ) [private]

Import declaration of the L9_StopGame method. See Interpreter.StopGame for details.

static void Level9::Interpreter::L9_RestoreGame ( string inFile ) [private]

Import declaration of the L9_RestoreGame method. See Interpreter.RestoreGame for details.

static void Level9::Interpreter::L9_FreeMemory ( ) [private]

Import declaration of the L9_FreeMemory method. See Interpreter.FreeMemory for details.

static void Level9::Interpreter::L9_GetPictureSize | ( | ref int | width,
 |  | ref int | height
 | ) |  | [private]

Import declaration of the L9_GetPictureSize method. See Interpreter.GetPictureSize for details.

static bool Level9::Interpreter::L9_RunGraphics ( ) [private]

Import declaration of the L9_RunGraphics method. See Interpreter.RunGraphics for details.

static bool Level9::Interpreter::L9_DetectBitmaps ( string path ) [private]

Import declaration of the L9_DetectBitmaps method. See Interpreter.DetectBitmaps for details.

static IntPtr Level9::Interpreter::L9_DecodeBitmap ( int n ) [private]

Import declaration of the L9_DecodeBitmap method. See Interpreter.DecodeBitmap for details.

static void Level9::Interpreter::L9_SetCallbackFunctions | ( | OS_PRINTCHAR | os_printchar,
 |  | OS_INPUT | os_input,
 |  | OS_READCHAR | os_readchar,
 |  | OS_FLUSH | os_flush,
 |  | OS_SAVE_FILE | os_save_file,
 |  | OS_LOAD_FILE | os_load_file,
 |  | OS_GET_GAME_FILE | os_get_game_file,
 |  | OS_SET_FILENUMBER | os_set_filenumber,
 |  | OS_GRAPHICS | os_graphics,
 |  | OS_CLEARGRAPHICS | os_cleargraphics,
 |  | OS_SETCOLOUR | os_setcolour,
 |  | OS_DRAWLINE | os_drawline,
 |  | OS_FILL | os_fill,
 |  | OS_SHOW_BITMAP | os_show_bitmap
 | ) |  | [private]

Import declaration of the L9_SetCallbackFunctions method. Sets the callback functions for the Level 9 interpreter.

Parameters:
os_printchar | the os_printchar callback function
os_input | the os_input callback function
os_readchar | the os_readchar callback function
os_flush | the os_flush callback function
os_save_file | the os_save_file callback function
os_load_file | the os_load_file callback function
os_get_game_file | the os_get_game_file callback function
os_set_filenumber | the os_set_filenumber callback function
os_graphics | the os_graphics callback function
os_cleargraphics | the os_cleargraphics callback function
os_setcolour | the os_setcolour callback function
os_drawline | the os_drawline callback function
os_fill | the os_fill callback function
os_show_bitmap | the os_show_bitmap callback function
static void Level9::Interpreter::os_printchar ( char c ) [inline, static]

os_printchar() prints a character to the output. The interface can either buffer this character or print it immediately, but if buffering is used then the characters must all be sent to the output when the interpreter calls os_flush(). A paragraph of text is output as one long stream of characters, without line breaks, so the interface must provide its own word wrapping and any other features that are desired, such as justification or a [More] prompt. The carriage return character is always '\r', rather than '\n'.

Parameters:
c the character to print
static bool Level9::Interpreter::os_input | ( | byte * | ibuff,
 |  | int | size
 | ) |  | [inline, static]

os_input() reads a line of text from the user, usually to accept the next command to be sent to the game. The text input must be stored in ibuff with a terminating zero, and be no longer than size characters. Normally os_input() should return true, but may return false to cause the entire input so far to be discarded.

Parameters:
ibuff | the zero terminated input line
size | the maximum length of an input line
Returns:
false if the entire input should be discarded
static byte Level9::Interpreter::os_readchar ( int millis ) [inline, static]

os_readchar() looks to see if a key has been pressed if one has, returns the character to the interpreter immediately. If no key has been pressed the interpreter should wait for a key for at least the number of milliseconds given in the argument. If after this period no key has been pressed, 0 should be returned. This is most commonly used when a game is exited, causing it to print "Press SPACE to play again" and then call os_readchar().

Parameters:
millis the number of milliseconds to wait for a keystroke
Returns:
0 if no key has been pressed; otherwise a character
static void Level9::Interpreter::os_flush ( ) [inline, static]

If the calls to os_printchar() are being buffered by the interface then the buffered text must be printed when os_flush() is called.

static bool Level9::Interpreter::os_save_file | ( | byte * | Ptr,
 |  | int | Bytes
 | ) |  | [inline, static]

os_save_file() should prompt the user in some way (with either text or a file requester) for a filename to save the area of memory of size Bytes pointed to by Ptr. true or false should be returned depending on whether or not the operation was successful.

Parameters:
Ptr | the area of memory to save
Bytes | the number of bytes to save
Returns:
true if the operation was successful; otherwise false
static bool Level9::Interpreter::os_load_file | ( | byte * | Ptr,
 |  | int * | Bytes,
 |  | int | Max
 | ) |  | [inline, static]

os_load_file() should prompt the user for the name of a file to load. At most Max bytes should be loaded into the memory pointed to by Ptr, and the number of bytes read should be placed into the variable pointed to by Bytes.

Parameters:
Ptr | an area of memory to write the data to
Bytes | the number of bytes read
Max | the maximum number of bytes to read
Returns:
true if the operation was successful; otherwise false
static bool Level9::Interpreter::os_get_game_file | ( | byte * | NewName,
 |  | int | Size
 | ) |  | [inline, static]

os_get_game_file() should prompt the user for a new game file, to be stored in NewName, which can take a maximum name of Size characters. When this function is called the NewName array contains the name of the currently loaded game, which can be used to derive a name to prompt the user with. This is used by at least the Adrian Mole games, which load in the next part of the game after the part currently being played has been completed. These games were originally written for tape-based systems where the call was simply "load the next game from the tape".

Parameters:
NewName | the name of a game file
Size | the maximum length of NewName
Returns:
true if the operation was successful; otherwise false
static void Level9::Interpreter::os_set_filenumber | ( | byte * | NewName,
 |  | int | Size,
 |  | int | n
 | ) |  | [inline, static]

os_set_filenumber() is for multi-part games originally written for disk-based systems, which used game filenames such as

                    gamedat1.dat
                    gamedat2.dat
                    gamedat3.dat

etc. The routine should take the full filename in NewName (of maximum size Size) and modify it to reflect the number n, e.g. os_set_filename("gamedat1.dat", 2) should leave "gamedat2.dat" in NewName.

Parameters:
NewName | the name of the new game file
Size | the maximum length of NewName
n | the number of the new game file
static void Level9::Interpreter::os_graphics ( int mode ) [inline, static]

Called when graphics are turned on or off, either by the game or by the user entering "graphics" or "text" as a command. If mode is 0 graphics should be turned off, else they should be turned on. After a os_graphics(0) call all the other graphics functions should do nothing. Typically, if mode is not 0 the code will allocate some suitable bitmap for drawing graphics into. To determine the size of the bitmap, the code should call GetPictureSize(). The graphics routines should draw in a bitmap of the size returned by this function, and then scale the bitmap appropriately for display. If instead the graphics code tries to scale the co-ordinates passed to os_drawline() and os_fill() then problems occur with fill colours "leaking" into other areas of the picture. The values returned by GetPictureSize() will not change unless a new game is loaded. The graphis bitmap is always 4 colour. The 4 colours are chosen from a possible 8 by calls to os_setcolour. Note that calls to os_setcolour() must affect the colour of pixels already drawn on the bitmap. For example, suppose a pixel in the bitmap is set to the first colour in the palette during drawing, which at that moment is red. If later the first colour in the palette is set to blue, at the end the pixel should be shown blue. In order to actually draw graphics, the input routines os_input() and os_readchar() should call RunGraphics().

Parameters:
mode the graphics mode
static void Level9::Interpreter::os_cleargraphics ( ) [inline, static]

Clear the current graphics bitmap by filling the entire bitmap with colour 0.

static void Level9::Interpreter::os_setcolour | ( | int | colour,
 |  | int | index
 | ) |  | [inline, static]

Set the given colour in the graphics bitmap's palette to the colour at the given index in the interpreter's table of colours. The actual table of colours in the interpreters provided by Level 9 vary across different machines. An acceptable palette that matches reasonably closely to the Amiga releases is as follows (all colours are 8 bit R,G,B):

                    0x00,0x00,0x00  (black)
                    0xFF,0x00,0x00  (red)
                    0x30,0xE8,0x30  (green)
                    0xFF,0xFF,0x00  (yellow)
                    0x00,0x00,0xFF  (blue)
                    0xA0,0x68,0x00  (brown)
                    0x00,0xFF,0xFF  (cyan)
                    0xFF,0xFF,0xFF  (white)

Parameters:
colour | the colour in the graphics bitmap's palette
index | the index in the interpreter's table of colours
static void Level9::Interpreter::os_drawline | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | byte | colour1,
 |  | byte | colour2
 | ) |  | [inline, static]

Draw a line on the graphics bitmap between (x1,y1) and (x2,y2). Note that either point may lie outside of the bitmap, and that it is the responsibility of the routine to clip to the appropriate coordinates. For each point on the line, if the colour at that point is equal to colour2 the pixel's colour should be changed to colour1, else it should not be modified.

Parameters:
x1 | the x coordinate of (x1,y1)
y1 | the y coordinate of (x1,y1)
x2 | the x coordinate of (x2,y2)
y2 | the y coordinate of (x2,y2)
colour1 | the index of colour 1
colour2 | the index of colour 2
static void Level9::Interpreter::os_fill | ( | int | x,
 |  | int | y,
 |  | byte | colour1,
 |  | byte | colour2
 | ) |  | [inline, static]

If the pixel's colour at (x,y) is equal to colour2, fill the region containing (x,y) with colour1. The boundaries of the region are defined as those areas of the bitmap with a colour other than colour2.

Parameters:
x | the x coordinate of pixel (x,y)
y | the y coordinate of pixel (x,y)
colour1 | the index of colour 1
colour2 | the index of colour 2
static void Level9::Interpreter::os_show_bitmap | ( | int | pic,
 |  | int | x,
 |  | int | y
 | ) |  | [inline, static]

Show the bitmap given by the number pic at the coordinates (x,y). Note that the game can request the same picture several times in a row: it is a good idea for ports to record the last picture number and check it against any new requests.

Parameters:
pic | the bitmap's number
x | the x coordinate
y | the y coordinate
static bool Level9::Interpreter::LoadGame | ( | string | filename,
 |  | string | picname
 | ) |  | [inline, static]

LoadGame() attempts to load a filename and then searches it for a valid Level 9 game. If it is successful true is returned, else false. The previous game in memory will be overwritten if the file filename can be loaded, even if it does not contain a Level9 game, so even if LoadGame() returns false it must be assumed that the game memory has changed. The second argument is the name of the file containing picture data, and may be NULL. Ports should usually ask the user for just the filename and derive picname from it in some way. The recommended approach is to first try the filename with an extension of ".pic" and then try replacing the filename with "picture.dat".

Parameters:
filename | the file to load
picname | the file containing picture data
Returns:
true if successful, else false
static bool Level9::Interpreter::RunGame ( ) [inline, static]

If LoadGame() has been successful, RunGame() can be called to run the Level 9 game. Each call to RunGame() executes a single opcode of the game. In pre-emptive multitasking systems or systems without any multitasking it is enough to sit in a loop calling RunGame(), e.g.

                    while (RunGame());

RunGame() returns true if an opcode code was executed and false if the game is stopped, either by an error or by calls to StopGame().

Returns:
true if an opcode code was executed and false if the game is stopped.
static void Level9::Interpreter::StopGame ( ) [inline, static]

StopGame() stops the current game from playing.

static void Level9::Interpreter::RestoreGame ( string inFile ) [inline, static]

RestoreGame() attempts to restore the currently running game to the position stored in the inFile saved game file. This gives interface code a means to restore a game position.

Parameters:
inFile the saved game file
static void Level9::Interpreter::FreeMemory ( ) [inline, static]

FreeMemory() frees memory used to store the game. This routine should be called when exiting the interpreter.

static void Level9::Interpreter::GetPictureSize | ( | ref int | width,
 |  | ref int | height
 | ) |  | [inline, static]

Returns the width and height of the bitmap that graphics should be drawn into. This is constant for any particular game.

Parameters:
width | the bitmap's width
height | the bitmap's height
static bool Level9::Interpreter::RunGraphics ( ) [inline, static]

Runs an opcode of the graphics routines. The simplest way to display graphics. If a graphics opcode was run true is returned, otherwise false. The simplest way to get graphics to display is to add a loop to repeatedly call RunGraphics() to os_input() and os_readchar():

                    while (RunGraphics());
                    // Now draw graphics bitmap on display...

Optionally, the code can provide a more "atmospheric" recreation of the games by drawing the graphics slowly, as was the case on the old 8-bit computers. This is achieved by calling RunGraphics() several times then waiting for a while before calling it again. Note that when waiting the code should still respond to user input.

Returns:
true if a graphics opcode was run; otherwise false
static bool Level9::Interpreter::DetectBitmaps ( string path ) [inline, static]

This function must be called first to initialize the decoder. It tries to determine which format of bitmap pictures is available in the given directory.

Parameters:
path the game directory
Returns:
true if supported pictures are found
static IntPtr Level9::Interpreter::DecodeBitmap ( int n ) [inline, static]

Decode and return picture with the given number.

Parameters:
n the picture's number
Returns:
IntPtr.Zero if decoding fails; otherwise IntPtr is a reference to a L9Bitmap structure
static void Level9::Interpreter::AddInputRequest ( Commands command ) [inline, static]

Adds an input request. Typically used by the application to execute special interpreter commands. See Interpreter.Commands for details.

Parameters:
command an input command
static void Level9::Interpreter::SetGameFile ( string filePath ) [inline, static]

Sets a new game file and notifies the listeners.

Parameters:
filePath the game file's path
static string Level9::Interpreter::BytesToString | ( | byte * | source,
 |  | int | size
 | ) |  | [inline, static, private]

Converts a byte array into a string.

Parameters:
source | a byte array
size | the maximum number of bytes to convert
Returns:
a string representation of the byte array
static void Level9::Interpreter::StringToBytes | ( | String | source,
 |  | byte * | target,
 |  | int | max
 | ) |  | [inline, static, private]

Converts a string into a byte array.

Parameters:
source | the source string
target | a byte array
max | the maximum number of characters to convert

Member Data Documentation

const int Level9::Interpreter::DICTIONARY_FLUSH = 256 [private]

The number of characters until os_flush() is called in dictionary output mode.

Delegate [] Level9::Interpreter::callbacks [static, private]
Initial value:
 new Delegate[]
                {
                        new OS_PRINTCHAR(os_printchar),
                        new OS_INPUT(os_input),
                        new OS_READCHAR(os_readchar),
                        new OS_FLUSH(os_flush),
                        new OS_SAVE_FILE(os_save_file),
                        new OS_LOAD_FILE(os_load_file),
                        new OS_GET_GAME_FILE(os_get_game_file),
                        new OS_SET_FILENUMBER(os_set_filenumber),
                        new OS_GRAPHICS(os_graphics),
                        new OS_CLEARGRAPHICS(os_cleargraphics),
                        new OS_SETCOLOUR(os_setcolour),
                        new OS_DRAWLINE(os_drawline),
                        new OS_FILL(os_fill),
                        new OS_SHOW_BITMAP(os_show_bitmap)
                }

An array that stores the interpreter callback functions.

string [] Level9::Interpreter::commands [static, private]
Initial value:
 new string[]
                {
                        "#save",
                        "#restore",
                        "#quit",
                        "#cheat",
                        "#dictionary",
                }

The interpreter commands that correspond to the Interpreter.Commands enumeration.

Commands Level9::Interpreter::currentCommand = Commands.None [static, private]

The current interpreter command.

ArrayList Level9::Interpreter::inputRequests = new ArrayList() [static, private]

Stores interpreter commands that were added with Interpreter.AddInputRequest. Those commands are executed in calls to Interpreter.os_input.

StringBuilder Level9::Interpreter::outputBuffer = new StringBuilder() [static, private]

A text buffer used in calls to os_printchar.

string Level9::Interpreter::gameFilePath [static, private]

The current game file's path.

string Level9::Interpreter::gameTitle [static, private]

The current game's title.

OsReadcharEventArgs Level9::Interpreter::readcharArgs = new OsReadcharEventArgs(0) [static, private]

Property Documentation

string Level9::Interpreter::GameFilePath [static, get]

Gets the current game file's path.

string Level9::Interpreter::GameTitle [static, get]

Gets the current game's title.

Event Documentation

OsFlushEventHandler Level9::Interpreter::OsFlush [static]

Occurs when the interpreter flushes a portion of text.

OsInputEventHandler Level9::Interpreter::OsInput [static]

Occurs when a running game waits for user input.

OsReadcharEventHandler Level9::Interpreter::OsReadchar [static]

Occurs when a running game waits for a key press.

OsSaveFileEventHandler Level9::Interpreter::OsSaveFile [static]

Occurs when the interpreter requests to save a file.

OsLoadFileEventHandler Level9::Interpreter::OsLoadFile [static]

Occurs when the interpreter requests to load a file.

OsGetGameFileEventHandler Level9::Interpreter::OsGetGameFile [static]

Occurs when the interpreter requests for a game file.

OsGraphicsEventHandler Level9::Interpreter::OsGraphics [static]

Occurs when graphics are turned on or off in a running game.

OsClearGraphicsEventHandler Level9::Interpreter::OsClearGraphics [static]

Occurs when the graphics area must be cleared in a running game.

OsDrawLineEventHandler Level9::Interpreter::OsDrawLine [static]

Occurs when a line must be drawn in a running game.

OsFillEventHandler Level9::Interpreter::OsFill [static]

Occurs when an area must be filled in a running game.

OsSetColourEventHandler Level9::Interpreter::OsSetColour [static]

Occurs when a palette color must be set in a running game.

OsShowBitmapEventHandler Level9::Interpreter::OsShowBitmap [static]

Occurs when a bitmap must be displayed in a running game.

NewGameFileEventHandler Level9::Interpreter::NewGameFile [static]

Occurs when a new game has been loaded.

GameFileErrorEventHandler Level9::Interpreter::GameFileError [static]

Occurs when the interpreter detects a game file error.

InputFinishedEventHandler Level9::Interpreter::InputFinished [static]

Occurs when the user has finished an input line.


Level9.Net: Member List

  • Interpreter
Level9::Interpreter Member List
This is the complete list of members for Level9::Interpreter, including all inherited members.
AddInputRequest(Commands command) | Level9::Interpreter | [inline, static]
BytesToString(byte *source, int size) | Level9::Interpreter | [inline, private, static]
callbacks | Level9::Interpreter | [private, static]
commands | Level9::Interpreter | [private, static]
Commands enum name | Level9::Interpreter |
currentCommand | Level9::Interpreter | [private, static]
DecodeBitmap(int n) | Level9::Interpreter | [inline, static]
DetectBitmaps(string path) | Level9::Interpreter | [inline, static]
DICTIONARY_FLUSH | Level9::Interpreter | [private]
FreeMemory() | Level9::Interpreter | [inline, static]
GameFileError | Level9::Interpreter | [static]
gameFilePath | Level9::Interpreter | [private, static]
GameFilePath | Level9::Interpreter | [static]
gameTitle | Level9::Interpreter | [private, static]
GameTitle | Level9::Interpreter | [static]
GetPictureSize(ref int width, ref int height) | Level9::Interpreter | [inline, static]
InputFinished | Level9::Interpreter | [static]
inputRequests | Level9::Interpreter | [private, static]
Interpreter() | Level9::Interpreter | [inline, private, static]
L9_DecodeBitmap(int n) | Level9::Interpreter | [private]
L9_DetectBitmaps(string path) | Level9::Interpreter | [private]
L9_FreeMemory() | Level9::Interpreter | [private]
L9_GetPictureSize(ref int width, ref int height) | Level9::Interpreter | [private]
L9_LoadGame(string filename, string picname) | Level9::Interpreter | [private]
L9_RestoreGame(string inFile) | Level9::Interpreter | [private]
L9_RunGame() | Level9::Interpreter | [private]
L9_RunGraphics() | Level9::Interpreter | [private]
L9_SetCallbackFunctions(OS_PRINTCHAR os_printchar, OS_INPUT os_input, OS_READCHAR os_readchar, OS_FLUSH os_flush, OS_SAVE_FILE os_save_file, OS_LOAD_FILE os_load_file, OS_GET_GAME_FILE os_get_game_file, OS_SET_FILENUMBER os_set_filenumber, OS_GRAPHICS os_graphics, OS_CLEARGRAPHICS os_cleargraphics, OS_SETCOLOUR os_setcolour, OS_DRAWLINE os_drawline, OS_FILL os_fill, OS_SHOW_BITMAP os_show_bitmap) | Level9::Interpreter | [private]
L9_StopGame() | Level9::Interpreter | [private]
LoadGame(string filename, string picname) | Level9::Interpreter | [inline, static]
NewGameFile | Level9::Interpreter | [static]
OS_CLEARGRAPHICS() | Level9::Interpreter | [private]
os_cleargraphics() | Level9::Interpreter | [inline, static]
os_drawline(int x1, int y1, int x2, int y2, byte colour1, byte colour2) | Level9::Interpreter | [inline, static]
OS_DRAWLINE(int x1, int y1, int x2, int y2, byte colour1, byte colour2) | Level9::Interpreter | [private]
os_fill(int x, int y, byte colour1, byte colour2) | Level9::Interpreter | [inline, static]
OS_FILL(int x, int y, byte colour1, byte colour2) | Level9::Interpreter | [private]
os_flush() | Level9::Interpreter | [inline, static]
OS_FLUSH() | Level9::Interpreter | [private]
OS_GET_GAME_FILE(byte *NewName, int Size) | Level9::Interpreter | [private]
os_get_game_file(byte *NewName, int Size) | Level9::Interpreter | [inline, static]
OS_GRAPHICS(int mode) | Level9::Interpreter | [private]
os_graphics(int mode) | Level9::Interpreter | [inline, static]
os_input(byte *ibuff, int size) | Level9::Interpreter | [inline, static]
OS_INPUT(byte *ibuff, int size) | Level9::Interpreter | [private]
OS_LOAD_FILE(byte *Ptr, int *Bytes, int Max) | Level9::Interpreter | [private]
os_load_file(byte *Ptr, int *Bytes, int Max) | Level9::Interpreter | [inline, static]
os_printchar(char c) | Level9::Interpreter | [inline, static]
OS_PRINTCHAR(char c) | Level9::Interpreter | [private]
OS_READCHAR(int millis) | Level9::Interpreter | [private]
os_readchar(int millis) | Level9::Interpreter | [inline, static]
OS_SAVE_FILE(byte *Ptr, int Bytes) | Level9::Interpreter | [private]
os_save_file(byte *Ptr, int Bytes) | Level9::Interpreter | [inline, static]
OS_SET_FILENUMBER(byte *NewName, int Size, int n) | Level9::Interpreter | [private]
os_set_filenumber(byte *NewName, int Size, int n) | Level9::Interpreter | [inline, static]
OS_SETCOLOUR(int colour, int index) | Level9::Interpreter | [private]
os_setcolour(int colour, int index) | Level9::Interpreter | [inline, static]
OS_SHOW_BITMAP(int pic, int x, int y) | Level9::Interpreter | [private]
os_show_bitmap(int pic, int x, int y) | Level9::Interpreter | [inline, static]
OsClearGraphics | Level9::Interpreter | [static]
OsDrawLine | Level9::Interpreter | [static]
OsFill | Level9::Interpreter | [static]
OsFlush | Level9::Interpreter | [static]
OsGetGameFile | Level9::Interpreter | [static]
OsGraphics | Level9::Interpreter | [static]
OsInput | Level9::Interpreter | [static]
OsLoadFile | Level9::Interpreter | [static]
OsReadchar | Level9::Interpreter | [static]
OsSaveFile | Level9::Interpreter | [static]
OsSetColour | Level9::Interpreter | [static]
OsShowBitmap | Level9::Interpreter | [static]
outputBuffer | Level9::Interpreter | [private, static]
readcharArgs | Level9::Interpreter | [private, static]
RestoreGame(string inFile) | Level9::Interpreter | [inline, static]
RunGame() | Level9::Interpreter | [inline, static]
RunGraphics() | Level9::Interpreter | [inline, static]
SetGameFile(string filePath) | Level9::Interpreter | [inline, static]
StopGame() | Level9::Interpreter | [inline, static]
StringToBytes(String source, byte *target, int max) | Level9::Interpreter | [inline, private, static]


Level9.Net: Level9::Interpreter::L9BITMAP Class Reference

  • Interpreter
  • L9BITMAP
Public Attributes
Level9::Interpreter::L9BITMAP Class Reference

The bitmap structure used in games with bitmap graphics. More...

List of all members.

Public Attributes

short | width
short | height
IntPtr | bitmap
byte[] | palette
short | npalette

Detailed Description

Member Data Documentation

short Level9::Interpreter::L9BITMAP::width

The bitmap width.

short Level9::Interpreter::L9BITMAP::height

The bitmap height.

IntPtr Level9::Interpreter::L9BITMAP::bitmap

A pointer to the bitmap pixels.

byte [] Level9::Interpreter::L9BITMAP::palette

The bitmap palette. Each entry consists of three bytes (red, green, blue).

short Level9::Interpreter::L9BITMAP::npalette

The number of palette entries.


Level9.Net: Member List

  • Interpreter
  • L9BITMAP
Level9::Interpreter::L9BITMAP Member List
This is the complete list of members for Level9::Interpreter::L9BITMAP, including all inherited members.
bitmap | Level9::Interpreter::L9BITMAP
height | Level9::Interpreter::L9BITMAP
npalette | Level9::Interpreter::L9BITMAP
palette | Level9::Interpreter::L9BITMAP
width | Level9::Interpreter::L9BITMAP


Level9.Net: Level9::L9Cut Class Reference

  • L9Cut
Static Public Member Functions | Static Private Member Functions | Private Attributes
Level9::L9Cut Class Reference

Controls the L9cut utility to extract datafiles and obtain the title of a game. More...

List of all members.

Static Public Member Functions

static string | GetGameTitle (string datafile)
static string | ExtractDatafile (string inFile, string outFile, bool patch)
static string | GetDetectedDatafiles ()
static string | GetMissingDatafiles ()
static string | GetMissingPatches ()

Static Private Member Functions

static string | ExecL9Cut (string arg1, string arg2, string stdin)
static bool | CheckL9Cut ()

Private Attributes

const string | DUMMY_DAT = "\\dummy.dat"
const string | L9CUT_YES = "Y"
const string | L9CUT_NO = "N"
const string | L9CUT_MISSING_PATCHES = "-mp"
const string | L9CUT_DETECTED_DATAFILES = "-ld"
const string | L9CUT_MISSING_DATAFILES = "-md"

Detailed Description

Member Function Documentation

static string Level9::L9Cut::GetGameTitle ( string datafile ) [inline, static]

Provides the game title of a given Level 9 datafile.

Parameters:
datafile the path of a datafile
Returns:
the game title or null if an error occurred
static string Level9::L9Cut::ExtractDatafile | ( | string | inFile,
 |  | string | outFile,
 |  | bool | patch
 | ) |  | [inline, static]

Extracts a Level 9 datafile.

Parameters:
inFile | the path of an input file
outFile | the path of an output file
patch | true if the datafile should be patchedm, else false
Returns:
the L9Cut console output
static string Level9::L9Cut::GetDetectedDatafiles ( ) [inline, static]

Provides a list of all detected datafiles.

Returns:
a list of detected datafiles
static string Level9::L9Cut::GetMissingDatafiles ( ) [inline, static]

Provides a list of missing datafiles.

Returns:
a list of missing datafiles
static string Level9::L9Cut::GetMissingPatches ( ) [inline, static]

Provides a list of missing patches.

Returns:
a list of missing patches
static string Level9::L9Cut::ExecL9Cut | ( | string | arg1,
 |  | string | arg2,
 |  | string | stdin
 | ) |  | [inline, static, private]

Executes L9cut with the given arguments.

Parameters:
arg1 | the first program argument
arg2 | the second program argument
stdin | if L9cut asks for protection removal, stdin is the answer
Returns:
the L9Cut console output
static bool Level9::L9Cut::CheckL9Cut ( ) [inline, static, private]

Checks for 'l9cut.exe' in the application directory.

Returns:
true if L9cut exists, else false

Member Data Documentation

const string Level9::L9Cut::DUMMY_DAT = "\\dummy.dat" [private]

The filename of a dummy L9cut output file. L9cut requires an output file even if we only want game information.

const string Level9::L9Cut::L9CUT_YES = "Y" [private]

The answer 'yes' if L9cut asks for protection removal.

const string Level9::L9Cut::L9CUT_NO = "N" [private]

The answer 'no' if L9cut asks for protection removal.

const string Level9::L9Cut::L9CUT_MISSING_PATCHES = "-mp" [private]

The L9cut parameter for a list of missing patches.

const string Level9::L9Cut::L9CUT_DETECTED_DATAFILES = "-ld" [private]

The L9cut parameter for a list of detected datafiles.

const string Level9::L9Cut::L9CUT_MISSING_DATAFILES = "-md" [private]

The L9cut parameter for a list of missing datafiles.


Level9.Net: Member List

  • L9Cut
Level9::L9Cut Member List
This is the complete list of members for Level9::L9Cut, including all inherited members.
CheckL9Cut() | Level9::L9Cut | [inline, private, static]
DUMMY_DAT | Level9::L9Cut | [private]
ExecL9Cut(string arg1, string arg2, string stdin) | Level9::L9Cut | [inline, private, static]
ExtractDatafile(string inFile, string outFile, bool patch) | Level9::L9Cut | [inline, static]
GetDetectedDatafiles() | Level9::L9Cut | [inline, static]
GetGameTitle(string datafile) | Level9::L9Cut | [inline, static]
GetMissingDatafiles() | Level9::L9Cut | [inline, static]
GetMissingPatches() | Level9::L9Cut | [inline, static]
L9CUT_DETECTED_DATAFILES | Level9::L9Cut | [private]
L9CUT_MISSING_DATAFILES | Level9::L9Cut | [private]
L9CUT_MISSING_PATCHES | Level9::L9Cut | [private]
L9CUT_NO | Level9::L9Cut | [private]
L9CUT_YES | Level9::L9Cut | [private]


Level9.Net: Level9::L9CutForm Class Reference

  • L9CutForm
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes
Level9::L9CutForm Class Reference

Dialog frontend for the L9cut utility. More...

List of all members.

Public Member Functions

L9CutForm ()

Protected Member Functions

override void | Dispose (bool disposing)

Private Member Functions

void | TextBoxInputTextChanged (object sender, EventArgs e)
void | TextBoxOutputTextChanged (object sender, EventArgs e)
void | RadioButtonDetectedDatafilesCheckedChanged (object sender, EventArgs e)
void | RadioButtonMissingDatafilesCheckedChanged (object sender, EventArgs e)
void | RadioButtonMissingPatchesCheckedChanged (object sender, EventArgs e)
void | ButtonExecuteClick (object sender, EventArgs e)
void | ButtonCloseClick (object sender, EventArgs e)
void | ButtonBrowseInputClick (object sender, EventArgs e)
void | ButtonBrowseOutputClick (object sender, EventArgs e)
void | CheckExecuteLists ()
void | CheckExecuteExtract ()
void | InitializeComponent ()

Private Attributes

const string | DEFAULT_OUTPUT_FILE = "\\output.dat"
bool | checkExecute = true
System.ComponentModel.IContainer | components = null

Detailed Description

Constructor & Destructor Documentation

Level9::L9CutForm::L9CutForm ( ) [inline]

Initializes a new instance of the L9CutForm class.

Member Function Documentation

void Level9::L9CutForm::TextBoxInputTextChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the input file changes.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::L9CutForm::TextBoxOutputTextChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the output file changes.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::L9CutForm::RadioButtonDetectedDatafilesCheckedChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Detected datafiles' button changes its state.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::L9CutForm::RadioButtonMissingDatafilesCheckedChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Missing datafiles' button changes its state.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::L9CutForm::RadioButtonMissingPatchesCheckedChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Missing patches' button changes its state.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::L9CutForm::ButtonExecuteClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Execute' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::L9CutForm::ButtonCloseClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Close' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::L9CutForm::ButtonBrowseInputClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Browse' button has been pressed (input file).

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::L9CutForm::ButtonBrowseOutputClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Browse' button has been pressed (output file).

Parameters:
sender | the object that originated the event
e | event arguments
void Level9::L9CutForm::CheckExecuteLists ( ) [inline, private]

Checks the selected arguments if the detected datafiles or the missing datafiles or the missing patches are to be displayed.

void Level9::L9CutForm::CheckExecuteExtract ( ) [inline, private]

Checks the selected arguments if a datafile is to be extracted.

override void Level9::L9CutForm::Dispose ( bool disposing ) [inline, protected]

Disposes resources used by the form.

Parameters:
disposing true if managed resources should be disposed; otherwise, false.
void Level9::L9CutForm::InitializeComponent ( ) [inline, private]

This method is required for Windows Forms designer support. Do not change the method contents inside the source code editor. The Forms designer might not be able to load this method if it was changed manually.

Member Data Documentation

const string Level9::L9CutForm::DEFAULT_OUTPUT_FILE = "\\output.dat" [private]

The default L9Cut output file.

bool Level9::L9CutForm::checkExecute = true [private]

This property indicates whether the selected arguments are valid for an execution of L9cut.

System.ComponentModel.IContainer Level9::L9CutForm::components = null [private]

Designer variable used to keep track of non-visual components.


Level9.Net: Member List

  • L9CutForm
Level9::L9CutForm Member List
This is the complete list of members for Level9::L9CutForm, including all inherited members.
ButtonBrowseInputClick(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]
ButtonBrowseOutputClick(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]
ButtonCloseClick(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]
ButtonExecuteClick(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]
checkExecute | Level9::L9CutForm | [private]
CheckExecuteExtract() | Level9::L9CutForm | [inline, private]
CheckExecuteLists() | Level9::L9CutForm | [inline, private]
components | Level9::L9CutForm | [private]
DEFAULT_OUTPUT_FILE | Level9::L9CutForm | [private]
Dispose(bool disposing) | Level9::L9CutForm | [inline, protected]
InitializeComponent() | Level9::L9CutForm | [inline, private]
L9CutForm() | Level9::L9CutForm | [inline]
RadioButtonDetectedDatafilesCheckedChanged(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]
RadioButtonMissingDatafilesCheckedChanged(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]
RadioButtonMissingPatchesCheckedChanged(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]
TextBoxInputTextChanged(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]
TextBoxOutputTextChanged(object sender, EventArgs e) | Level9::L9CutForm | [inline, private]


Level9.Net: Level9::LexerError Class Reference

  • LexerError
Public Member Functions | Properties | Private Attributes
Level9::LexerError Class Reference

Represents a grammar error that occurs while parsing a Level9.Net script file. More...

List of all members.

Public Member Functions

LexerError (string message, int line, int column)

Properties

int | Line [get, set]
int | Column [get, set]
string | Message [get, set]

Private Attributes

int | line
int | column
string | message = null

Detailed Description

Constructor & Destructor Documentation

Level9::LexerError::LexerError | ( | string | message,
 |  | int | line,
 |  | int | column
 | ) |  | [inline]

Initializes a new instance of the ScriptEntry class.

Parameters:
message | the error message
line | the script line containing the grammar error
column | the column position of the grammar error

Member Data Documentation

int Level9::LexerError::line [private]

The script line containing the grammar error.

int Level9::LexerError::column [private]

The column position of the grammar error.

string Level9::LexerError::message = null [private]

The error message.

Property Documentation

int Level9::LexerError::Line [get, set]

Gets or sets the script line containing the grammar error.

int Level9::LexerError::Column [get, set]

Gets or sets the column position of the grammar error.

string Level9::LexerError::Message [get, set]

Gets or sets the error message.


Level9.Net: Member List

  • LexerError
Level9::LexerError Member List
This is the complete list of members for Level9::LexerError, including all inherited members.
column | Level9::LexerError | [private]
Column | Level9::LexerError |
LexerError(string message, int line, int column) | Level9::LexerError | [inline]
line | Level9::LexerError | [private]
Line | Level9::LexerError |
Message | Level9::LexerError |
message | Level9::LexerError | [private]


Level9.Net: Level9::ListViewItemClickedEventArgs Class Reference

  • ListViewItemClickedEventArgs
Public Member Functions | Properties | Private Attributes
Level9::ListViewItemClickedEventArgs Class Reference

Provides data for the ListViewItemClicked event. More...

Collaboration diagram for Level9::ListViewItemClickedEventArgs:
[legend]

List of all members.

Public Member Functions

ListViewItemClickedEventArgs (SimpleListViewItem item)

Properties

SimpleListViewItem | Item [get, set]

Private Attributes

SimpleListViewItem | item = null

Detailed Description

Constructor & Destructor Documentation

Level9::ListViewItemClickedEventArgs::ListViewItemClickedEventArgs ( SimpleListViewItem item ) [inline]

Initializes a new instance of the ListViewItemClickedEventArgs class.

Parameters:
item the list view item

Member Data Documentation

SimpleListViewItem Level9::ListViewItemClickedEventArgs::item = null [private]

The list view item.

Property Documentation

SimpleListViewItem Level9::ListViewItemClickedEventArgs::Item [get, set]

Gets or sets the list view item.


Level9.Net: Member List

  • ListViewItemClickedEventArgs
Level9::ListViewItemClickedEventArgs Member List
This is the complete list of members for Level9::ListViewItemClickedEventArgs, including all inherited members.
item | Level9::ListViewItemClickedEventArgs | [private]
Item | Level9::ListViewItemClickedEventArgs |
ListViewItemClickedEventArgs(SimpleListViewItem item) | Level9::ListViewItemClickedEventArgs | [inline]


Level9.Net: Level9::Logger Class Reference

  • Logger
Static Public Member Functions | Private Attributes | Static Private Attributes
Level9::Logger Class Reference

Simple logging functionality for Level9.Net. More...

List of all members.

Static Public Member Functions

static void | Log (Type type, string message, Exception e)
static void | Log (Object obj, string message, Exception e)
static void | Log (Type type, string message)
static void | Log (Object obj, string message)

Private Attributes

const string | TS_FORMAT = "yyyy-MM-dd HH:mm:ss"

Static Private Attributes

static StreamWriter | sw = null

Detailed Description

Member Function Documentation

static void Level9::Logger::Log | ( | Type | type,
 |  | string | message,
 |  | Exception | e
 | ) |  | [inline, static]

Appends a log message to the application logfile.

Parameters:
type | the object type that raises the log message
message | the log message
e | an Exception, or null if none occurred
static void Level9::Logger::Log | ( | Object | obj,
 |  | string | message,
 |  | Exception | e
 | ) |  | [inline, static]

Appends a log message to the application logfile.

Parameters:
obj | the object that raises the log message
message | the log message
e | an Exception, or null if none occurred
static void Level9::Logger::Log | ( | Type | type,
 |  | string | message
 | ) |  | [inline, static]

Appends a log message to the application logfile.

Parameters:
type | the object type that raises the log message
message | the log message
static void Level9::Logger::Log | ( | Object | obj,
 |  | string | message
 | ) |  | [inline, static]

Appends a log message to the application logfile.

Parameters:
obj | the object that raises the log message
message | the log message

Member Data Documentation

const string Level9::Logger::TS_FORMAT = "yyyy-MM-dd HH:mm:ss" [private]

The format of logging timestamps.

StreamWriter Level9::Logger::sw = null [static, private]

A stream writer for writing into a logfile.


Level9.Net: Member List

  • Logger
Level9::Logger Member List
This is the complete list of members for Level9::Logger, including all inherited members.
Log(Type type, string message, Exception e) | Level9::Logger | [inline, static]
Log(Object obj, string message, Exception e) | Level9::Logger | [inline, static]
Log(Type type, string message) | Level9::Logger | [inline, static]
Log(Object obj, string message) | Level9::Logger | [inline, static]
sw | Level9::Logger | [private, static]
TS_FORMAT | Level9::Logger | [private]


Level9.Net: Level9::MainForm Class Reference

  • MainForm
Public Member Functions | Static Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes
Level9::MainForm Class Reference

Main window of the Level9.Net application. More...

Collaboration diagram for Level9::MainForm:
[legend]

List of all members.

Public Member Functions

MainForm (string[] args)

Static Public Member Functions

static void | Main (string[] args)

Protected Member Functions

override void | Dispose (bool disposing)

Private Member Functions

void | ApplicationExit (object sender, EventArgs e)
void | MenuItemExitClick (object sender, EventArgs e)
void | MenuItemLoadGameClick (object sender, EventArgs e)
void | MenuItemAboutClick (object sender, EventArgs e)
void | MenuItemScrollbackClick (object sender, EventArgs e)
void | MenuItemSavePosClick (object sender, EventArgs e)
void | MenuItemRestorePosClick (object sender, EventArgs e)
void | MenuItemToolBarClick (object sender, EventArgs e)
void | MenuItemPlaybackClick (object sender, EventArgs e)
void | MenuItemTitleBarClick (object sender, EventArgs e)
void | MenuItemTimerClick (object sender, EventArgs e)
void | MenuItemStatusBarClick (object sender, EventArgs e)
void | MenuItemL9CutClick (object sender, EventArgs e)
void | MenuItemDictionaryClick (object sender, EventArgs e)
void | MenuItemFullscreenClick (object sender, EventArgs e)
void | MenuItemSettingsClick (object sender, EventArgs e)
void | MenuItemScriptRecordingClick (object sender, EventArgs e)
void | MainFormToolBarButtonClicked (object sender, ToolbarButtonClickedEventArgs e)
void | MenuItemRecentFileClick (object sender, System.EventArgs e)
void | MenuItemReloadCurrentGameClick (object sender, EventArgs e)
void | MenuItemSaveScreenshotClick (object sender, EventArgs e)
void | MenuItemL9netHelpClick (object sender, EventArgs e)
void | GamePanelDragDrop (object sender, DragEventArgs e)
void | GamePanelDragEnter (object sender, DragEventArgs e)
void | MainFormFormClosed (object sender, FormClosedEventArgs e)
void | MainFormActivated (object sender, EventArgs e)
void | GamePanelClick (object sender, EventArgs e)
void | DomainUpDownInputDelaySelectedItemChanged (object sender, EventArgs e)
void | ButtonPlaybackPlayClick (object sender, EventArgs e)
void | ButtonPlaybackStopClick (object sender, EventArgs e)
void | DomainUpDownInputDelayEnter (object sender, EventArgs e)
void | TextBoxScriptStatusEnter (object sender, EventArgs e)
void | ScriptTimerTick (Object sender, EventArgs e)
void | ScriptChanged (ScriptChangedEventArgs e)
void | GamePanelInputMode (InputModeEventArgs e)
void | InterpreterOsSaveFile (OsSaveFileEventArgs e)
void | InterpreterOsLoadFile (OsLoadFileEventArgs e)
void | InterpreterOsGetGameFile (OsGetGameFileEventArgs e)
void | InterpreterNewGameFile (NewGameFileEventArgs e)
void | InterpreterGameFileError (GameFileErrorEventArgs e)
void | LoadGame (string filename)
void | UpdateRecentFiles ()
void | InitializeComponent ()

Private Attributes

const string | COMMAND_LINE_LOGGING = "-logging"
const string | TITLE_BAR_TEXT
SimpleToolBarButton toolbarButtonLoadGame
SimpleToolBarButton toolbarButtonSavePos
SimpleToolBarButton toolbarButtonRestorePos
SimpleToolBarButton toolbarButtonScrollback
SimpleToolBarButton toolbarButtonFullscreen
SimpleToolBarButton toolbarButtonSettings
SimpleToolBarButton toolbarButtonDictionary
SimpleToolBarButton toolbarButtonL9Cut
SimpleToolBarButton toolbarButtonScripts
Size | prevSize
ScriptForm | scriptForm = null
System.Windows.Forms.Timer | scriptTimer
InputModeEventArgs | inputModeArgs = null
DateTime | scriptInputModeEventTs
System.ComponentModel.IContainer | components = null

Detailed Description

Constructor & Destructor Documentation

Level9::MainForm::MainForm ( string[] args ) [inline]

Initializes a new instance of the MainForm class.

Parameters:
args the program arguments

Member Function Documentation

void Level9::MainForm::ApplicationExit | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the application exits.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemExitClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Exit' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemLoadGameClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Load game...' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemAboutClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'About' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemScrollbackClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Scrollback...' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemSavePosClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Save current position...' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemRestorePosClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Restore saved position...' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemToolBarClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Toolbar' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemPlaybackClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Script playback' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemTitleBarClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Title bar' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemTimerClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Timer' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemStatusBarClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Status bar' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemL9CutClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'L9Cut...' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemDictionaryClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Dictionary...' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemFullscreenClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Fullscreen' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemSettingsClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Settings...' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemScriptRecordingClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Scripts...' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MainFormToolBarButtonClicked | ( | object | sender,
 |  | ToolbarButtonClickedEventArgs | e
 | ) |  | [inline, private]

Invoked when a button has been pressed on the toolbar.

Parameters:
sender | the object that originated the event
e | a ButtonClickedEventArgs that contains the event data
void Level9::MainForm::MenuItemRecentFileClick | ( | object | sender,
 |  | System.EventArgs | e
 | ) |  | [inline, private]

Invoked when a 'Recent files' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemReloadCurrentGameClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Reload current game' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemSaveScreenshotClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Save screenshot' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::MenuItemL9netHelpClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Level9.Net help' menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::GamePanelDragDrop | ( | object | sender,
 |  | DragEventArgs | e
 | ) |  | [inline, private]

Invoked when a drag-and-drop operation finished within the game panel.

Parameters:
sender | the object that originated the event
e | a DragEventArgs that contains the event data
void Level9::MainForm::GamePanelDragEnter | ( | object | sender,
 |  | DragEventArgs | e
 | ) |  | [inline, private]

Invoked when the mouse drags an item into the game panel.

Parameters:
sender | the object that originated the event
e | a DragEventArgs that contains the event data
void Level9::MainForm::MainFormFormClosed | ( | object | sender,
 |  | FormClosedEventArgs | e
 | ) |  | [inline, private]

Invoked when the dialog form closes.

Parameters:
sender | the object that originated the event
e | a FormClosedEventArgs that contains the event data
void Level9::MainForm::MainFormActivated | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the form is activated. Sets the focus for the game panel.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::GamePanelClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the game panel is clicked. Sets the focus for the game panel.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::DomainUpDownInputDelaySelectedItemChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the script input delay changes.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::ButtonPlaybackPlayClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Play' button for script playback has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::ButtonPlaybackStopClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Stop' button for script playback has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::DomainUpDownInputDelayEnter | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Input delay' control is focused.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::TextBoxScriptStatusEnter | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Status' text box is focused.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::ScriptTimerTick | ( | Object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when a script timer interval has expired.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::MainForm::ScriptChanged ( ScriptChangedEventArgs e ) [inline, private]

Invoked when a Level9.Net script has changed.

Parameters:
e a ScriptChangedEventArgs that contains the event data
void Level9::MainForm::GamePanelInputMode ( InputModeEventArgs e ) [inline, private]

Invoked when the game panel's input mode changes.

Parameters:
e an EventArgs that contains the event data
void Level9::MainForm::InterpreterOsSaveFile ( OsSaveFileEventArgs e ) [inline, private]

Invoked when the Level 9 Interpreter requests to save a file.

Parameters:
e a OsSaveFileEventArgs that contains the event data
void Level9::MainForm::InterpreterOsLoadFile ( OsLoadFileEventArgs e ) [inline, private]

Invoked when the Level 9 Interpreter requests to load a file.

Parameters:
e a OsLoadFileEventArgs that contains the event data
void Level9::MainForm::InterpreterOsGetGameFile ( OsGetGameFileEventArgs e ) [inline, private]

Invoked when the Level 9 interpreter requests for a game file.

Parameters:
e a OsGetGameFileEventArgs that contains the event data
void Level9::MainForm::InterpreterNewGameFile ( NewGameFileEventArgs e ) [inline, private]

Invoked when a new game has been loaded.

Parameters:
e a NewGameFileEventArgs that contains the event data
void Level9::MainForm::InterpreterGameFileError ( GameFileErrorEventArgs e ) [inline, private]

Invoked when the interpreter detects an error.

Parameters:
e a GameFileErrorEventArgs that contains the event data
void Level9::MainForm::LoadGame ( string filename ) [inline, private]

Loads a game file.

Parameters:
filename the filename of a game file
void Level9::MainForm::UpdateRecentFiles ( ) [inline, private]

Updates the 'recent files' list in the main menu.

static void Level9::MainForm::Main ( string[] args ) [inline, static]

Level 9 application entry point.

Parameters:
args the program arguments
override void Level9::MainForm::Dispose ( bool disposing ) [inline, protected]

Disposes resources used by the form.

Parameters:
disposing true if managed resources should be disposed; otherwise, false.
void Level9::MainForm::InitializeComponent ( ) [inline, private]

This method is required for Windows Forms designer support. Do not change the method contents inside the source code editor. The Forms designer might not be able to load this method if it was changed manually.

Member Data Documentation

const string Level9::MainForm::COMMAND_LINE_LOGGING = "-logging" [private]

The command line argument that switches on logging.

const string Level9::MainForm::TITLE_BAR_TEXT [private]
Initial value:
" "
                        + Config.PROGRAM_VERSION

The text displayed in the window title bar.

SimpleToolBarButton Level9::MainForm::toolbarButtonLoadGame [private]

The 'Load Game' toolbar button.

SimpleToolBarButton Level9::MainForm::toolbarButtonSavePos [private]

The 'Save Current Position' toolbar button.

SimpleToolBarButton Level9::MainForm::toolbarButtonRestorePos [private]

The 'Restore Saved Position' toolbar button.

SimpleToolBarButton Level9::MainForm::toolbarButtonScrollback [private]

The 'Scrollback' toolbar button.

SimpleToolBarButton Level9::MainForm::toolbarButtonFullscreen [private]

The 'Fullscreen' toolbar button.

SimpleToolBarButton Level9::MainForm::toolbarButtonSettings [private]

The 'Settings' toolbar button.

SimpleToolBarButton Level9::MainForm::toolbarButtonDictionary [private]

The 'Dictionary' toolbar button.

SimpleToolBarButton Level9::MainForm::toolbarButtonL9Cut [private]

The 'L9Cut' toolbar button.

SimpleToolBarButton Level9::MainForm::toolbarButtonScripts [private]

The 'Manage Scripts' toolbar button.

Size Level9::MainForm::prevSize [private]

This property stores the last window size before the fullscreen mode starts.

ScriptForm Level9::MainForm::scriptForm = null [private]

This property stores the instance of a non-modal 'Scripts' form.

System.Windows.Forms.Timer Level9::MainForm::scriptTimer [private]
Initial value:
                        new System.Windows.Forms.Timer()

The timer for script playback.

InputModeEventArgs Level9::MainForm::inputModeArgs = null [private]

The event data of the last InputMode event.

DateTime Level9::MainForm::scriptInputModeEventTs [private]

Timestamp of the last InputMode event that ScriptTimerTick() processed.

System.ComponentModel.IContainer Level9::MainForm::components = null [private]

Designer variable used to keep track of non-visual components.


Level9.Net: Member List

  • MainForm
Level9::MainForm Member List
This is the complete list of members for Level9::MainForm, including all inherited members.
ApplicationExit(object sender, EventArgs e) | Level9::MainForm | [inline, private]
ButtonPlaybackPlayClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
ButtonPlaybackStopClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
COMMAND_LINE_LOGGING | Level9::MainForm | [private]
components | Level9::MainForm | [private]
Dispose(bool disposing) | Level9::MainForm | [inline, protected]
DomainUpDownInputDelayEnter(object sender, EventArgs e) | Level9::MainForm | [inline, private]
DomainUpDownInputDelaySelectedItemChanged(object sender, EventArgs e) | Level9::MainForm | [inline, private]
GamePanelClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
GamePanelDragDrop(object sender, DragEventArgs e) | Level9::MainForm | [inline, private]
GamePanelDragEnter(object sender, DragEventArgs e) | Level9::MainForm | [inline, private]
GamePanelInputMode(InputModeEventArgs e) | Level9::MainForm | [inline, private]
InitializeComponent() | Level9::MainForm | [inline, private]
inputModeArgs | Level9::MainForm | [private]
InterpreterGameFileError(GameFileErrorEventArgs e) | Level9::MainForm | [inline, private]
InterpreterNewGameFile(NewGameFileEventArgs e) | Level9::MainForm | [inline, private]
InterpreterOsGetGameFile(OsGetGameFileEventArgs e) | Level9::MainForm | [inline, private]
InterpreterOsLoadFile(OsLoadFileEventArgs e) | Level9::MainForm | [inline, private]
InterpreterOsSaveFile(OsSaveFileEventArgs e) | Level9::MainForm | [inline, private]
LoadGame(string filename) | Level9::MainForm | [inline, private]
Main(string[] args) | Level9::MainForm | [inline, static]
MainForm(string[] args) | Level9::MainForm | [inline]
MainFormActivated(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MainFormFormClosed(object sender, FormClosedEventArgs e) | Level9::MainForm | [inline, private]
MainFormToolBarButtonClicked(object sender, ToolbarButtonClickedEventArgs e) | Level9::MainForm | [inline, private]
MenuItemAboutClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemDictionaryClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemExitClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemFullscreenClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemL9CutClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemL9netHelpClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemLoadGameClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemPlaybackClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemRecentFileClick(object sender, System.EventArgs e) | Level9::MainForm | [inline, private]
MenuItemReloadCurrentGameClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemRestorePosClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemSavePosClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemSaveScreenshotClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemScriptRecordingClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemScrollbackClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemSettingsClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemStatusBarClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemTimerClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemTitleBarClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
MenuItemToolBarClick(object sender, EventArgs e) | Level9::MainForm | [inline, private]
prevSize | Level9::MainForm | [private]
ScriptChanged(ScriptChangedEventArgs e) | Level9::MainForm | [inline, private]
scriptForm | Level9::MainForm | [private]
scriptInputModeEventTs | Level9::MainForm | [private]
scriptTimer | Level9::MainForm | [private]
ScriptTimerTick(Object sender, EventArgs e) | Level9::MainForm | [inline, private]
TextBoxScriptStatusEnter(object sender, EventArgs e) | Level9::MainForm | [inline, private]
TITLE_BAR_TEXT | Level9::MainForm | [private]
toolbarButtonDictionary | Level9::MainForm | [private]
toolbarButtonFullscreen | Level9::MainForm | [private]
toolbarButtonL9Cut | Level9::MainForm | [private]
toolbarButtonLoadGame | Level9::MainForm | [private]
toolbarButtonRestorePos | Level9::MainForm | [private]
toolbarButtonSavePos | Level9::MainForm | [private]
toolbarButtonScripts | Level9::MainForm | [private]
toolbarButtonScrollback | Level9::MainForm | [private]
toolbarButtonSettings | Level9::MainForm | [private]
UpdateRecentFiles() | Level9::MainForm | [inline, private]


Level9.Net: Level9::NewGameFileEventArgs Class Reference

  • NewGameFileEventArgs
Public Member Functions
Level9::NewGameFileEventArgs Class Reference

Provides data for the NewGameFile event. More...

List of all members.

Public Member Functions

NewGameFileEventArgs ()

Detailed Description

Constructor & Destructor Documentation

Level9::NewGameFileEventArgs::NewGameFileEventArgs ( ) [inline]

Initializes a new instance of the NewGameFileEventArgs class.


Level9.Net: Member List

  • NewGameFileEventArgs
Level9::NewGameFileEventArgs Member List
This is the complete list of members for Level9::NewGameFileEventArgs, including all inherited members.
NewGameFileEventArgs() Level9::NewGameFileEventArgs [inline]


Level9.Net: Level9::OsClearGraphicsEventArgs Class Reference

  • OsClearGraphicsEventArgs
Public Member Functions
Level9::OsClearGraphicsEventArgs Class Reference

Provides data for the OsClearGraphics event. More...

List of all members.

Public Member Functions

OsClearGraphicsEventArgs ()

Detailed Description

Constructor & Destructor Documentation

Level9::OsClearGraphicsEventArgs::OsClearGraphicsEventArgs ( ) [inline]

Initializes a new instance of the OsClearGraphicsEventArgs class.


Level9.Net: Member List

  • OsClearGraphicsEventArgs
Level9::OsClearGraphicsEventArgs Member List
This is the complete list of members for Level9::OsClearGraphicsEventArgs, including all inherited members.
OsClearGraphicsEventArgs() Level9::OsClearGraphicsEventArgs [inline]


Level9.Net: Level9::OsDrawLineEventArgs Class Reference

  • OsDrawLineEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsDrawLineEventArgs Class Reference

Provides data for the OsDrawLine event. More...

List of all members.

Public Member Functions

OsDrawLineEventArgs (int x1, int y1, int x2, int y2, byte colour1, byte colour2)

Properties

int | X1 [get, set]
int | Y1 [get, set]
int | X2 [get, set]
int | Y2 [get, set]
byte | Colour1 [get, set]
byte | Colour2 [get, set]

Private Attributes

int | x1 = 0
int | y1 = 0
int | x2 = 0
int | y2 = 0
byte | colour1 = 0
byte | colour2 = 0

Detailed Description

Constructor & Destructor Documentation

Level9::OsDrawLineEventArgs::OsDrawLineEventArgs | ( | int | x1,
 |  | int | y1,
 |  | int | x2,
 |  | int | y2,
 |  | byte | colour1,
 |  | byte | colour2
 | ) |  | [inline]

Initializes a new instance of the OsDrawLineEventArgs class.

Parameters:
x1 | the x coordinate of pixel (x1,y1)
y1 | the y coordinate of pixel (x1,y1)
x2 | the x coordinate of pixel (x2,y2)
y2 | the y coordinate of pixel (x2,y2)
colour1 | the index of colour 1
colour2 | the index of colour 2

Member Data Documentation

int Level9::OsDrawLineEventArgs::x1 = 0 [private]

The x coordinate of pixel (x1,y1).

int Level9::OsDrawLineEventArgs::y1 = 0 [private]

The y coordinate of pixel (x1,y1).

int Level9::OsDrawLineEventArgs::x2 = 0 [private]

The x coordinate of pixel (x2,y2).

int Level9::OsDrawLineEventArgs::y2 = 0 [private]

The y coordinate of pixel (x2,y2).

byte Level9::OsDrawLineEventArgs::colour1 = 0 [private]

The index of colour 1.

byte Level9::OsDrawLineEventArgs::colour2 = 0 [private]

The index of colour 2.

Property Documentation

int Level9::OsDrawLineEventArgs::X1 [get, set]

Gets or sets the x coordinate of pixel (x1,y1).

int Level9::OsDrawLineEventArgs::Y1 [get, set]

Gets or sets the y coordinate of pixel (x1,y1).

int Level9::OsDrawLineEventArgs::X2 [get, set]

Gets or sets the x coordinate of pixel (x2,y2).

int Level9::OsDrawLineEventArgs::Y2 [get, set]

Gets or sets the y coordinate of pixel (x2,y2).

byte Level9::OsDrawLineEventArgs::Colour1 [get, set]

Gets or sets the index of colour 1.

byte Level9::OsDrawLineEventArgs::Colour2 [get, set]

Gets or sets the index of colour 2.


Level9.Net: Member List

  • OsDrawLineEventArgs
Level9::OsDrawLineEventArgs Member List
This is the complete list of members for Level9::OsDrawLineEventArgs, including all inherited members.
colour1 | Level9::OsDrawLineEventArgs | [private]
Colour1 | Level9::OsDrawLineEventArgs |
colour2 | Level9::OsDrawLineEventArgs | [private]
Colour2 | Level9::OsDrawLineEventArgs |
OsDrawLineEventArgs(int x1, int y1, int x2, int y2, byte colour1, byte colour2) | Level9::OsDrawLineEventArgs | [inline]
x1 | Level9::OsDrawLineEventArgs | [private]
X1 | Level9::OsDrawLineEventArgs |
X2 | Level9::OsDrawLineEventArgs |
x2 | Level9::OsDrawLineEventArgs | [private]
y1 | Level9::OsDrawLineEventArgs | [private]
Y1 | Level9::OsDrawLineEventArgs |
y2 | Level9::OsDrawLineEventArgs | [private]
Y2 | Level9::OsDrawLineEventArgs |


Level9.Net: Level9::OsFillEventArgs Class Reference

  • OsFillEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsFillEventArgs Class Reference

Provides data for the OsFill event. More...

List of all members.

Public Member Functions

OsFillEventArgs (int x, int y, byte colour1, byte colour2)

Properties

int | X [get, set]
int | Y [get, set]
byte | Colour1 [get, set]
byte | Colour2 [get, set]

Private Attributes

int | x = 0
int | y = 0
byte | colour1 = 0
byte | colour2 = 0

Detailed Description

Constructor & Destructor Documentation

Level9::OsFillEventArgs::OsFillEventArgs | ( | int | x,
 |  | int | y,
 |  | byte | colour1,
 |  | byte | colour2
 | ) |  | [inline]

Initializes a new instance of the OsFillEventArgs class.

Parameters:
x | the x coordinate of pixel (x,y)
y | the y coordinate of pixel (x,y)
colour1 | the index of colour 1
colour2 | the index of colour 2

Member Data Documentation

int Level9::OsFillEventArgs::x = 0 [private]

The x coordinate of pixel (x,y).

int Level9::OsFillEventArgs::y = 0 [private]

The y coordinate of pixel (x,y).

byte Level9::OsFillEventArgs::colour1 = 0 [private]

The index of colour 1.

byte Level9::OsFillEventArgs::colour2 = 0 [private]

The index of colour 2.

Property Documentation

int Level9::OsFillEventArgs::X [get, set]

Gets or sets the x coordinate of pixel (x,y).

int Level9::OsFillEventArgs::Y [get, set]

Gets or sets the y coordinate of pixel (x,y).

byte Level9::OsFillEventArgs::Colour1 [get, set]

Gets or sets the index of colour 1.

byte Level9::OsFillEventArgs::Colour2 [get, set]

Gets or sets the index of colour 2.


Level9.Net: Member List

  • OsFillEventArgs
Level9::OsFillEventArgs Member List
This is the complete list of members for Level9::OsFillEventArgs, including all inherited members.
colour1 | Level9::OsFillEventArgs | [private]
Colour1 | Level9::OsFillEventArgs |
colour2 | Level9::OsFillEventArgs | [private]
Colour2 | Level9::OsFillEventArgs |
OsFillEventArgs(int x, int y, byte colour1, byte colour2) | Level9::OsFillEventArgs | [inline]
X | Level9::OsFillEventArgs |
x | Level9::OsFillEventArgs | [private]
Y | Level9::OsFillEventArgs |
y | Level9::OsFillEventArgs | [private]


Level9.Net: Level9::OsFlushEventArgs Class Reference

  • OsFlushEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsFlushEventArgs Class Reference

Provides data for the OsFlush event. More...

Collaboration diagram for Level9::OsFlushEventArgs:
[legend]

List of all members.

Public Member Functions

OsFlushEventArgs (string text)

Properties

Interpreter.Commands | Command [get, set]
string | Text [get, set]

Private Attributes

string | text = null
Interpreter.Commands | command = Interpreter.Commands.None

Detailed Description

Constructor & Destructor Documentation

Level9::OsFlushEventArgs::OsFlushEventArgs ( string text ) [inline]

Initializes a new instance of the OsFlushEventArgs class.

Parameters:
text the text to flush

Member Data Documentation

string Level9::OsFlushEventArgs::text = null [private]

The text to flush.

Interpreter.Commands Level9::OsFlushEventArgs::command = Interpreter.Commands.None [private]

The current interpreter command. See Interpreter.Commands for details.

Property Documentation

Interpreter.Commands Level9::OsFlushEventArgs::Command [get, set]

Gets or sets the current interpreter command.

string Level9::OsFlushEventArgs::Text [get, set]

Gets or sets the text to flush.


Level9.Net: Member List

  • OsFlushEventArgs
Level9::OsFlushEventArgs Member List
This is the complete list of members for Level9::OsFlushEventArgs, including all inherited members.
command | Level9::OsFlushEventArgs | [private]
Command | Level9::OsFlushEventArgs |
OsFlushEventArgs(string text) | Level9::OsFlushEventArgs | [inline]
text | Level9::OsFlushEventArgs | [private]
Text | Level9::OsFlushEventArgs |


Level9.Net: Level9::OsGetGameFileEventArgs Class Reference

  • OsGetGameFileEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsGetGameFileEventArgs Class Reference

Provides data for the OsGetGameFile event. More...

List of all members.

Public Member Functions

OsGetGameFileEventArgs (string filename)

Properties

string | Filename [get, set]
bool | Success [get, set]

Private Attributes

string | filename = null
bool | success = false

Detailed Description

Constructor & Destructor Documentation

Level9::OsGetGameFileEventArgs::OsGetGameFileEventArgs ( string filename ) [inline]

Initializes a new instance of the OsGetGameFileEventArgs class.

Parameters:
filename the game file name

Member Data Documentation

string Level9::OsGetGameFileEventArgs::filename = null [private]

The game file name.

bool Level9::OsGetGameFileEventArgs::success = false [private]

This property indicates whether the operation was successful.

Property Documentation

string Level9::OsGetGameFileEventArgs::Filename [get, set]

Gets or sets the game file name.

bool Level9::OsGetGameFileEventArgs::Success [get, set]

Gets or sets a value that indicates whether the operation was successful.


Level9.Net: Member List

  • OsGetGameFileEventArgs
Level9::OsGetGameFileEventArgs Member List
This is the complete list of members for Level9::OsGetGameFileEventArgs, including all inherited members.
filename | Level9::OsGetGameFileEventArgs | [private]
Filename | Level9::OsGetGameFileEventArgs |
OsGetGameFileEventArgs(string filename) | Level9::OsGetGameFileEventArgs | [inline]
success | Level9::OsGetGameFileEventArgs | [private]
Success | Level9::OsGetGameFileEventArgs |


Level9.Net: Level9::OsGraphicsEventArgs Class Reference

  • OsGraphicsEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsGraphicsEventArgs Class Reference

Provides data for the OsGraphics event. More...

List of all members.

Public Member Functions

OsGraphicsEventArgs (int mode)

Properties

int | Mode [get, set]

Private Attributes

int | mode = 0

Detailed Description

Constructor & Destructor Documentation

Level9::OsGraphicsEventArgs::OsGraphicsEventArgs ( int mode ) [inline]

Initializes a new instance of the OsGraphicsEventArgs class.

Parameters:
mode the graphics mode

Member Data Documentation

int Level9::OsGraphicsEventArgs::mode = 0 [private]

The graphics mode. See Interpreter.os_graphics for details.

Property Documentation

int Level9::OsGraphicsEventArgs::Mode [get, set]

Gets or sets the graphics mode.


Level9.Net: Member List

  • OsGraphicsEventArgs
Level9::OsGraphicsEventArgs Member List
This is the complete list of members for Level9::OsGraphicsEventArgs, including all inherited members.
mode | Level9::OsGraphicsEventArgs | [private]
Mode | Level9::OsGraphicsEventArgs |
OsGraphicsEventArgs(int mode) | Level9::OsGraphicsEventArgs | [inline]


Level9.Net: Level9::OsInputEventArgs Class Reference

  • OsInputEventArgs
Properties | Private Attributes
Level9::OsInputEventArgs Class Reference

Provides data for the OsInput event. More...

List of all members.

Properties

string | Input [get, set]

Private Attributes

string | input = null

Detailed Description

Member Data Documentation

string Level9::OsInputEventArgs::input = null [private]

The input line.

Property Documentation

string Level9::OsInputEventArgs::Input [get, set]

Gets or sets the input line.


Level9.Net: Member List

  • OsInputEventArgs
Level9::OsInputEventArgs Member List
This is the complete list of members for Level9::OsInputEventArgs, including all inherited members.
input | Level9::OsInputEventArgs | [private]
Input | Level9::OsInputEventArgs |


Level9.Net: Level9::OsLoadFileEventArgs Class Reference

  • OsLoadFileEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsLoadFileEventArgs Class Reference

Provides data for the OsLoadFile event. More...

List of all members.

Public Member Functions

OsLoadFileEventArgs (int maxBytes)

Properties

byte[] | Bytes [get, set]
bool | Success [get, set]
int | MaxBytes [get, set]

Private Attributes

byte[] | bytes
int | maxBytes
bool | success = false

Detailed Description

Constructor & Destructor Documentation

Level9::OsLoadFileEventArgs::OsLoadFileEventArgs ( int maxBytes ) [inline]

Initializes a new instance of the OsLoadFileEventArgs class.

Parameters:
maxBytes the maximum number of bytes to load

Member Data Documentation

byte [] Level9::OsLoadFileEventArgs::bytes [private]

The number of bytes loaded.

int Level9::OsLoadFileEventArgs::maxBytes [private]

The maximum number of bytes to load.

bool Level9::OsLoadFileEventArgs::success = false [private]

This property indicates whether the operation was successful.

Property Documentation

byte [] Level9::OsLoadFileEventArgs::Bytes [get, set]

Gets or sets the number of bytes loaded.

bool Level9::OsLoadFileEventArgs::Success [get, set]

Gets or sets a value that indicates whether the operation was successful.

int Level9::OsLoadFileEventArgs::MaxBytes [get, set]

Gets or sets the maximum number of bytes to load.


Level9.Net: Member List

  • OsLoadFileEventArgs
Level9::OsLoadFileEventArgs Member List
This is the complete list of members for Level9::OsLoadFileEventArgs, including all inherited members.
bytes | Level9::OsLoadFileEventArgs | [private]
Bytes | Level9::OsLoadFileEventArgs |
maxBytes | Level9::OsLoadFileEventArgs | [private]
MaxBytes | Level9::OsLoadFileEventArgs |
OsLoadFileEventArgs(int maxBytes) | Level9::OsLoadFileEventArgs | [inline]
Success | Level9::OsLoadFileEventArgs |
success | Level9::OsLoadFileEventArgs | [private]


Level9.Net: Level9::OsReadcharEventArgs Class Reference

  • OsReadcharEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsReadcharEventArgs Class Reference

Provides data for the OsReadchar event. More...

List of all members.

Public Member Functions

OsReadcharEventArgs (int millis)

Properties

byte | Character [get, set]
int | Millis [get, set]

Private Attributes

byte | character = 0
int | millis = 0

Detailed Description

Constructor & Destructor Documentation

Level9::OsReadcharEventArgs::OsReadcharEventArgs ( int millis ) [inline]

Initializes a new instance of the OsReadcharEventArgs class.

Parameters:
millis the number of milliseconds to wait for a keystroke

Member Data Documentation

byte Level9::OsReadcharEventArgs::character = 0 [private]

The input character.

int Level9::OsReadcharEventArgs::millis = 0 [private]

The number of milliseconds to wait for a keystroke.

Property Documentation

byte Level9::OsReadcharEventArgs::Character [get, set]

Gets or sets the input character.

int Level9::OsReadcharEventArgs::Millis [get, set]

Gets or sets the number of milliseconds to wait for a keystroke.


Level9.Net: Member List

  • OsReadcharEventArgs
Level9::OsReadcharEventArgs Member List
This is the complete list of members for Level9::OsReadcharEventArgs, including all inherited members.
character | Level9::OsReadcharEventArgs | [private]
Character | Level9::OsReadcharEventArgs |
Millis | Level9::OsReadcharEventArgs |
millis | Level9::OsReadcharEventArgs | [private]
OsReadcharEventArgs(int millis) | Level9::OsReadcharEventArgs | [inline]


Level9.Net: Level9::OsSaveFileEventArgs Class Reference

  • OsSaveFileEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsSaveFileEventArgs Class Reference

Provides data for the OsSaveFile event. More...

List of all members.

Public Member Functions

OsSaveFileEventArgs (byte[] bytes)

Properties

byte[] | Bytes [get, set]
bool | Success [get, set]

Private Attributes

byte[] | bytes
bool | success = false

Detailed Description

Constructor & Destructor Documentation

Level9::OsSaveFileEventArgs::OsSaveFileEventArgs ( byte[] bytes ) [inline]

Initializes a new instance of the OsSaveFileEventArgs class.

Parameters:
bytes the portion of bytes to save

Member Data Documentation

byte [] Level9::OsSaveFileEventArgs::bytes [private]

The portion of bytes to save.

bool Level9::OsSaveFileEventArgs::success = false [private]

This property indicates whether the operation was successful.

Property Documentation

byte [] Level9::OsSaveFileEventArgs::Bytes [get, set]

Gets or sets the portion of bytes to save.

bool Level9::OsSaveFileEventArgs::Success [get, set]

Gets or sets a value that indicates whether the operation was successful.


Level9.Net: Member List

  • OsSaveFileEventArgs
Level9::OsSaveFileEventArgs Member List
This is the complete list of members for Level9::OsSaveFileEventArgs, including all inherited members.
bytes | Level9::OsSaveFileEventArgs | [private]
Bytes | Level9::OsSaveFileEventArgs |
OsSaveFileEventArgs(byte[] bytes) | Level9::OsSaveFileEventArgs | [inline]
success | Level9::OsSaveFileEventArgs | [private]
Success | Level9::OsSaveFileEventArgs |


Level9.Net: Level9::OsSetColourEventArgs Class Reference

  • OsSetColourEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsSetColourEventArgs Class Reference

Provides data for the OsSetColour event. More...

List of all members.

Public Member Functions

OsSetColourEventArgs (int colour, int index)

Properties

int | Colour [get, set]
int | Index [get, set]

Private Attributes

int | colour = 0
int | index = 0

Detailed Description

Constructor & Destructor Documentation

Level9::OsSetColourEventArgs::OsSetColourEventArgs | ( | int | colour,
 |  | int | index
 | ) |  | [inline]

Initializes a new instance of the OsSetColourEventArgs class.

Parameters:
colour | the colour in the graphics bitmap's palette
index | the index in the interpreter's table of colours

Member Data Documentation

int Level9::OsSetColourEventArgs::colour = 0 [private]

The colour in the graphics bitmap's palette.

int Level9::OsSetColourEventArgs::index = 0 [private]

The index in the interpreter's table of colours.

Property Documentation

int Level9::OsSetColourEventArgs::Colour [get, set]

Gets or sets the colour in the graphics bitmap's palette.

int Level9::OsSetColourEventArgs::Index [get, set]

Gets or sets the index in the interpreter's table of colours.


Level9.Net: Member List

  • OsSetColourEventArgs
Level9::OsSetColourEventArgs Member List
This is the complete list of members for Level9::OsSetColourEventArgs, including all inherited members.
colour | Level9::OsSetColourEventArgs | [private]
Colour | Level9::OsSetColourEventArgs |
Index | Level9::OsSetColourEventArgs |
index | Level9::OsSetColourEventArgs | [private]
OsSetColourEventArgs(int colour, int index) | Level9::OsSetColourEventArgs | [inline]


Level9.Net: Level9::OsShowBitmapEventArgs Class Reference

  • OsShowBitmapEventArgs
Public Member Functions | Properties | Private Attributes
Level9::OsShowBitmapEventArgs Class Reference

Provides data for the OsShowBitmap event. More...

List of all members.

Public Member Functions

OsShowBitmapEventArgs (int number, int x, int y)

Properties

int | Number [get, set]
int | X [get, set]
int | Y [get, set]

Private Attributes

int | number = 0
int | x = 0
int | y = 0

Detailed Description

Constructor & Destructor Documentation

Level9::OsShowBitmapEventArgs::OsShowBitmapEventArgs | ( | int | number,
 |  | int | x,
 |  | int | y
 | ) |  | [inline]

Initializes a new instance of the OsShowBitmapEventArgs class.

Parameters:
number | the bitmap's number
x | the bitmap's x offset
y | the bitmap's y offset

Member Data Documentation

int Level9::OsShowBitmapEventArgs::number = 0 [private]

The bitmap's number.

int Level9::OsShowBitmapEventArgs::x = 0 [private]

The bitmap's x offset.

int Level9::OsShowBitmapEventArgs::y = 0 [private]

The bitmap's y offset.

Property Documentation

int Level9::OsShowBitmapEventArgs::Number [get, set]

Gets or sets the bitmap's number.

int Level9::OsShowBitmapEventArgs::X [get, set]

Gets or sets the bitmap's x offset.

int Level9::OsShowBitmapEventArgs::Y [get, set]

Gets or sets the bitmap's y offset.


Level9.Net: Member List

  • OsShowBitmapEventArgs
Level9::OsShowBitmapEventArgs Member List
This is the complete list of members for Level9::OsShowBitmapEventArgs, including all inherited members.
number | Level9::OsShowBitmapEventArgs | [private]
Number | Level9::OsShowBitmapEventArgs |
OsShowBitmapEventArgs(int number, int x, int y) | Level9::OsShowBitmapEventArgs | [inline]
X | Level9::OsShowBitmapEventArgs |
x | Level9::OsShowBitmapEventArgs | [private]
Y | Level9::OsShowBitmapEventArgs |
y | Level9::OsShowBitmapEventArgs | [private]


Level9.Net: Level9::PictureCreatedEventArgs Class Reference

  • PictureCreatedEventArgs
Public Member Functions | Properties | Private Attributes
Level9::PictureCreatedEventArgs Class Reference

Provides data for the PictureCreated event. More...

List of all members.

Public Member Functions

PictureCreatedEventArgs (Bitmap picture)

Properties

Bitmap | Picture [get, set]

Private Attributes

Bitmap | picture = null

Detailed Description

Constructor & Destructor Documentation

Level9::PictureCreatedEventArgs::PictureCreatedEventArgs ( Bitmap picture ) [inline]

Initializes a new instance of the PictureCreatedEventArgs class.

Parameters:
picture the picture that has been created

Member Data Documentation

Bitmap Level9::PictureCreatedEventArgs::picture = null [private]

The picture that has been created.

Property Documentation

Bitmap Level9::PictureCreatedEventArgs::Picture [get, set]

Gets or sets the picture that has been created.


Level9.Net: Member List

  • PictureCreatedEventArgs
Level9::PictureCreatedEventArgs Member List
This is the complete list of members for Level9::PictureCreatedEventArgs, including all inherited members.
picture | Level9::PictureCreatedEventArgs | [private]
Picture | Level9::PictureCreatedEventArgs |
PictureCreatedEventArgs(Bitmap picture) | Level9::PictureCreatedEventArgs | [inline]


Level9.Net: Level9::Script Class Reference

  • Script
Public Member Functions | Properties | Events | Private Member Functions | Private Attributes | Static Private Attributes
Level9::Script Class Reference

Manages Level9.Net script files. More...

Collaboration diagram for Level9::Script:
[legend]

List of all members.

Public Member Functions

void | FireScriptChanged ()
bool | AddEntry (ScriptEntry entry)
bool | InsertEntry (int index)
bool | RemoveEntry (int index)
bool | RemoveControlMark (int index)
ScriptEntry | GetEntryAt (int index)
bool | SetInputAt (int index, string input)
bool | SetCommentAt (int index, string comment)
bool | SetPauseAt (int index)
int | FindText (string text, int start, bool previous)
int | GetEntriesCount ()
bool | Clear ()
bool | Load (string filename)
string | Create (bool includeComments, bool oneEntryPerLine)
bool | StartRecording ()
void | StopRecording ()
bool | StartPlayback ()
void | StopPlayback ()
int | GetNextInput (out string input, out bool pause)

Properties

static Script | Instance [get]
bool | IsRecording [get]
bool | IsPlaying [get]
int | PlaybackPos [get]
List< LexerError > | Errors [get]
string | Title [get, set]
string | Comment [get, set]
int | StartIndex [get, set]
int | EndIndex [get, set]

Events

ScriptChangedEventHandler | ScriptChanged

Private Member Functions

Script ()
void | InterpreterInputFinished (InputFinishedEventArgs e)
bool | EntryMatch (string text, ScriptEntry entry)

Private Attributes

const int | SCRIPT_LINE_LENGTH = 80
const string | SCRIPT_TITLE = "#title: "
const string | SCRIPT_COMMENT = "#comment: "
const string | SCRIPT_NEWLINE = "\r\n"
const string | SCRIPT_COMMAND_SEPARATOR = ";"
const string | SCRIPT_COMMAND_BRACKET_BEGIN = "["
const string | SCRIPT_COMMAND_BRACKET_END = "]"
bool | isrecording = false
bool | isplaying = false
string | title = null
string | comment = null
List< ScriptEntry > | entries = new List<ScriptEntry>()
List< LexerError > | errors = new List<LexerError>()
int | startIndex = -1
int | endIndex = int.MaxValue
int | playbackPos = 0
bool | fireEvents = true

Static Private Attributes

static Script | instance = null

Detailed Description

Constructor & Destructor Documentation

Level9::Script::Script ( ) [inline, private]

Initializes a new instance of the Script class.

Member Function Documentation

void Level9::Script::FireScriptChanged ( ) [inline]

Notifies the listeners that the script has changed.

void Level9::Script::InterpreterInputFinished ( InputFinishedEventArgs e ) [inline, private]

Invoked when the user has finished an input line.

Parameters:
e a InputFinishedEventArgs that contains the event data
bool Level9::Script::AddEntry ( ScriptEntry entry ) [inline]

Adds a script entry.

Parameters:
entry the script entry
Returns:
false if script playback is active or an error occurred, else true
bool Level9::Script::InsertEntry ( int index ) [inline]

Inserts a script entry before or after the given entry.

Parameters:
index the script entry's index
Returns:
false if script playback is active or an error occurred, else true
bool Level9::Script::RemoveEntry ( int index ) [inline]

Removes script entries.

Parameters:
index the script entries' index
Returns:
false if script playback is active or an error occurred, else true
bool Level9::Script::RemoveControlMark ( int index ) [inline]

Removes the control mark from a script entry.

Parameters:
index the script entries' index
Returns:
false if script playback is active or an error occurred, else true
ScriptEntry Level9::Script::GetEntryAt ( int index ) [inline]

Provides a copy of the script entry at the given index.

Parameters:
index the script entry's index
Returns:
a script entry or null if an error occurred
bool Level9::Script::SetInputAt | ( | int | index,
 |  | string | input
 | ) |  | [inline]

Sets the input of a script entry at the given index.

Parameters:
index | the entry's index
input | the entry's input
Returns:
false if script playback is active or an error occurred, else true
bool Level9::Script::SetCommentAt | ( | int | index,
 |  | string | comment
 | ) |  | [inline]

Sets the comment of a script entry at the given index.

Parameters:
index | the script entry's index
comment | the script entry's comment
Returns:
false if script playback is active or an error occurred, else true
bool Level9::Script::SetPauseAt ( int index ) [inline]

Sets the 'pause' property of a script entry at the given index.

Parameters:
index the script entry's index
Returns:
false if script playback is active or an error occurred, else true
int Level9::Script::FindText | ( | string | text,
 |  | int | start,
 |  | bool | previous
 | ) |  | [inline]

Searches the script entries for the occurrence of a search term.

Parameters:
text | the search term
start | the start index
previous | if set to true the search looks for previous occurrences of the search term
Returns:
the index of a script entry if the search term has been found, else -1
bool Level9::Script::EntryMatch | ( | string | text,
 |  | ScriptEntry | entry
 | ) |  | [inline, private]

Checks if a given text is contained in the input or comment of a script entry.

Parameters:
text | the search term
entry | the script entry
Returns:
true if the input or comment of the script entry contains the given text, else false
int Level9::Script::GetEntriesCount ( ) [inline]

Returns the number of script entries.

Returns:
the number of script entries
bool Level9::Script::Clear ( ) [inline]

Clears the script content.

Returns:
false if script playback is active, else true
bool Level9::Script::Load ( string filename ) [inline]

Loads a Level9.Net script.

Parameters:
filename the script's file name
Returns:
false if script playback is active, else true
string Level9::Script::Create | ( | bool | includeComments,
 |  | bool | oneEntryPerLine
 | ) |  | [inline]

Creates a string representation of the current script.

Parameters:
includeComments | if set to true the script includes comments for each entry
oneEntryPerLine | if set to true the script contains one entry per line
Returns:
a string representation of the current script
bool Level9::Script::StartRecording ( ) [inline]

Starts the script recording.

Returns:
false if script playback is active, else true
void Level9::Script::StopRecording ( ) [inline]

Stops the script recording.

bool Level9::Script::StartPlayback ( ) [inline]

Starts the script playback.

Returns:
false if script recording is active or an error occurred, else true
void Level9::Script::StopPlayback ( ) [inline]

Stops the script playback.

int Level9::Script::GetNextInput | ( | out string | input,
 |  | out bool | pause
 | ) |  | [inline]

Provides the next script entry in playback mode.

Parameters:
input | the script entry (return value)
pause | if set to true playback should be paused (return value)
Returns:
the script entry's index or -1 if script playback isn't active or the playback range has been exceeded

Member Data Documentation

const int Level9::Script::SCRIPT_LINE_LENGTH = 80 [private]

The line length in Level9.Net script files.

const string Level9::Script::SCRIPT_TITLE = "#title: " [private]

The title prefix in Level9.Net script files.

const string Level9::Script::SCRIPT_COMMENT = "#comment: " [private]

The comment prefix in Level9.Net script files.

const string Level9::Script::SCRIPT_NEWLINE = "\r\n" [private]

The newline characters in Level9.Net script files.

const string Level9::Script::SCRIPT_COMMAND_SEPARATOR = ";" [private]

The command separator in Level9.Net script files.

const string Level9::Script::SCRIPT_COMMAND_BRACKET_BEGIN = "[" [private]

The starting bracket of comments in Level9.Net script files.

const string Level9::Script::SCRIPT_COMMAND_BRACKET_END = "]" [private]

The ending bracket of comments in Level9.Net script files.

Script Level9::Script::instance = null [static, private]

The one and only Script instance (singleton).

bool Level9::Script::isrecording = false [private]

This property indicates whether script recording is active.

bool Level9::Script::isplaying = false [private]

This property indicates whether script playback is active.

string Level9::Script::title = null [private]

The current script's title.

string Level9::Script::comment = null [private]

The current script's comment.

List<ScriptEntry> Level9::Script::entries = new List<ScriptEntry>() [private]

A list of script entries. A script entry consists of a command and a comment.

List<LexerError> Level9::Script::errors = new List<LexerError>() [private]

A list of errors that occurred while parsing the current script.

int Level9::Script::startIndex = -1 [private]

The start index of the script's playback range.

int Level9::Script::endIndex = int.MaxValue [private]

The end index of the script's playback range.

int Level9::Script::playbackPos = 0 [private]

The script's current playback position.

bool Level9::Script::fireEvents = true [private]

This property indicates whether ScriptChanged events are fired or not.

Property Documentation

Script Level9::Script::Instance [static, get]

Gets the one and only Script instance (singleton).

bool Level9::Script::IsRecording [get]

Gets a value that indicates whether script recording is active.

bool Level9::Script::IsPlaying [get]

Gets a value that indicates whether script playback is active.

int Level9::Script::PlaybackPos [get]

Gets the current playback position.

List<LexerError> Level9::Script::Errors [get]

Gets s list of errors that occurred while parsing the current script.

string Level9::Script::Title [get, set]

Gets or sets the current script's title.

string Level9::Script::Comment [get, set]

Gets or sets the current script's comment.

int Level9::Script::StartIndex [get, set]

Gets or sets the start index of the script's playback range.

int Level9::Script::EndIndex [get, set]

Gets or sets the end index of the script's playback range.

Event Documentation

ScriptChangedEventHandler Level9::Script::ScriptChanged

Occurs when the script has changed.


Level9.Net: Member List

  • Script
Level9::Script Member List
This is the complete list of members for Level9::Script, including all inherited members.
AddEntry(ScriptEntry entry) | Level9::Script | [inline]
Clear() | Level9::Script | [inline]
comment | Level9::Script | [private]
Comment | Level9::Script |
Create(bool includeComments, bool oneEntryPerLine) | Level9::Script | [inline]
endIndex | Level9::Script | [private]
EndIndex | Level9::Script |
entries | Level9::Script | [private]
EntryMatch(string text, ScriptEntry entry) | Level9::Script | [inline, private]
Errors | Level9::Script |
errors | Level9::Script | [private]
FindText(string text, int start, bool previous) | Level9::Script | [inline]
fireEvents | Level9::Script | [private]
FireScriptChanged() | Level9::Script | [inline]
GetEntriesCount() | Level9::Script | [inline]
GetEntryAt(int index) | Level9::Script | [inline]
GetNextInput(out string input, out bool pause) | Level9::Script | [inline]
InsertEntry(int index) | Level9::Script | [inline]
Instance | Level9::Script | [static]
instance | Level9::Script | [private, static]
InterpreterInputFinished(InputFinishedEventArgs e) | Level9::Script | [inline, private]
isplaying | Level9::Script | [private]
IsPlaying | Level9::Script |
isrecording | Level9::Script | [private]
IsRecording | Level9::Script |
Load(string filename) | Level9::Script | [inline]
playbackPos | Level9::Script | [private]
PlaybackPos | Level9::Script |
RemoveControlMark(int index) | Level9::Script | [inline]
RemoveEntry(int index) | Level9::Script | [inline]
Script() | Level9::Script | [inline, private]
SCRIPT_COMMAND_BRACKET_BEGIN | Level9::Script | [private]
SCRIPT_COMMAND_BRACKET_END | Level9::Script | [private]
SCRIPT_COMMAND_SEPARATOR | Level9::Script | [private]
SCRIPT_COMMENT | Level9::Script | [private]
SCRIPT_LINE_LENGTH | Level9::Script | [private]
SCRIPT_NEWLINE | Level9::Script | [private]
SCRIPT_TITLE | Level9::Script | [private]
ScriptChanged | Level9::Script |
SetCommentAt(int index, string comment) | Level9::Script | [inline]
SetInputAt(int index, string input) | Level9::Script | [inline]
SetPauseAt(int index) | Level9::Script | [inline]
StartIndex | Level9::Script |
startIndex | Level9::Script | [private]
StartPlayback() | Level9::Script | [inline]
StartRecording() | Level9::Script | [inline]
StopPlayback() | Level9::Script | [inline]
StopRecording() | Level9::Script | [inline]
title | Level9::Script | [private]
Title | Level9::Script |


Level9.Net: Level9::ScriptChangedEventArgs Class Reference

  • ScriptChangedEventArgs
Public Member Functions
Level9::ScriptChangedEventArgs Class Reference

Provides data for the ScriptChanged event. More...

List of all members.

Public Member Functions

ScriptChangedEventArgs ()

Detailed Description

Constructor & Destructor Documentation

Level9::ScriptChangedEventArgs::ScriptChangedEventArgs ( ) [inline]

Initializes a new instance of the ScriptChangedEventArgs class.


Level9.Net: Member List

  • ScriptChangedEventArgs
Level9::ScriptChangedEventArgs Member List
This is the complete list of members for Level9::ScriptChangedEventArgs, including all inherited members.
ScriptChangedEventArgs() Level9::ScriptChangedEventArgs [inline]


Level9.Net: Level9::ScriptEntry Class Reference

  • ScriptEntry
Public Member Functions | Properties | Private Attributes
Level9::ScriptEntry Class Reference

Represents a Level9.Net script entry that consists of user input and a comment. More...

List of all members.

Public Member Functions

ScriptEntry ()
ScriptEntry (string input, string comment)

Properties

string | Input [get, set]
string | Comment [get, set]
bool | Pause [get, set]

Private Attributes

string | input = null
string | comment = null
bool | pause = false

Detailed Description

Constructor & Destructor Documentation

Level9::ScriptEntry::ScriptEntry ( ) [inline]

Initializes a new instance of the ScriptEntry class.

Level9::ScriptEntry::ScriptEntry | ( | string | input,
 |  | string | comment
 | ) |  | [inline]

Initializes a new instance of the ScriptEntry class.

Parameters:
input | the user input
comment | a comment

Member Data Documentation

string Level9::ScriptEntry::input = null [private]

The script entry's user input.

string Level9::ScriptEntry::comment = null [private]

The script entry's comment.

bool Level9::ScriptEntry::pause = false [private]

This property indicates whether the script playback should be interrupted at this entry.

Property Documentation

string Level9::ScriptEntry::Input [get, set]

Gets or sets the script entry's user input.

string Level9::ScriptEntry::Comment [get, set]

Gets or sets the script entry's comment.

bool Level9::ScriptEntry::Pause [get, set]

Gets or sets a value that indicates whether the script playback should be interrupted at this entry.


Level9.Net: Member List

  • ScriptEntry
Level9::ScriptEntry Member List
This is the complete list of members for Level9::ScriptEntry, including all inherited members.
comment | Level9::ScriptEntry | [private]
Comment | Level9::ScriptEntry |
Input | Level9::ScriptEntry |
input | Level9::ScriptEntry | [private]
Pause | Level9::ScriptEntry |
pause | Level9::ScriptEntry | [private]
ScriptEntry() | Level9::ScriptEntry | [inline]
ScriptEntry(string input, string comment) | Level9::ScriptEntry | [inline]


Level9.Net: Level9::ScriptForm Class Reference

  • ScriptForm
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes
Level9::ScriptForm Class Reference

A dialog to create, edit, load and save Level9.Net script files. More...

List of all members.

Public Member Functions

ScriptForm ()

Protected Member Functions

override void | Dispose (bool disposing)

Private Member Functions

void | ScriptChanged (ScriptChangedEventArgs e)
void | TimerTick (Object sender, EventArgs e)
void | ScriptFormFormClosing (object sender, FormClosingEventArgs e)
void | ButtonRecordClick (object sender, EventArgs e)
void | MenuItemLoadClick (object sender, EventArgs e)
void | MenuItemSaveClick (object sender, EventArgs e)
void | MenuItemCloseClick (object sender, EventArgs e)
void | MenuItemCopyClick (object sender, EventArgs e)
void | MenuItemClearClick (object sender, EventArgs e)
void | MenuItemOneEntryPerLineClick (object sender, EventArgs e)
void | MenuItemIncludeCommentsClick (object sender, EventArgs e)
void | TextBoxTitleLeave (object sender, EventArgs e)
void | TextBoxCommentLeave (object sender, EventArgs e)
void | DataGridViewScriptCellValueNeeded (object sender, DataGridViewCellValueEventArgs e)
void | DataGridViewScriptCellValuePushed (object sender, DataGridViewCellValueEventArgs e)
void | ContextMenuStripScriptOpening (object sender, System.ComponentModel.CancelEventArgs e)
void | DeleteRowToolStripMenuItemClick (object sender, EventArgs e)
void | PlaybackStartToolStripMenuItemClick (object sender, EventArgs e)
void | PlaybackEndToolStripMenuItemClick (object sender, EventArgs e)
void | PlaybackPauseToolStripMenuItemClick (object sender, EventArgs e)
void | InsertRowToolStripMenuItemClick (object sender, EventArgs e)
void | InsertRowAfterToolStripMenuItemClick (object sender, EventArgs e)
void | RemoveControlMarkToolStripMenuItemClick (object sender, EventArgs e)
void | DataGridViewScriptCellMouseDown (object sender, DataGridViewCellMouseEventArgs e)
void | ButtonPreviousClick (object sender, EventArgs e)
void | ButtonNextClick (object sender, EventArgs e)
void | TextBoxFindTextChanged (object sender, EventArgs e)
void | ScriptFormKeyDown (object sender, KeyEventArgs e)
void | UpdateScript ()
void | UpdateScriptPreview ()
void | UpdateButtons ()
void | FindText (bool previous)
void | InitializeComponent ()

Private Attributes

System.Windows.Forms.Timer | timer = new System.Windows.Forms.Timer()
ScriptChangedEventHandler | scriptChangedHandler
System.ComponentModel.IContainer | components = null

Detailed Description

Constructor & Destructor Documentation

Level9::ScriptForm::ScriptForm ( ) [inline]

Initializes a new instance of the ScriptForm class.

Member Function Documentation

void Level9::ScriptForm::ScriptChanged ( ScriptChangedEventArgs e ) [inline, private]

Invoked when the script has changed.

Parameters:
e a ScriptChangedEventArgs that contains the event data
void Level9::ScriptForm::TimerTick | ( | Object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when a timer interval of the record button's blink timer has expired.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::ScriptFormFormClosing | ( | object | sender,
 |  | FormClosingEventArgs | e
 | ) |  | [inline, private]

Invoked when the form is being closed.

Parameters:
sender | the object that originated the event
e | a FormClosingEventArgs that contains the event data
void Level9::ScriptForm::ButtonRecordClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Start/Stop recording' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::MenuItemLoadClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the menu item 'Load script...' has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::MenuItemSaveClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the menu item 'Save script...' has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::MenuItemCloseClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the menu item 'Close' has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::MenuItemCopyClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the menu item 'Copy' has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::MenuItemClearClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the menu item 'Clear' has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::MenuItemOneEntryPerLineClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the menu item 'One command per line' has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::MenuItemIncludeCommentsClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the menu item 'Include comments' has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::TextBoxTitleLeave | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Title' text box loses the input focus.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::TextBoxCommentLeave | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Comment' text box loses the input focus.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::DataGridViewScriptCellValueNeeded | ( | object | sender,
 |  | DataGridViewCellValueEventArgs | e
 | ) |  | [inline, private]

Invoked when a cell value for a script entry is needed.

Parameters:
sender | the object that originated the event
e | a DataGridViewCellValueEventArgs that contains the event data
void Level9::ScriptForm::DataGridViewScriptCellValuePushed | ( | object | sender,
 |  | DataGridViewCellValueEventArgs | e
 | ) |  | [inline, private]

Invoked when a script entry's cell value was changed.

Parameters:
sender | the object that originated the event
e | a DataGridViewCellValueEventArgs that contains the event data
void Level9::ScriptForm::ContextMenuStripScriptOpening | ( | object | sender,
 |  | System.ComponentModel.CancelEventArgs | e
 | ) |  | [inline, private]

Invoked when the user presses the right mouse button on a script entry and a context menu is needed.

Parameters:
sender | the object that originated the event
e | a DataGridViewRowContextMenuStripNeededEventArgs that contains the event data
void Level9::ScriptForm::DeleteRowToolStripMenuItemClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Delete row(s)' context menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::PlaybackStartToolStripMenuItemClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Control: Play' context menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::PlaybackEndToolStripMenuItemClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Control: Stop' context menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::PlaybackPauseToolStripMenuItemClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Control: Pause' context menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::InsertRowToolStripMenuItemClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Insert row' context menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::InsertRowAfterToolStripMenuItemClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Insert row (after)' context menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::RemoveControlMarkToolStripMenuItemClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Remove Control' context menu item has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::DataGridViewScriptCellMouseDown | ( | object | sender,
 |  | DataGridViewCellMouseEventArgs | e
 | ) |  | [inline, private]

Invoked when a mouse button has been pressed on a script entry cell.

Parameters:
sender | the object that originated the event
e | a DataGridViewCellMouseEventArgs that contains the event data
void Level9::ScriptForm::ButtonPreviousClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Find previous' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::ButtonNextClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Find next' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::TextBoxFindTextChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the search term has been changed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::ScriptFormKeyDown | ( | object | sender,
 |  | KeyEventArgs | e
 | ) |  | [inline, private]

Invoked when the form has focus and the user presses a key.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::ScriptForm::UpdateScript ( ) [inline, private]

Updates the script.

void Level9::ScriptForm::UpdateScriptPreview ( ) [inline, private]

Updates the script preview.

void Level9::ScriptForm::UpdateButtons ( ) [inline, private]

Updates the dialog buttons.

void Level9::ScriptForm::FindText ( bool previous ) [inline, private]

Searches the script entries for the occurrence of a search term.

Parameters:
previous if set to true the search looks for previous occurrences of the search term
override void Level9::ScriptForm::Dispose ( bool disposing ) [inline, protected]

Disposes resources used by the form.

Parameters:
disposing true if managed resources should be disposed; otherwise, false.
void Level9::ScriptForm::InitializeComponent ( ) [inline, private]

This method is required for Windows Forms designer support. Do not change the method contents inside the source code editor. The Forms designer might not be able to load this method if it was changed manually.

Member Data Documentation

System.Windows.Forms.Timer Level9::ScriptForm::timer = new System.Windows.Forms.Timer() [private]

The record button's blink timer.

ScriptChangedEventHandler Level9::ScriptForm::scriptChangedHandler [private]

A handler for ScriptChanged events.

System.ComponentModel.IContainer Level9::ScriptForm::components = null [private]

Designer variable used to keep track of non-visual components.


Level9.Net: Member List

  • ScriptForm
Level9::ScriptForm Member List
This is the complete list of members for Level9::ScriptForm, including all inherited members.
ButtonNextClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
ButtonPreviousClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
ButtonRecordClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
components | Level9::ScriptForm | [private]
ContextMenuStripScriptOpening(object sender, System.ComponentModel.CancelEventArgs e) | Level9::ScriptForm | [inline, private]
DataGridViewScriptCellMouseDown(object sender, DataGridViewCellMouseEventArgs e) | Level9::ScriptForm | [inline, private]
DataGridViewScriptCellValueNeeded(object sender, DataGridViewCellValueEventArgs e) | Level9::ScriptForm | [inline, private]
DataGridViewScriptCellValuePushed(object sender, DataGridViewCellValueEventArgs e) | Level9::ScriptForm | [inline, private]
DeleteRowToolStripMenuItemClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
Dispose(bool disposing) | Level9::ScriptForm | [inline, protected]
FindText(bool previous) | Level9::ScriptForm | [inline, private]
InitializeComponent() | Level9::ScriptForm | [inline, private]
InsertRowAfterToolStripMenuItemClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
InsertRowToolStripMenuItemClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
MenuItemClearClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
MenuItemCloseClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
MenuItemCopyClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
MenuItemIncludeCommentsClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
MenuItemLoadClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
MenuItemOneEntryPerLineClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
MenuItemSaveClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
PlaybackEndToolStripMenuItemClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
PlaybackPauseToolStripMenuItemClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
PlaybackStartToolStripMenuItemClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
RemoveControlMarkToolStripMenuItemClick(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
ScriptChanged(ScriptChangedEventArgs e) | Level9::ScriptForm | [inline, private]
scriptChangedHandler | Level9::ScriptForm | [private]
ScriptForm() | Level9::ScriptForm | [inline]
ScriptFormFormClosing(object sender, FormClosingEventArgs e) | Level9::ScriptForm | [inline, private]
ScriptFormKeyDown(object sender, KeyEventArgs e) | Level9::ScriptForm | [inline, private]
TextBoxCommentLeave(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
TextBoxFindTextChanged(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
TextBoxTitleLeave(object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
timer | Level9::ScriptForm | [private]
TimerTick(Object sender, EventArgs e) | Level9::ScriptForm | [inline, private]
UpdateButtons() | Level9::ScriptForm | [inline, private]
UpdateScript() | Level9::ScriptForm | [inline, private]
UpdateScriptPreview() | Level9::ScriptForm | [inline, private]


Level9.Net: Level9::SimpleListView Class Reference

  • SimpleListView
Public Member Functions | Protected Member Functions | Events | Private Member Functions | Private Attributes
Level9::SimpleListView Class Reference

Simple list view control with icons and captions. More...

List of all members.

Public Member Functions

SimpleListView ()
void | AddListViewItem (SimpleListViewItem listViewItem)
void | SetSelectedItem (SimpleListViewItem listViewItem)

Protected Member Functions

override void | OnMouseDown (MouseEventArgs e)
override void | OnPaint (PaintEventArgs e)

Events

ListViewItemClickedEventHandler | ItemClicked

Private Member Functions

void | InvalidateItem (int item)
int | GetItemByPoint (Point point)
Rectangle | GetItemRect (int item)
int | GetCaptionWidth (string caption)

Private Attributes

const int | V_SPACING = 7
const int | BORDER_SPACING = 5
const int | CAPTION_SPACING = 3
List< SimpleListViewItem > | listViewItems
int | selected = -1

Detailed Description

Constructor & Destructor Documentation

Level9::SimpleListView::SimpleListView ( ) [inline]

Initializes a new instance of the SimpleListView class.

Member Function Documentation

override void Level9::SimpleListView::OnMouseDown ( MouseEventArgs e ) [inline, protected]

Handles the MouseDown event.

override void Level9::SimpleListView::OnPaint ( PaintEventArgs e ) [inline, protected]

Handles the Paint event.

void Level9::SimpleListView::AddListViewItem ( SimpleListViewItem listViewItem ) [inline]

Adds an item to the list view.

Parameters:
listViewItem a list view item
void Level9::SimpleListView::SetSelectedItem ( SimpleListViewItem listViewItem ) [inline]

Sets the selected list view item.

Parameters:
listViewItem the selected list view item
void Level9::SimpleListView::InvalidateItem ( int item ) [inline, private]

Invalidates a list view item that must be redrawn.

Parameters:
item a list view item
int Level9::SimpleListView::GetItemByPoint ( Point point ) [inline, private]

Provides the list view item that's associated with a given point on the component.

Parameters:
point a point on the component
Returns:
the list view item number
Rectangle Level9::SimpleListView::GetItemRect ( int item ) [inline, private]

Provides the rectangle that's associated with a list view item.

Parameters:
item the list view item number
Returns:
a rectangle
int Level9::SimpleListView::GetCaptionWidth ( string caption ) [inline, private]

Provides the width of a list view item's caption.

Parameters:
caption the caption
Returns:
the caption width

Member Data Documentation

const int Level9::SimpleListView::V_SPACING = 7 [private]

The vertical spacing between list view items in pixels.

const int Level9::SimpleListView::BORDER_SPACING = 5 [private]

The spacing between component border and icons in pixels.

const int Level9::SimpleListView::CAPTION_SPACING = 3 [private]

The vertical spacing between icons and captions in pixels.

List<SimpleListViewItem> Level9::SimpleListView::listViewItems [private]
Initial value:
                        new List<SimpleListViewItem>()

A list of list view items.

int Level9::SimpleListView::selected = -1 [private]

The number of the currently selected item. A value of -1 means that no item is selected.

Event Documentation

ListViewItemClickedEventHandler Level9::SimpleListView::ItemClicked

Occurs when a list view item has been clicked.


Level9.Net: Member List

  • SimpleListView
Level9::SimpleListView Member List
This is the complete list of members for Level9::SimpleListView, including all inherited members.
AddListViewItem(SimpleListViewItem listViewItem) | Level9::SimpleListView | [inline]
BORDER_SPACING | Level9::SimpleListView | [private]
CAPTION_SPACING | Level9::SimpleListView | [private]
GetCaptionWidth(string caption) | Level9::SimpleListView | [inline, private]
GetItemByPoint(Point point) | Level9::SimpleListView | [inline, private]
GetItemRect(int item) | Level9::SimpleListView | [inline, private]
InvalidateItem(int item) | Level9::SimpleListView | [inline, private]
ItemClicked | Level9::SimpleListView |
listViewItems | Level9::SimpleListView | [private]
OnMouseDown(MouseEventArgs e) | Level9::SimpleListView | [inline, protected]
OnPaint(PaintEventArgs e) | Level9::SimpleListView | [inline, protected]
selected | Level9::SimpleListView | [private]
SetSelectedItem(SimpleListViewItem listViewItem) | Level9::SimpleListView | [inline]
SimpleListView() | Level9::SimpleListView | [inline]
V_SPACING | Level9::SimpleListView | [private]


Level9.Net: Level9::SimpleListViewItem Class Reference

  • SimpleListViewItem
Public Member Functions | Properties | Private Attributes
Level9::SimpleListViewItem Class Reference

Represents a simple list view item. More...

List of all members.

Public Member Functions

SimpleListViewItem (Image image, string text)

Properties

Image | Image [get, set]
string | Text [get, set]

Private Attributes

Image | image = null
string | text = null

Detailed Description

Constructor & Destructor Documentation

Level9::SimpleListViewItem::SimpleListViewItem | ( | Image | image,
 |  | string | text
 | ) |  | [inline]

Initializes a new instance of the SimpleListViewItem class.

Parameters:
image | the list view item's image
text | the text of the list view item's caption

Member Data Documentation

Image Level9::SimpleListViewItem::image = null [private]

The list view item's image.

string Level9::SimpleListViewItem::text = null [private]

The text of the list view item's caption.

Property Documentation

Image Level9::SimpleListViewItem::Image [get, set]

Gets or sets the list view item's image.

string Level9::SimpleListViewItem::Text [get, set]

Gets or sets the text of the list view item's caption.


Level9.Net: Member List

  • SimpleListViewItem
Level9::SimpleListViewItem Member List
This is the complete list of members for Level9::SimpleListViewItem, including all inherited members.
image | Level9::SimpleListViewItem | [private]
Image | Level9::SimpleListViewItem |
SimpleListViewItem(Image image, string text) | Level9::SimpleListViewItem | [inline]
text | Level9::SimpleListViewItem | [private]
Text | Level9::SimpleListViewItem |


Level9.Net: Level9::SimpleToolBar Class Reference

  • SimpleToolBar
Public Member Functions | Protected Member Functions | Events | Private Member Functions | Private Attributes | Static Private Attributes
Level9::SimpleToolBar Class Reference

Simple toolbar with icons and tooltips. More...

List of all members.

Public Member Functions

SimpleToolBar ()
void | AddButton (SimpleToolBarButton toolbarButton)

Protected Member Functions

override void | OnMouseMove (MouseEventArgs e)
override void | OnMouseDown (MouseEventArgs e)
override void | OnMouseUp (MouseEventArgs e)
override void | OnMouseLeave (EventArgs e)
override void | OnPaint (PaintEventArgs e)

Events

ToolbarButtonClickedEventHandler | ButtonClicked

Private Member Functions

void | ToolbarButtonEnabledChanged (SimpleToolBarButton sender, EventArgs e)
void | InvalidateButton (int button)
int | GetButtonByPoint (Point point)
Rectangle | GetButtonRect (int button)

Private Attributes

const int | H_SPACING = 6
const int | V_SPACING = 4
const int | H_OFFSET = 6
const int | BORDER_SPACING = 3
const int | SEPARATOR_WIDTH = 2
List< SimpleToolBarButton > | toolbarButtons
int | selected = -1
int | pressed = -1
int | maxIconHeight = 0
ToolTip | toolTip = new ToolTip()

Static Private Attributes

static float[][] | greyScaleMatrix

Detailed Description

Constructor & Destructor Documentation

Level9::SimpleToolBar::SimpleToolBar ( ) [inline]

Initializes a new instance of the SimpleToolBar class.

Member Function Documentation

override void Level9::SimpleToolBar::OnMouseMove ( MouseEventArgs e ) [inline, protected]

Handles the MouseMove event.

override void Level9::SimpleToolBar::OnMouseDown ( MouseEventArgs e ) [inline, protected]

Handles the MouseDown event.

override void Level9::SimpleToolBar::OnMouseUp ( MouseEventArgs e ) [inline, protected]

Handles the MouseUp event.

override void Level9::SimpleToolBar::OnMouseLeave ( EventArgs e ) [inline, protected]

Handles the MouseLeave event.

override void Level9::SimpleToolBar::OnPaint ( PaintEventArgs e ) [inline, protected]

Handles the Paint event.

void Level9::SimpleToolBar::ToolbarButtonEnabledChanged | ( | SimpleToolBarButton | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the enabled state of a toolbar button has changed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::SimpleToolBar::AddButton ( SimpleToolBarButton toolbarButton ) [inline]

Adds a toolbar button to the toolbar.

Parameters:
toolbarButton a toolbar button
void Level9::SimpleToolBar::InvalidateButton ( int button ) [inline, private]

Invalidates a toolbar button that must be redrawn.

Parameters:
button a toolbar button
int Level9::SimpleToolBar::GetButtonByPoint ( Point point ) [inline, private]

Provides the button number that's associated with a point on the toolbar.

Parameters:
point a point on the toolbar
Returns:
the button number
Rectangle Level9::SimpleToolBar::GetButtonRect ( int button ) [inline, private]

Provides the rectangle that's associated with a toolbar button.

Parameters:
button the button number
Returns:
a rectangle

Member Data Documentation

const int Level9::SimpleToolBar::H_SPACING = 6 [private]

The horizontal spacing between icons in pixels.

const int Level9::SimpleToolBar::V_SPACING = 4 [private]

The vertical spacing between component border and icons in pixels.

const int Level9::SimpleToolBar::H_OFFSET = 6 [private]

The horizontal spacing between component border and icons in pixels.

const int Level9::SimpleToolBar::BORDER_SPACING = 3 [private]

The icon border spacing in pixels.

const int Level9::SimpleToolBar::SEPARATOR_WIDTH = 2 [private]

The width of a toolbar separator in pixels.

List<SimpleToolBarButton> Level9::SimpleToolBar::toolbarButtons [private]
Initial value:
                        new List<SimpleToolBarButton>()

A list of toolbar buttons.

int Level9::SimpleToolBar::selected = -1 [private]

The number of the currently selected button. A value of -1 means that no button is selected.

int Level9::SimpleToolBar::pressed = -1 [private]

The number of the currently pressed button. A value of -1 means that no button is pressed.

int Level9::SimpleToolBar::maxIconHeight = 0 [private]

The maximum height of a toolbar icon in pixels.

ToolTip Level9::SimpleToolBar::toolTip = new ToolTip() [private]

The toolbar's tooltip.

float [][] Level9::SimpleToolBar::greyScaleMatrix [static, private]
Initial value:
 new float[][] {
                        new float[] { 0.2222f, 0.2222f, 0.2222f, 0.0000f, 0.0000f },
                        new float[] { 0.2222f, 0.2222f, 0.2222f, 0.0000f, 0.0000f },
                        new float[] { 0.2222f, 0.2222f, 0.2222f, 0.0000f, 0.0000f },
                        new float[] { 0.3333f, 0.3333f, 0.3333f, 0.7500f, 0.0000f },
                        new float[] { 0.0000f, 0.0000f, 0.0000f, 0.0000f, 1.0000f }
                }

A grey scale matrix to display disabled toolbar buttons.

Event Documentation

ToolbarButtonClickedEventHandler Level9::SimpleToolBar::ButtonClicked

Occurs when a toolbar button has been clicked.


Level9.Net: Member List

  • SimpleToolBar
Level9::SimpleToolBar Member List
This is the complete list of members for Level9::SimpleToolBar, including all inherited members.
AddButton(SimpleToolBarButton toolbarButton) | Level9::SimpleToolBar | [inline]
BORDER_SPACING | Level9::SimpleToolBar | [private]
ButtonClicked | Level9::SimpleToolBar |
GetButtonByPoint(Point point) | Level9::SimpleToolBar | [inline, private]
GetButtonRect(int button) | Level9::SimpleToolBar | [inline, private]
greyScaleMatrix | Level9::SimpleToolBar | [private, static]
H_OFFSET | Level9::SimpleToolBar | [private]
H_SPACING | Level9::SimpleToolBar | [private]
InvalidateButton(int button) | Level9::SimpleToolBar | [inline, private]
maxIconHeight | Level9::SimpleToolBar | [private]
OnMouseDown(MouseEventArgs e) | Level9::SimpleToolBar | [inline, protected]
OnMouseLeave(EventArgs e) | Level9::SimpleToolBar | [inline, protected]
OnMouseMove(MouseEventArgs e) | Level9::SimpleToolBar | [inline, protected]
OnMouseUp(MouseEventArgs e) | Level9::SimpleToolBar | [inline, protected]
OnPaint(PaintEventArgs e) | Level9::SimpleToolBar | [inline, protected]
pressed | Level9::SimpleToolBar | [private]
selected | Level9::SimpleToolBar | [private]
SEPARATOR_WIDTH | Level9::SimpleToolBar | [private]
SimpleToolBar() | Level9::SimpleToolBar | [inline]
ToolbarButtonEnabledChanged(SimpleToolBarButton sender, EventArgs e) | Level9::SimpleToolBar | [inline, private]
toolbarButtons | Level9::SimpleToolBar | [private]
toolTip | Level9::SimpleToolBar | [private]
V_SPACING | Level9::SimpleToolBar | [private]


Level9.Net: Level9::SimpleToolBarButton Class Reference

  • SimpleToolBarButton
Public Member Functions | Properties | Events | Private Member Functions | Private Attributes
Level9::SimpleToolBarButton Class Reference

Represents a simple toolbar button. More...

List of all members.

Public Member Functions

SimpleToolBarButton (Image image, string toolTip)

Properties

bool | Enabled [get, set]
Image | Image [get, set]
string | ToolTip [get, set]
bool | IsSeparator [get, set]
static SimpleToolBarButton | Separator [get]

Events

ToolbarButtonEnabledChangedEventHandler | EnabledChanged

Private Member Functions

SimpleToolBarButton ()

Private Attributes

Image | image = null
bool | separator = false
bool | enabled = true
string | toolTip = null

Detailed Description

Constructor & Destructor Documentation

Level9::SimpleToolBarButton::SimpleToolBarButton | ( | Image | image,
 |  | string | toolTip
 | ) |  | [inline]

Initializes a new instance of the SimpleToolBarButton class.

Parameters:
image | the toolbar button's image
toolTip | the text of the toolbar button's tooltip
Level9::SimpleToolBarButton::SimpleToolBarButton ( ) [inline, private]

Initializes a new instance of the SimpleToolBarButton class. This constructor creates toolbar button separators.

Member Data Documentation

Image Level9::SimpleToolBarButton::image = null [private]

The toolbar button's image.

bool Level9::SimpleToolBarButton::separator = false [private]

This property indicates whether the toolbar button acts as a separator.

bool Level9::SimpleToolBarButton::enabled = true [private]

This property indicates whether the toolbar button is enabled.

string Level9::SimpleToolBarButton::toolTip = null [private]

The text of the toolbar button's tooltip.

Property Documentation

bool Level9::SimpleToolBarButton::Enabled [get, set]

Gets or sets a value that indicates whether the toolbar button is enabled.

Image Level9::SimpleToolBarButton::Image [get, set]

Gets or sets the toolbar button image.

string Level9::SimpleToolBarButton::ToolTip [get, set]

Gets or sets the text of the toolbar button's tooltip.

bool Level9::SimpleToolBarButton::IsSeparator [get, set]

Gets or sets a value that indicates whether the toolbar button acts as a seperator.

SimpleToolBarButton Level9::SimpleToolBarButton::Separator [static, get]

Creates a toolbar separator.

Event Documentation

ToolbarButtonEnabledChangedEventHandler Level9::SimpleToolBarButton::EnabledChanged

Occurs when the enabled state of a toolbar button has changed.


Level9.Net: Member List

  • SimpleToolBarButton
Level9::SimpleToolBarButton Member List
This is the complete list of members for Level9::SimpleToolBarButton, including all inherited members.
enabled | Level9::SimpleToolBarButton | [private]
Enabled | Level9::SimpleToolBarButton |
EnabledChanged | Level9::SimpleToolBarButton |
image | Level9::SimpleToolBarButton | [private]
Image | Level9::SimpleToolBarButton |
IsSeparator | Level9::SimpleToolBarButton |
Separator | Level9::SimpleToolBarButton | [static]
separator | Level9::SimpleToolBarButton | [private]
SimpleToolBarButton(Image image, string toolTip) | Level9::SimpleToolBarButton | [inline]
SimpleToolBarButton() | Level9::SimpleToolBarButton | [inline, private]
toolTip | Level9::SimpleToolBarButton | [private]
ToolTip | Level9::SimpleToolBarButton |


Level9.Net: Level9::TextForm Class Reference

  • TextForm
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes
Level9::TextForm Class Reference

Simple text viewer with search options. More...

Collaboration diagram for Level9::TextForm:
[legend]

List of all members.

Public Member Functions

TextForm (bool disposeOnClose, Config.WindowSize dialogSize)
void | AppendText (string text)
void | AppendText (string text, Color color)
void | SetCaretPosition (int pos)
int | GetTextLength ()
void | Clear ()

Protected Member Functions

override void | Dispose (bool disposing)

Private Member Functions

void | TextFormFormClosing (object sender, FormClosingEventArgs e)
void | MenuItemCloseClick (object sender, EventArgs e)
void | MenuItemCopyClick (object sender, EventArgs e)
void | MenuItemSaveClick (object sender, EventArgs e)
void | ButtonNextClick (object sender, EventArgs e)
void | ButtonPreviousClick (object sender, EventArgs e)
void | TextFormKeyDown (object sender, KeyEventArgs e)
void | TextBoxFindTextChanged (object sender, EventArgs e)
bool | FindText (bool previous)
void | InitializeComponent ()

Private Attributes

bool | disposeOnClose = true
Config.WindowSize | dialogSize = null
System.ComponentModel.IContainer | components = null

Detailed Description

Constructor & Destructor Documentation

Level9::TextForm::TextForm | ( | bool | disposeOnClose,
 |  | Config.WindowSize | dialogSize
 | ) |  | [inline]

Initializes a new instance of the TextForm class.

Parameters:
disposeOnClose | if set to true the dialog disposes with the close operation
dialogSize | the Config.WindowSize instance that stores the dialog size

Member Function Documentation

void Level9::TextForm::TextFormFormClosing | ( | object | sender,
 |  | FormClosingEventArgs | e
 | ) |  | [inline, private]

Invoked when the form is being closed.

Parameters:
sender | the object that originated the event
e | a FormClosingEventArgs that contains the event data
void Level9::TextForm::MenuItemCloseClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Close' menu item has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::TextForm::MenuItemCopyClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Copy to clipboard' menu item has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::TextForm::MenuItemSaveClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Save' menu item has been clicked.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::TextForm::ButtonNextClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Find next' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::TextForm::ButtonPreviousClick | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the 'Find previous' button has been pressed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::TextForm::TextFormKeyDown | ( | object | sender,
 |  | KeyEventArgs | e
 | ) |  | [inline, private]

Invoked when the form has focus and the user presses a key.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
void Level9::TextForm::TextBoxFindTextChanged | ( | object | sender,
 |  | EventArgs | e
 | ) |  | [inline, private]

Invoked when the text in the 'Find' text box has been changed.

Parameters:
sender | the object that originated the event
e | an EventArgs that contains the event data
bool Level9::TextForm::FindText ( bool previous ) [inline, private]

Searches for a search term in the text associated with this control.

Parameters:
previous if set to true the search looks for previous occurrences of the search term
Returns:
true if the search term has been found, else false
void Level9::TextForm::AppendText ( string text ) [inline]

Appends a string to the text associated with this control.

Parameters:
text the text to append
void Level9::TextForm::AppendText | ( | string | text,
 |  | Color | color
 | ) |  | [inline]

Appends a string to the text associated with this control.

Parameters:
text | the text to append
color | the text color
void Level9::TextForm::SetCaretPosition ( int pos ) [inline]

Sets the caret position.

Parameters:
pos the caret position
int Level9::TextForm::GetTextLength ( ) [inline]

Returns the length of the text associated with this control.

void Level9::TextForm::Clear ( ) [inline]

Clears the text associated with this control.

override void Level9::TextForm::Dispose ( bool disposing ) [inline, protected]

Disposes resources used by the form.

Parameters:
disposing true if managed resources should be disposed; otherwise, false.
void Level9::TextForm::InitializeComponent ( ) [inline, private]

This method is required for Windows Forms designer support. Do not change the method contents inside the source code editor. The Forms designer might not be able to load this method if it was changed manually.

Member Data Documentation

bool Level9::TextForm::disposeOnClose = true [private]

This property indicates whether the dialog disposes with the close operation.

Config.WindowSize Level9::TextForm::dialogSize = null [private]

The Config.WindowSize instance that stores the dialog size.

System.ComponentModel.IContainer Level9::TextForm::components = null [private]

Designer variable used to keep track of non-visual components.


Level9.Net: Member List

  • TextForm
Level9::TextForm Member List
This is the complete list of members for Level9::TextForm, including all inherited members.
AppendText(string text) | Level9::TextForm | [inline]
AppendText(string text, Color color) | Level9::TextForm | [inline]
ButtonNextClick(object sender, EventArgs e) | Level9::TextForm | [inline, private]
ButtonPreviousClick(object sender, EventArgs e) | Level9::TextForm | [inline, private]
Clear() | Level9::TextForm | [inline]
components | Level9::TextForm | [private]
dialogSize | Level9::TextForm | [private]
Dispose(bool disposing) | Level9::TextForm | [inline, protected]
disposeOnClose | Level9::TextForm | [private]
FindText(bool previous) | Level9::TextForm | [inline, private]
GetTextLength() | Level9::TextForm | [inline]
InitializeComponent() | Level9::TextForm | [inline, private]
MenuItemCloseClick(object sender, EventArgs e) | Level9::TextForm | [inline, private]
MenuItemCopyClick(object sender, EventArgs e) | Level9::TextForm | [inline, private]
MenuItemSaveClick(object sender, EventArgs e) | Level9::TextForm | [inline, private]
SetCaretPosition(int pos) | Level9::TextForm | [inline]
TextBoxFindTextChanged(object sender, EventArgs e) | Level9::TextForm | [inline, private]
TextForm(bool disposeOnClose, Config.WindowSize dialogSize) | Level9::TextForm | [inline]
TextFormFormClosing(object sender, FormClosingEventArgs e) | Level9::TextForm | [inline, private]
TextFormKeyDown(object sender, KeyEventArgs e) | Level9::TextForm | [inline, private]


Level9.Net: Level9::TextPosition Class Reference

  • TextPosition
Public Member Functions | Properties | Private Attributes
Level9::TextPosition Class Reference

Represents a text position defined via paragraph and column. More...

List of all members.

Public Member Functions

TextPosition ()
TextPosition (int paragraph, int column)
void | Copy (TextPosition pos)
void | Clear ()
override bool | Equals (Object obj)
override int | GetHashCode ()
int | CompareTo (Object obj)
override string | ToString ()

Properties

int | Column [get, set]
int | Paragraph [get, set]

Private Attributes

int | paragraph = 0
int | column = 0

Detailed Description

Constructor & Destructor Documentation

Level9::TextPosition::TextPosition ( ) [inline]

Initializes a new instance of the TextPosition class.

Level9::TextPosition::TextPosition | ( | int | paragraph,
 |  | int | column
 | ) |  | [inline]

Initializes a new instance of the TextPosition class.

Parameters:
paragraph | a paragraph
column | a column

Member Function Documentation

void Level9::TextPosition::Copy ( TextPosition pos ) [inline]

Copies the paragraph and column values of a given text position.

Parameters:
pos a text position
void Level9::TextPosition::Clear ( ) [inline]

Clears the paragraph and column values.

override bool Level9::TextPosition::Equals ( Object obj ) [inline]

Determines whether the specified Object is equal to the current Object.

Parameters:
obj the Object to compare with the current Object
Returns:
true if the specified Object is equal to the current Object; otherwise, false
override int Level9::TextPosition::GetHashCode ( ) [inline]

Serves as a hash function for a particular type.

Returns:
a hash code for the current Object
int Level9::TextPosition::CompareTo ( Object obj ) [inline]

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Parameters:
obj an object to compare with this instance
Returns:
a value that indicates the relative order of the objects being compared
override string Level9::TextPosition::ToString ( ) [inline]

Returns a String that represents the current Object.

Returns:
a String that represents the current Object

Member Data Documentation

int Level9::TextPosition::paragraph = 0 [private]

The text position's paragraph.

int Level9::TextPosition::column = 0 [private]

The text position's column.

Property Documentation

int Level9::TextPosition::Column [get, set]

Gets or sets the text position's column.

int Level9::TextPosition::Paragraph [get, set]

Gets or sets the text position's paragraph.


Level9.Net: Member List

  • TextPosition
Level9::TextPosition Member List
This is the complete list of members for Level9::TextPosition, including all inherited members.
Clear() | Level9::TextPosition | [inline]
column | Level9::TextPosition | [private]
Column | Level9::TextPosition |
CompareTo(Object obj) | Level9::TextPosition | [inline]
Copy(TextPosition pos) | Level9::TextPosition | [inline]
Equals(Object obj) | Level9::TextPosition | [inline]
GetHashCode() | Level9::TextPosition | [inline]
paragraph | Level9::TextPosition | [private]
Paragraph | Level9::TextPosition |
TextPosition() | Level9::TextPosition | [inline]
TextPosition(int paragraph, int column) | Level9::TextPosition | [inline]
ToString() | Level9::TextPosition | [inline]


Level9.Net: Level9::TextUtils Class Reference

  • TextUtils
Static Public Member Functions | Static Private Member Functions
Level9::TextUtils Class Reference

Utilities for text handling. More...

List of all members.

Static Public Member Functions

static List< string > | SplitParagraph (string paragraph, int columns)
static List< string > | SplitParagraph (string paragraph, int numLines, int columns)
static List< AttributedText > | SplitParagraphs (List< AttributedText > paragraphs, int lines, int columns, bool topDown)
static List< AttributedText > | SplitParagraphs (List< AttributedText > paragraphs, int lines, int columns, TextPosition offset, bool topDown)
static string | Substring (string text, string start, string end)

Static Private Member Functions

static List< AttributedText > | SplitParagraph (AttributedText paragraph, int columns, int offset, int paragraphIndex)

Detailed Description

Member Function Documentation

static List<string> Level9::TextUtils::SplitParagraph | ( | string | paragraph,
 |  | int | columns
 | ) |  | [inline, static]

Splits a paragraph into separate lines with a given number of columns.

Parameters:
paragraph | the paragraph string
columns | the number of columns per line
Returns:
a list of lines
static List<string> Level9::TextUtils::SplitParagraph | ( | string | paragraph,
 |  | int | numLines,
 |  | int | columns
 | ) |  | [inline, static]

Splits a paragraph into separate lines with a given number of columns.

Parameters:
paragraph | the paragraph string
numLines | the number of lines
columns | the number of columns per line
Returns:
a list of lines
static List<AttributedText> Level9::TextUtils::SplitParagraphs | ( | List< AttributedText > | paragraphs,
 |  | int | lines,
 |  | int | columns,
 |  | bool | topDown
 | ) |  | [inline, static]

Splits a list of paragraphs into separate lines with a given number of columns.

Parameters:
paragraphs | the list of paragraphs
lines | the number of lines
columns | the number of columns per line
topDown | if set to true the paragraphs are handled from top to bottom. If set to false the paragraphs are handled from bottom to top
Returns:
a list of lines
static List<AttributedText> Level9::TextUtils::SplitParagraphs | ( | List< AttributedText > | paragraphs,
 |  | int | lines,
 |  | int | columns,
 |  | TextPosition | offset,
 |  | bool | topDown
 | ) |  | [inline, static]

Splits a list of paragraphs into separate lines with a given number of columns.

Parameters:
paragraphs | the list of paragraphs
lines | the number of lines
columns | the number of columns per line
offset | the offset position in the list of paragraphs (top-down mode only)
topDown | if set to true the paragraphs are handled from top to bottom. If set to false the paragraphs are handled from bottom to top
Returns:
a list of lines
static List<AttributedText> Level9::TextUtils::SplitParagraph | ( | AttributedText | paragraph,
 |  | int | columns,
 |  | int | offset,
 |  | int | paragraphIndex
 | ) |  | [inline, static, private]

Splits a paragraph into separate lines with a given number of columns.

Parameters:
paragraph | the paragraph string
columns | the number of columns per line
offset | the offset position within the paragraph
paragraphIndex | the paragraph's index
Returns:
a list of lines
static string Level9::TextUtils::Substring | ( | string | text,
 |  | string | start,
 |  | string | end
 | ) |  | [inline, static]

Extracts the substring from 'text' that's located between the given strings 'start' and 'end'.

Parameters:
text | the text
start | the start string
end | the end string
Returns:


Level9.Net: Member List

  • TextUtils
Level9::TextUtils Member List
This is the complete list of members for Level9::TextUtils, including all inherited members.
SplitParagraph(string paragraph, int columns) | Level9::TextUtils | [inline, static]
SplitParagraph(string paragraph, int numLines, int columns) | Level9::TextUtils | [inline, static]
SplitParagraph(AttributedText paragraph, int columns, int offset, int paragraphIndex) | Level9::TextUtils | [inline, private, static]
SplitParagraphs(List< AttributedText > paragraphs, int lines, int columns, bool topDown) | Level9::TextUtils | [inline, static]
SplitParagraphs(List< AttributedText > paragraphs, int lines, int columns, TextPosition offset, bool topDown) | Level9::TextUtils | [inline, static]
Substring(string text, string start, string end) | Level9::TextUtils | [inline, static]


Level9.Net: Level9::ToolbarButtonClickedEventArgs Class Reference

  • ToolbarButtonClickedEventArgs
Public Member Functions | Properties | Private Attributes
Level9::ToolbarButtonClickedEventArgs Class Reference

Provides data for the ToolbarButtonClicked event. More...

Collaboration diagram for Level9::ToolbarButtonClickedEventArgs:
[legend]

List of all members.

Public Member Functions

ToolbarButtonClickedEventArgs (SimpleToolBarButton button)

Properties

SimpleToolBarButton | Button [get, set]

Private Attributes

SimpleToolBarButton | button = null

Detailed Description

Constructor & Destructor Documentation

Level9::ToolbarButtonClickedEventArgs::ToolbarButtonClickedEventArgs ( SimpleToolBarButton button ) [inline]

Initializes a new instance of the ToolbarButtonClickedEventArgs class.

Parameters:
button a toolbar button

Member Data Documentation

SimpleToolBarButton Level9::ToolbarButtonClickedEventArgs::button = null [private]

The toolbar button.

Property Documentation

SimpleToolBarButton Level9::ToolbarButtonClickedEventArgs::Button [get, set]

Gets or sets the toolbar button.


Level9.Net: Member List

  • ToolbarButtonClickedEventArgs
Level9::ToolbarButtonClickedEventArgs Member List
This is the complete list of members for Level9::ToolbarButtonClickedEventArgs, including all inherited members.
button | Level9::ToolbarButtonClickedEventArgs | [private]
Button | Level9::ToolbarButtonClickedEventArgs |
ToolbarButtonClickedEventArgs(SimpleToolBarButton button) | Level9::ToolbarButtonClickedEventArgs | [inline]


Level9.Net: Level9::Config::WindowSize Class Reference

  • Config
  • WindowSize
Public Member Functions | Properties | Private Attributes
Level9::Config::WindowSize Class Reference

Represents the size of a window. More...

List of all members.

Public Member Functions

WindowSize (int width, int height)
Size | ToSize ()
void | FromSize (Size size)

Properties

int | Width [get, set]
int | Height [get, set]

Private Attributes

int | width
int | height

Detailed Description

Constructor & Destructor Documentation

Level9::Config::WindowSize::WindowSize | ( | int | width,
 |  | int | height
 | ) |  | [inline]

Initializes a new instance of the WindowSize class.

Parameters:
width | the window width
height | the window height

Member Function Documentation

Size Level9::Config::WindowSize::ToSize ( ) [inline]

Gets the window size.

void Level9::Config::WindowSize::FromSize ( Size size ) [inline]

Sets the window size.

Member Data Documentation

int Level9::Config::WindowSize::width [private]

The window width.

int Level9::Config::WindowSize::height [private]

The window height.

Property Documentation

int Level9::Config::WindowSize::Width [get, set]

Gets or sets the window width.

int Level9::Config::WindowSize::Height [get, set]

Gets or sets the window height.


Level9.Net: Member List

  • Config
  • WindowSize
Level9::Config::WindowSize Member List
This is the complete list of members for Level9::Config::WindowSize, including all inherited members.
FromSize(Size size) | Level9::Config::WindowSize | [inline]
Height | Level9::Config::WindowSize |
height | Level9::Config::WindowSize | [private]
ToSize() | Level9::Config::WindowSize | [inline]
width | Level9::Config::WindowSize | [private]
Width | Level9::Config::WindowSize |
WindowSize(int width, int height) | Level9::Config::WindowSize | [inline]


Level9.Net: Class Index

Class Index
A | B | C | D | E | F | G | I | L | M | N | O | P | S | T | W
A
DictionaryProgressForm (Level9) InputModeEventArgs (Level9) OsDrawLineEventArgs (Level9) ScriptChangedEventArgs (Level9)
AboutForm (Level9)
E
Interpreter (Level9) OsFillEventArgs (Level9) ScriptEntry (Level9)
AttributedText (Level9) ErrorHandler (Level9)
L
OsFlushEventArgs (Level9) ScriptForm (Level9)
B
F
Interpreter::L9BITMAP (Level9) OsGetGameFileEventArgs (Level9) SimpleListView (Level9)
BitmapFont (Level9) FileUtils (Level9) L9Cut (Level9) OsGraphicsEventArgs (Level9) SimpleListViewItem (Level9)
BitmapFontPanel (Level9)
G
L9CutForm (Level9) OsInputEventArgs (Level9) SimpleToolBar (Level9)
BitmapFontRenderer (Level9) GameFileErrorEventArgs (Level9) LexerError (Level9) OsLoadFileEventArgs (Level9) SimpleToolBarButton (Level9)
BitmapFonts (Level9) GameGraphics (Level9) ListViewItemClickedEventArgs (Level9) OsReadcharEventArgs (Level9)
T
C
GamePanel (Level9) Logger (Level9) OsSaveFileEventArgs (Level9) TextForm (Level9)
Config (Level9) GameText (Level9)
M
OsSetColourEventArgs (Level9) TextPosition (Level9)
ConfigChangedEventArgs (Level9) GameThread (Level9) MainForm (Level9) OsShowBitmapEventArgs (Level9) TextUtils (Level9)
ConfigForm (Level9) GraphicsOffEventArgs (Level9)
N
P
ToolbarButtonClickedEventArgs (Level9)
ConfigXML (Level9)
I
NewGameFileEventArgs (Level9) PictureCreatedEventArgs (Level9)
W
D
Images (Level9)
O
S
Config::WindowSize (Level9)
Dictionary (Level9) InputFinishedEventArgs (Level9) OsClearGraphicsEventArgs (Level9) Script (Level9)
A | B | C | D | E | F | G | I | L | M | N | O | P | S | T | W


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- a -

  • AboutForm() : Level9::AboutForm
  • active : Level9::InputModeEventArgs
  • Active : Level9::InputModeEventArgs
  • Add() : Level9::Dictionary
  • AddAttribute() : Level9::AttributedText
  • AddButton() : Level9::SimpleToolBar
  • AddEntry() : Level9::Script
  • AddInputRequest() : Level9::Interpreter
  • AddListViewItem() : Level9::SimpleListView
  • AddToRecentFiles() : Level9::Config
  • amigaPalette : Level9::Config
  • AmigaPalette : Level9::Config
  • ANTLR_DLL : Level9::Config
  • Append()
: Level9::AttributedText
, Level9::GameText
, Level9::AttributedText
  • AppendText() : Level9::TextForm
  • ApplicationExit()
: Level9::GameGraphics
, Level9::MainForm
  • ATTR_INPUT_CARET : Level9::AttributedText
  • ATTR_INPUT_END : Level9::AttributedText
  • ATTR_INPUT_START : Level9::AttributedText
  • AttributedText() : Level9::AttributedText
  • Attributes : Level9::AttributedText
  • attributes : Level9::AttributedText


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- j -

  • Join() : Level9::GameThread


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- k -

  • keys : Level9::Dictionary


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- l -

  • L9_DecodeBitmap() : Level9::Interpreter
  • L9_DetectBitmaps() : Level9::Interpreter
  • L9_FreeMemory() : Level9::Interpreter
  • L9_GetPictureSize() : Level9::Interpreter
  • L9_LoadGame() : Level9::Interpreter
  • L9_RestoreGame() : Level9::Interpreter
  • L9_RunGame() : Level9::Interpreter
  • L9_RunGraphics() : Level9::Interpreter
  • L9_SetCallbackFunctions() : Level9::Interpreter
  • L9_StopGame() : Level9::Interpreter
  • L9CUT_DETECTED_DATAFILES : Level9::L9Cut
  • L9CUT_EXE : Level9::Config
  • L9CUT_MISSING_DATAFILES : Level9::L9Cut
  • L9CUT_MISSING_PATCHES : Level9::L9Cut
  • L9CUT_NO : Level9::L9Cut
  • L9CUT_YES : Level9::L9Cut
  • L9CutForm() : Level9::L9CutForm
  • LabelLinkLinkClicked() : Level9::AboutForm
  • LabelTextColorPreviewClick() : Level9::ConfigForm
  • LabelUserColorClick() : Level9::ConfigForm
  • LEVEL9_DLL : Level9::Config
  • LexerError() : Level9::LexerError
  • line : Level9::LexerError
  • Line : Level9::LexerError
  • line_spacing : Level9::ConfigXML
  • lineSpacing
: Level9::BitmapFontRenderer
, Level9::BitmapFontPanel
, Level9::Config
  • LineSpacing : Level9::BitmapFontPanel , Level9::Config
  • lineSpacings : Level9::Config
  • LineSpacings : Level9::Config
  • listViewButtonColors : Level9::ConfigForm
  • listViewButtonFont : Level9::ConfigForm
  • listViewButtonGraphics : Level9::ConfigForm
  • ListViewItemClickedEventArgs() : Level9::ListViewItemClickedEventArgs
  • listViewItems : Level9::SimpleListView
  • Load() : Level9::Script
  • LoadGame()
: Level9::MainForm
, Level9::Interpreter
  • Log() : Level9::Logger
  • LOG_FILE : Level9::Config
  • loggingEnabled : Level9::Config
  • LoggingEnabled : Level9::Config


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- m -

  • Main() : Level9::MainForm
  • MainForm() : Level9::MainForm
  • MainFormActivated() : Level9::MainForm
  • MainFormFormClosed() : Level9::MainForm
  • MainFormToolBarButtonClicked() : Level9::MainForm
  • MASK_FORECOLOR : Level9::BitmapFontRenderer
  • MASK_INPUTCOLOR : Level9::BitmapFontRenderer
  • MASK_INPUTCOLOR_INV : Level9::BitmapFontRenderer
  • MAX_COMMANDS_HISTORY : Level9::GameText
  • MAX_LENGTH_INPUT : Level9::GameText
  • MAX_RECENT_FILES : Level9::Config
  • maxBytes : Level9::OsLoadFileEventArgs
  • MaxBytes : Level9::OsLoadFileEventArgs
  • maxIconHeight : Level9::SimpleToolBar
  • MenuItemAboutClick() : Level9::MainForm
  • MenuItemClearClick() : Level9::ScriptForm
  • MenuItemCloseClick()
: Level9::ScriptForm
, Level9::TextForm
  • MenuItemCopyClick()
: Level9::ScriptForm
, Level9::TextForm
  • MenuItemDictionaryClick() : Level9::MainForm
  • MenuItemExitClick() : Level9::MainForm
  • MenuItemFullscreenClick() : Level9::MainForm
  • MenuItemIncludeCommentsClick() : Level9::ScriptForm
  • MenuItemL9CutClick() : Level9::MainForm
  • MenuItemL9netHelpClick() : Level9::MainForm
  • MenuItemLoadClick() : Level9::ScriptForm
  • MenuItemLoadGameClick() : Level9::MainForm
  • MenuItemOneEntryPerLineClick() : Level9::ScriptForm
  • MenuItemPlaybackClick() : Level9::MainForm
  • MenuItemRecentFileClick() : Level9::MainForm
  • MenuItemReloadCurrentGameClick() : Level9::MainForm
  • MenuItemRestorePosClick() : Level9::MainForm
  • MenuItemSaveClick()
: Level9::ScriptForm
, Level9::TextForm
  • MenuItemSavePosClick() : Level9::MainForm
  • MenuItemSaveScreenshotClick() : Level9::MainForm
  • MenuItemScriptRecordingClick() : Level9::MainForm
  • MenuItemScrollbackClick() : Level9::MainForm
  • MenuItemSettingsClick() : Level9::MainForm
  • MenuItemStatusBarClick() : Level9::MainForm
  • MenuItemTimerClick() : Level9::MainForm
  • MenuItemTitleBarClick() : Level9::MainForm
  • MenuItemToolBarClick() : Level9::MainForm
  • Message : Level9::LexerError
  • message : Level9::LexerError
  • millis : Level9::OsReadcharEventArgs
  • Millis : Level9::OsReadcharEventArgs
  • mode : Level9::OsGraphicsEventArgs
  • Mode : Level9::OsGraphicsEventArgs
  • moreLines : Level9::GamePanel , Level9::InputModeEventArgs
  • MoreLines : Level9::InputModeEventArgs


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- n -

  • NewGameFile : Level9::Interpreter
  • NewGameFileEventArgs() : Level9::NewGameFileEventArgs
  • npalette : Level9::Interpreter::L9BITMAP
  • number : Level9::OsShowBitmapEventArgs
  • Number : Level9::OsShowBitmapEventArgs


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- o -

  • OFDDataFiles() : Level9::FileUtils
  • OFDGameFiles() : Level9::FileUtils
  • OFDSavedGameFiles() : Level9::FileUtils
  • OFDTextFiles() : Level9::FileUtils
  • offsetPos : Level9::GameText
  • OnGotFocus() : Level9::GamePanel
  • OnKeyDown() : Level9::GamePanel
  • OnKeyPress() : Level9::GamePanel
  • OnLostFocus() : Level9::GamePanel
  • OnMouseDown()
: Level9::SimpleListView
, Level9::SimpleToolBar
  • OnMouseLeave() : Level9::SimpleToolBar
  • OnMouseMove() : Level9::SimpleToolBar
  • OnMouseUp() : Level9::SimpleToolBar
  • OnPaint()
: Level9::GamePanel
, Level9::SimpleListView
, Level9::SimpleToolBar
, Level9::BitmapFontPanel
  • OnPaintBackground() : Level9::GamePanel
  • OnSizeChanged() : Level9::GamePanel
  • Origin : Level9::AttributedText
  • origin : Level9::AttributedText
  • OS_CLEARGRAPHICS() : Level9::Interpreter
  • os_cleargraphics() : Level9::Interpreter
  • os_drawline() : Level9::Interpreter
  • OS_DRAWLINE() : Level9::Interpreter
  • os_fill() : Level9::Interpreter
  • OS_FILL() : Level9::Interpreter
  • OS_FLUSH() : Level9::Interpreter
  • os_flush() : Level9::Interpreter
  • os_get_game_file() : Level9::Interpreter
  • OS_GET_GAME_FILE() : Level9::Interpreter
  • os_graphics() : Level9::Interpreter
  • OS_GRAPHICS() : Level9::Interpreter
  • OS_INPUT() : Level9::Interpreter
  • os_input() : Level9::Interpreter
  • OS_LOAD_FILE() : Level9::Interpreter
  • os_load_file() : Level9::Interpreter
  • OS_PRINTCHAR() : Level9::Interpreter
  • os_printchar() : Level9::Interpreter
  • os_readchar() : Level9::Interpreter
  • OS_READCHAR() : Level9::Interpreter
  • OS_SAVE_FILE() : Level9::Interpreter
  • os_save_file() : Level9::Interpreter
  • OS_SET_FILENUMBER() : Level9::Interpreter
  • os_set_filenumber() : Level9::Interpreter
  • OS_SETCOLOUR() : Level9::Interpreter
  • os_setcolour() : Level9::Interpreter
  • OS_SHOW_BITMAP() : Level9::Interpreter
  • os_show_bitmap() : Level9::Interpreter
  • OsClearGraphics : Level9::Interpreter
  • OsClearGraphicsEventArgs() : Level9::OsClearGraphicsEventArgs
  • OsDrawLine : Level9::Interpreter
  • OsDrawLineEventArgs() : Level9::OsDrawLineEventArgs
  • OsFill : Level9::Interpreter
  • OsFillEventArgs() : Level9::OsFillEventArgs
  • OsFlush : Level9::Interpreter
  • OsFlushEventArgs() : Level9::OsFlushEventArgs
  • osFlushHandler : Level9::DictionaryProgressForm
  • OsGetGameFile : Level9::Interpreter
  • OsGetGameFileEventArgs() : Level9::OsGetGameFileEventArgs
  • OsGraphics : Level9::Interpreter
  • OsGraphicsEventArgs() : Level9::OsGraphicsEventArgs
  • OsInput : Level9::Interpreter
  • OsLoadFile : Level9::Interpreter
  • OsLoadFileEventArgs() : Level9::OsLoadFileEventArgs
  • OsReadchar : Level9::Interpreter
  • OsReadcharEventArgs() : Level9::OsReadcharEventArgs
  • OsSaveFile : Level9::Interpreter
  • OsSaveFileEventArgs() : Level9::OsSaveFileEventArgs
  • OsSetColour : Level9::Interpreter
  • OsSetColourEventArgs() : Level9::OsSetColourEventArgs
  • OsShowBitmap : Level9::Interpreter
  • OsShowBitmapEventArgs() : Level9::OsShowBitmapEventArgs
  • output : Level9::Dictionary , Level9::GameText
  • outputBuffer : Level9::Interpreter


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- b -

  • back_color : Level9::ConfigXML
  • backColor : Level9::Config
  • BackColor : Level9::Config
  • bar_back_color : Level9::ConfigXML
  • BAR_ELEMENT_SPACING : Level9::GamePanel
  • bar_text_color : Level9::ConfigXML
  • BAR_XY_SPACING : Level9::GamePanel , Level9::BitmapFontPanel
  • barBackColor : Level9::Config
  • BarBackColor : Level9::Config
  • barTextColor : Level9::Config
  • BarTextColor : Level9::Config
  • bitmap : Level9::BitmapFont , Level9::Interpreter::L9BITMAP
  • Bitmap : Level9::BitmapFont
  • BitmapFont : Level9::BitmapFontPanel , Level9::BitmapFont
  • bitmapFont : Level9::BitmapFontPanel
  • BitmapFontPanel() : Level9::BitmapFontPanel
  • BitmapFonts() : Level9::BitmapFonts
  • bitmapFonts : Level9::BitmapFonts
  • bitmapNumber : Level9::GameGraphics
  • bitmapsDetected : Level9::GameGraphics
  • BORDER_SPACING : Level9::SimpleListView , Level9::SimpleToolBar
  • Button : Level9::ToolbarButtonClickedEventArgs
  • button : Level9::ToolbarButtonClickedEventArgs
  • ButtonBrowseInputClick() : Level9::L9CutForm
  • ButtonBrowseOutputClick() : Level9::L9CutForm
  • ButtonCancelClick() : Level9::ConfigForm
  • ButtonClicked : Level9::SimpleToolBar
  • ButtonCloseClick() : Level9::L9CutForm
  • ButtonExecuteClick() : Level9::L9CutForm
  • ButtonNextClick()
: Level9::ScriptForm
, Level9::TextForm
  • ButtonOKClick() : Level9::ConfigForm
  • ButtonPlaybackPlayClick() : Level9::MainForm
  • ButtonPlaybackStopClick() : Level9::MainForm
  • ButtonPreviousClick()
: Level9::TextForm
, Level9::ScriptForm
  • ButtonRecordClick() : Level9::ScriptForm
  • Bytes : Level9::OsLoadFileEventArgs
  • bytes : Level9::OsLoadFileEventArgs , Level9::OsSaveFileEventArgs
  • Bytes : Level9::OsSaveFileEventArgs
  • BytesToString() : Level9::Interpreter


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- c -

  • callbacks : Level9::Interpreter
  • CAPTION_SPACING : Level9::SimpleListView
  • CaretBack() : Level9::GameText
  • CaretDelete() : Level9::GameText
  • CaretEnd() : Level9::GameText
  • CaretHome() : Level9::GameText
  • CaretIns() : Level9::GameText
  • CaretLeft() : Level9::GameText
  • caretPos : Level9::GameText
  • CaretRight() : Level9::GameText
  • character : Level9::OsReadcharEventArgs
  • Character : Level9::OsReadcharEventArgs
  • checkExecute : Level9::L9CutForm
  • CheckExecuteExtract() : Level9::L9CutForm
  • CheckExecuteLists() : Level9::L9CutForm
  • CheckL9Cut() : Level9::L9Cut
  • Clear()
: Level9::GameText
, Level9::Script
, Level9::TextForm
, Level9::TextPosition
  • ClearCaretInParagraphs() : Level9::GameText
  • client_height : Level9::ConfigXML
  • client_width : Level9::ConfigXML
  • clientSize : Level9::Config
  • ClientSize : Level9::Config
  • colour : Level9::OsSetColourEventArgs
  • Colour : Level9::OsSetColourEventArgs
  • Colour1 : Level9::OsFillEventArgs
  • colour1 : Level9::OsDrawLineEventArgs , Level9::OsFillEventArgs
  • Colour1 : Level9::OsDrawLineEventArgs
  • colour2 : Level9::OsDrawLineEventArgs , Level9::OsFillEventArgs
  • Colour2 : Level9::OsDrawLineEventArgs , Level9::OsFillEventArgs
  • column : Level9::LexerError , Level9::TextPosition
  • Column : Level9::LexerError , Level9::TextPosition
  • ComboBoxFontTypeSelectedIndexChanged() : Level9::ConfigForm
  • Command : Level9::OsFlushEventArgs
  • command : Level9::OsFlushEventArgs
  • COMMAND_LINE_LOGGING : Level9::MainForm
  • commandHistory : Level9::GameText
  • commandHistoryPos : Level9::GameText
  • Commands : Level9::Interpreter
  • commands : Level9::Interpreter
  • Comment : Level9::Script
  • comment : Level9::Script , Level9::ScriptEntry
  • Comment : Level9::ScriptEntry
  • CompareTo() : Level9::TextPosition
  • components
: Level9::ScriptForm
, Level9::AboutForm
, Level9::ConfigForm
, Level9::MainForm
, Level9::TextForm
, Level9::DictionaryProgressForm
, Level9::L9CutForm
  • Config() : Level9::Config
  • ConfigChanged
: Level9::Config
, Level9::GamePanel
, Level9::GameGraphics
  • ConfigChangedEventArgs() : Level9::ConfigChangedEventArgs
  • ConfigForm() : Level9::ConfigForm
  • ConfigXML() : Level9::ConfigXML
  • ContextMenuStripScriptOpening() : Level9::ScriptForm
  • Copy() : Level9::TextPosition
  • Create() : Level9::Script
  • CreateBitmapImage() : Level9::GameGraphics
  • CreateLineDrawnImage() : Level9::GameGraphics
  • CreateOutput() : Level9::Dictionary
  • currentCommand : Level9::Interpreter


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- d -

  • DataGridViewScriptCellMouseDown() : Level9::ScriptForm
  • DataGridViewScriptCellValueNeeded() : Level9::ScriptForm
  • DataGridViewScriptCellValuePushed() : Level9::ScriptForm
  • DecodeBitmap() : Level9::Interpreter
  • DEFAULT_OUTPUT_FILE : Level9::L9CutForm
  • DeleteRowToolStripMenuItemClick() : Level9::ScriptForm
  • DetectBitmaps() : Level9::Interpreter
  • dialogSize : Level9::TextForm
  • dict_viewer_height : Level9::ConfigXML
  • dict_viewer_width : Level9::ConfigXML
  • Dictionary() : Level9::Dictionary
  • dictionary : Level9::Dictionary
  • DICTIONARY_FLUSH : Level9::Interpreter
  • DictionaryProgressForm() : Level9::DictionaryProgressForm
  • dictionaryView : Level9::Dictionary
  • dictViewerSize : Level9::Config
  • DictViewerSize : Level9::Config
  • Dispose()
: Level9::AboutForm
, Level9::BitmapFontPanel
, Level9::ConfigForm
, Level9::DictionaryProgressForm
, Level9::GamePanel
, Level9::ScriptForm
, Level9::MainForm
, Level9::TextForm
, Level9::L9CutForm
  • disposeOnClose : Level9::TextForm
  • DomainUpDownFontScalingSelectedItemChanged() : Level9::ConfigForm
  • DomainUpDownInputDelayEnter() : Level9::MainForm
  • DomainUpDownInputDelaySelectedItemChanged() : Level9::MainForm
  • DomainUpDownLineSpacingSelectedItemChanged() : Level9::ConfigForm
  • drawingThread : Level9::GameGraphics
  • DrawingThreadProc() : Level9::GameGraphics
  • DrawLineIf() : Level9::GameGraphics
  • DUMMY_DAT : Level9::L9Cut


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- e -

  • empty : Level9::Dictionary
  • enabled : Level9::SimpleToolBarButton
  • Enabled : Level9::SimpleToolBarButton
  • EnabledChanged : Level9::SimpleToolBarButton
  • endIndex : Level9::Script
  • EndIndex : Level9::Script
  • entries : Level9::Script
  • EntryMatch() : Level9::Script
  • Equals()
: Level9::BitmapFont
, Level9::TextPosition
, Level9::AttributedText
  • Errors : Level9::Script
  • errors : Level9::Script
  • ExecL9Cut() : Level9::L9Cut
  • ExtractDatafile() : Level9::L9Cut


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- f -

  • filename : Level9::OsGetGameFileEventArgs
  • Filename : Level9::OsGetGameFileEventArgs
  • FILTER_DATA_FILES : Level9::FileUtils
  • FILTER_GAME_FILES : Level9::FileUtils
  • FILTER_PNG_FILES : Level9::FileUtils
  • FILTER_SAVED_GAME_FILES : Level9::FileUtils
  • FILTER_TXT_FILES : Level9::FileUtils
  • FindText()
: Level9::Script
, Level9::ScriptForm
, Level9::TextForm
  • FireConfigChanged() : Level9::Config
  • fireEvents : Level9::Script
  • FireInputModeEvent() : Level9::GamePanel
  • FireInputModeEventDelegate() : Level9::GamePanel
  • FireScriptChanged() : Level9::Script
  • FloodFillIf() : Level9::GameGraphics
  • font : Level9::BitmapFontRenderer , Level9::Config
  • Font : Level9::Config
  • font_scaling : Level9::ConfigXML
  • font_type : Level9::ConfigXML
  • fontRenderer : Level9::BitmapFontPanel
  • fontScaling : Level9::Config
  • FontScaling : Level9::Config
  • FontScalings : Level9::BitmapFonts
  • fontScalings : Level9::BitmapFonts
  • FontTypes : Level9::BitmapFonts
  • fontTypes : Level9::BitmapFonts
  • FreeMemory() : Level9::Interpreter
  • FromSize() : Level9::Config::WindowSize


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- g -

  • GameFileError : Level9::Interpreter
  • GameFileErrorEventArgs() : Level9::GameFileErrorEventArgs
  • GameFilePath : Level9::Interpreter
  • gameFilePath : Level9::Interpreter
  • gameGraphics : Level9::GamePanel
  • GameGraphics() : Level9::GameGraphics
  • GameGraphicsGraphicsOff() : Level9::GamePanel
  • GameGraphicsPictureCreated() : Level9::GamePanel
  • GamePanel() : Level9::GamePanel
  • GamePanelClick() : Level9::MainForm
  • GamePanelDragDrop() : Level9::MainForm
  • GamePanelDragEnter() : Level9::MainForm
  • GamePanelInputMode() : Level9::MainForm
  • gameStart : Level9::GamePanel
  • GameText() : Level9::GameText
  • gameText : Level9::GamePanel
  • gameThread : Level9::GameThread
  • gameTimer : Level9::GamePanel
  • gameTitle : Level9::Interpreter
  • GameTitle : Level9::Interpreter
  • Get()
: Level9::BitmapFonts
, Level9::Images
  • GetActivePalette() : Level9::Config
  • GetAntlrPath() : Level9::Config
  • GetAppDataPath() : Level9::Config
  • GetButtonByPoint() : Level9::SimpleToolBar
  • GetButtonRect() : Level9::SimpleToolBar
  • GetCaptionWidth() : Level9::SimpleListView
  • GetClientSizeString() : Level9::GamePanel
  • GetClipboardText() : Level9::GamePanel
  • GetConfigFilePath() : Level9::Config
  • GetDetectedDatafiles() : Level9::L9Cut
  • GetEntriesCount() : Level9::Script
  • GetEntryAt() : Level9::Script
  • GetGameTitle() : Level9::L9Cut
  • GetHashCode()
: Level9::BitmapFont
, Level9::TextPosition
, Level9::AttributedText
  • GetHelpFilePath() : Level9::Config
  • GetInput() : Level9::GameText
  • GetItemByPoint() : Level9::SimpleListView
  • GetItemRect() : Level9::SimpleListView
  • GetL9CutPath() : Level9::Config
  • GetLength() : Level9::AttributedText
  • GetLevel9DLLPath() : Level9::Config
  • GetLogFilePath() : Level9::Config
  • GetMissingDatafiles() : Level9::L9Cut
  • GetMissingPatches() : Level9::L9Cut
  • GetNextInput() : Level9::Script
  • GetOpenFile() : Level9::FileUtils
  • GetOutput() : Level9::GameText
  • GetOutputLinesCount() : Level9::GameText
  • GetParagraphCount() : Level9::GameText
  • GetPictureSize() : Level9::Interpreter
  • GetRange() : Level9::AttributedText
  • GetSaveFile() : Level9::FileUtils
  • GetStatusString() : Level9::GamePanel
  • GetTextLength() : Level9::TextForm
  • GetTimerString() : Level9::GamePanel
  • graphicsMode : Level9::GameGraphics
  • GraphicsMode : Level9::GameGraphics
  • GraphicsOff : Level9::GameGraphics
  • GraphicsOffEventArgs() : Level9::GraphicsOffEventArgs
  • greyScaleMatrix : Level9::SimpleToolBar


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- h -

  • H_OFFSET : Level9::SimpleToolBar
  • H_SPACING : Level9::SimpleToolBar
  • Handle() : Level9::ErrorHandler
  • height : Level9::Config::WindowSize , Level9::Interpreter::L9BITMAP
  • Height : Level9::BitmapFont
  • height : Level9::BitmapFont
  • Height : Level9::Config::WindowSize
  • HELP_FILE : Level9::Config
  • HideCaret() : Level9::GameText
  • HistoryDown() : Level9::GameText
  • HistoryUp() : Level9::GameText


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- i -

  • image : Level9::SimpleListViewItem , Level9::SimpleToolBarButton
  • Image : Level9::SimpleToolBarButton , Level9::SimpleListViewItem
  • image_scaling : Level9::ConfigXML
  • images : Level9::Images
  • Images() : Level9::Images
  • imageScaling : Level9::Config
  • ImageScaling : Level9::Config
  • imageScalings : Level9::Config
  • ImageScalings : Level9::Config
  • index : Level9::OsSetColourEventArgs
  • Index : Level9::OsSetColourEventArgs
  • InitializeComponent()
: Level9::DictionaryProgressForm
, Level9::L9CutForm
, Level9::MainForm
, Level9::ScriptForm
, Level9::TextForm
, Level9::AboutForm
, Level9::ConfigForm
  • input
: Level9::OsInputEventArgs
, Level9::InputFinishedEventArgs
, Level9::ScriptEntry
  • Input
: Level9::OsInputEventArgs
, Level9::InputFinishedEventArgs
, Level9::ScriptEntry
  • input_color : Level9::ConfigXML
  • inputArgs : Level9::GamePanel
  • inputColor : Level9::Config
  • InputColor : Level9::BitmapFontPanel , Level9::Config
  • inputColor : Level9::BitmapFontPanel
  • InputFinished : Level9::Interpreter
  • InputFinishedEventArgs() : Level9::InputFinishedEventArgs
  • inputMode : Level9::GamePanel
  • InputMode : Level9::GamePanel
  • inputModeArgs : Level9::GamePanel , Level9::MainForm
  • InputModeEventArgs() : Level9::InputModeEventArgs
  • inputPos : Level9::GameText
  • inputRequests : Level9::Interpreter
  • Insert() : Level9::AttributedText
  • InsertEntry() : Level9::Script
  • InsertRowAfterToolStripMenuItemClick() : Level9::ScriptForm
  • InsertRowToolStripMenuItemClick() : Level9::ScriptForm
  • instance
: Level9::Config
, Level9::Dictionary
, Level9::Script
  • Instance
: Level9::Config
, Level9::Dictionary
, Level9::Script
  • Interpreter() : Level9::Interpreter
  • InterpreterGameFileError()
: Level9::MainForm
, Level9::GamePanel
  • InterpreterInputFinished() : Level9::Script
  • InterpreterNewGameFile()
: Level9::GamePanel
, Level9::Dictionary
, Level9::GameGraphics
, Level9::MainForm
  • InterpreterOsClearGraphics() : Level9::GameGraphics
  • InterpreterOsDrawLine() : Level9::GameGraphics
  • InterpreterOsFill() : Level9::GameGraphics
  • InterpreterOsFlush()
: Level9::DictionaryProgressForm
, Level9::GamePanel
  • InterpreterOsGetGameFile() : Level9::MainForm
  • InterpreterOsGraphics() : Level9::GameGraphics
  • InterpreterOsInput()
: Level9::GameGraphics
, Level9::GamePanel
  • InterpreterOsLoadFile() : Level9::MainForm
  • InterpreterOsReadchar()
: Level9::GamePanel
, Level9::GameGraphics
  • InterpreterOsSaveFile() : Level9::MainForm
  • InterpreterOsSetColour() : Level9::GameGraphics
  • InterpreterOsShowBitmap() : Level9::GameGraphics
  • InvalidateButton() : Level9::SimpleToolBar
  • InvalidateItem() : Level9::SimpleListView
  • IsInitialized() : Level9::Config
  • isplaying : Level9::Script
  • IsPlaying : Level9::Script
  • IsRecording : Level9::Script
  • isrecording : Level9::Script
  • IsRunning : Level9::GameThread
  • isRunning : Level9::GameThread
  • IsSeparator : Level9::SimpleToolBarButton
  • isSleeping : Level9::GameThread
  • IsSleeping : Level9::GameThread
  • item : Level9::ListViewItemClickedEventArgs
  • Item : Level9::ListViewItemClickedEventArgs
  • ItemClicked : Level9::SimpleListView


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- p -

  • Palette : Level9::Config
  • palette : Level9::GameGraphics , Level9::Interpreter::L9BITMAP
  • palette_selection : Level9::ConfigXML
  • paletteSelection : Level9::Config
  • PaletteSelection : Level9::Config
  • Paragraph : Level9::TextPosition
  • paragraph : Level9::TextPosition
  • Paragraphs : Level9::BitmapFontPanel , Level9::GameText
  • paragraphs : Level9::BitmapFontPanel , Level9::GameText
  • pause : Level9::ScriptEntry
  • Pause : Level9::ScriptEntry
  • picture : Level9::PictureCreatedEventArgs , Level9::GamePanel
  • Picture : Level9::PictureCreatedEventArgs
  • PictureCreated : Level9::GameGraphics
  • PictureCreatedEventArgs() : Level9::PictureCreatedEventArgs
  • pictureSize : Level9::GameGraphics
  • pixels : Level9::GameGraphics
  • PlaybackEndToolStripMenuItemClick() : Level9::ScriptForm
  • PlaybackPauseToolStripMenuItemClick() : Level9::ScriptForm
  • PlaybackPos : Level9::Script
  • playbackPos : Level9::Script
  • PlaybackStartToolStripMenuItemClick() : Level9::ScriptForm
  • pressed : Level9::SimpleToolBar
  • prevSize : Level9::MainForm
  • PROGRAM_NAME : Level9::Config
  • PROGRAM_VERSION : Level9::Config


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- r -

  • RadioButtonDetectedDatafilesCheckedChanged() : Level9::L9CutForm
  • RadioButtonMissingDatafilesCheckedChanged() : Level9::L9CutForm
  • RadioButtonMissingPatchesCheckedChanged() : Level9::L9CutForm
  • readcharArgs : Level9::GamePanel , Level9::Interpreter
  • ReadSettings() : Level9::Config
  • RecallCommand() : Level9::GameText
  • recent_files : Level9::ConfigXML
  • RecentFiles : Level9::Config
  • recentFiles : Level9::Config
  • REGION_ALL : Level9::GamePanel
  • REGION_PICTURE : Level9::GamePanel
  • REGION_STATUS : Level9::GamePanel
  • REGION_TEXT : Level9::GamePanel
  • REGION_TIMER : Level9::GamePanel
  • REGION_TITLE_BAR : Level9::GamePanel
  • RemoveAttribute() : Level9::AttributedText
  • RemoveControlMark() : Level9::Script
  • RemoveControlMarkToolStripMenuItemClick() : Level9::ScriptForm
  • RemoveEntry() : Level9::Script
  • RemoveRange() : Level9::AttributedText
  • RenderText() : Level9::BitmapFontRenderer
  • resources : Level9::Images , Level9::BitmapFonts
  • RestoreGame() : Level9::Interpreter
  • Resume() : Level9::GameThread
  • RunGame() : Level9::Interpreter
  • RunGraphics() : Level9::Interpreter


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- s -

  • SaveScreenshot() : Level9::GamePanel
  • ScaleBitmap() : Level9::GameGraphics
  • screenBitmap : Level9::GamePanel
  • Script() : Level9::Script
  • SCRIPT_COMMAND_BRACKET_BEGIN : Level9::Script
  • SCRIPT_COMMAND_BRACKET_END : Level9::Script
  • SCRIPT_COMMAND_SEPARATOR : Level9::Script
  • SCRIPT_COMMENT : Level9::Script
  • script_editor_height : Level9::ConfigXML
  • script_editor_width : Level9::ConfigXML
  • script_include_comments : Level9::ConfigXML
  • script_input_delay : Level9::ConfigXML
  • SCRIPT_LINE_LENGTH : Level9::Script
  • SCRIPT_NEWLINE : Level9::Script
  • script_one_entry_per_line : Level9::ConfigXML
  • SCRIPT_TITLE : Level9::Script
  • ScriptChanged
: Level9::Script
, Level9::MainForm
, Level9::ScriptForm
  • ScriptChangedEventArgs() : Level9::ScriptChangedEventArgs
  • scriptChangedHandler : Level9::ScriptForm
  • scriptEditorSize : Level9::Config
  • ScriptEditorSize : Level9::Config
  • ScriptEntry() : Level9::ScriptEntry
  • scriptForm : Level9::MainForm
  • ScriptForm() : Level9::ScriptForm
  • ScriptFormFormClosing() : Level9::ScriptForm
  • ScriptFormKeyDown() : Level9::ScriptForm
  • ScriptIncludeComments : Level9::Config
  • scriptIncludeComments : Level9::Config
  • ScriptInputDelay : Level9::Config
  • scriptInputDelay : Level9::Config
  • ScriptInputDelays : Level9::Config
  • scriptInputDelays : Level9::Config
  • scriptInputModeEventTs : Level9::MainForm
  • scriptOneEntryPerLine : Level9::Config
  • ScriptOneEntryPerLine : Level9::Config
  • scriptTimer : Level9::MainForm
  • ScriptTimerTick() : Level9::MainForm
  • scrollbackView : Level9::GameText
  • selected : Level9::SimpleListView , Level9::SimpleToolBar
  • separator : Level9::SimpleToolBarButton
  • Separator : Level9::SimpleToolBarButton
  • SEPARATOR_WIDTH : Level9::SimpleToolBar
  • SetCaretInParagraphs() : Level9::GameText
  • SetCaretPosition() : Level9::TextForm
  • SetCommentAt() : Level9::Script
  • SetConfigurationValues() : Level9::ConfigForm
  • SetGameFile() : Level9::Interpreter
  • SetInputAt() : Level9::Script
  • SetInputPosition() : Level9::GameText
  • SetMembers() : Level9::Config
  • SetPauseAt() : Level9::Script
  • SetSelectedItem() : Level9::SimpleListView
  • SetTextOffset() : Level9::GameText
  • SETTINGS_FILE : Level9::Config
  • SFDDataFiles() : Level9::FileUtils
  • SFDPngFiles() : Level9::FileUtils
  • SFDSavedGameFiles() : Level9::FileUtils
  • SFDTextFiles() : Level9::FileUtils
  • Show() : Level9::Dictionary
  • show_script_playback : Level9::ConfigXML
  • show_status_bar : Level9::ConfigXML
  • show_timer : Level9::ConfigXML
  • show_title_bar : Level9::ConfigXML
  • show_toolbar : Level9::ConfigXML
  • ShowCaret() : Level9::GameText
  • ShowScriptPlayback : Level9::Config
  • showScriptPlayback : Level9::Config
  • ShowScrollback()
: Level9::GamePanel
, Level9::GameText
  • showStatusBar : Level9::Config
  • ShowStatusBar : Level9::Config
  • ShowTimer : Level9::Config
  • showTimer : Level9::Config
  • showTitle : Level9::GameGraphics
  • showTitleBar : Level9::Config
  • ShowTitleBar : Level9::Config
  • showToolbar : Level9::Config
  • ShowToolbar : Level9::Config
  • SimpleListView() : Level9::SimpleListView
  • SimpleListViewButtonClicked() : Level9::ConfigForm
  • SimpleListViewItem() : Level9::SimpleListViewItem
  • SimpleToolBar() : Level9::SimpleToolBar
  • SimpleToolBarButton() : Level9::SimpleToolBarButton
  • SimulateKey() : Level9::GamePanel
  • SimulateKeys() : Level9::GamePanel
  • size : Level9::BitmapFont
  • Size : Level9::BitmapFont
  • sizeBitmap : Level9::GamePanel
  • sizeRenderer : Level9::GamePanel
  • sizes : Level9::BitmapFonts
  • Sleep() : Level9::GameThread
  • SpectrumPalette : Level9::Config
  • spectrumPalette : Level9::Config
  • split : Level9::Dictionary
  • SplitParagraph() : Level9::TextUtils
  • SplitParagraphs() : Level9::TextUtils
  • Start() : Level9::GameThread
  • StartDrawingThread() : Level9::GameGraphics
  • startIndex : Level9::Script
  • StartIndex : Level9::Script
  • StartPlayback() : Level9::Script
  • StartRecording() : Level9::Script
  • statusBitmap : Level9::GamePanel
  • statusRenderer : Level9::GamePanel
  • Stock : Level9::Images
  • Stop() : Level9::GameThread
  • StopDrawingThread() : Level9::GameGraphics
  • StopGame() : Level9::Interpreter
  • StopPlayback() : Level9::Script
  • StopRecording() : Level9::Script
  • stopRequest : Level9::GameThread
  • StopRequest : Level9::GameThread
  • StoreConfig() : Level9::ConfigForm
  • StringToBytes() : Level9::Interpreter
  • Substring() : Level9::TextUtils
  • Success : Level9::OsGetGameFileEventArgs , Level9::OsLoadFileEventArgs
  • success : Level9::OsSaveFileEventArgs , Level9::OsGetGameFileEventArgs
  • Success : Level9::OsSaveFileEventArgs
  • success : Level9::OsLoadFileEventArgs
  • sw : Level9::Logger


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- t -

  • text : Level9::OsFlushEventArgs , Level9::SimpleListViewItem
  • Text : Level9::BitmapFontPanel , Level9::OsFlushEventArgs
  • text : Level9::AttributedText
  • Text : Level9::SimpleListViewItem , Level9::AttributedText
  • text_color : Level9::ConfigXML
  • text_viewer_height : Level9::ConfigXML
  • text_viewer_width : Level9::ConfigXML
  • TEXT_X_SPACING : Level9::BitmapFontPanel , Level9::GamePanel
  • TEXT_Y_SPACING : Level9::BitmapFontPanel , Level9::GamePanel
  • textBitmap
: Level9::BitmapFontRenderer
, Level9::GamePanel
, Level9::BitmapFontPanel
  • TextBoxCommentLeave() : Level9::ScriptForm
  • TextBoxFindTextChanged()
: Level9::ScriptForm
, Level9::TextForm
  • TextBoxInputTextChanged() : Level9::L9CutForm
  • TextBoxOutputTextChanged() : Level9::L9CutForm
  • TextBoxScriptStatusEnter() : Level9::MainForm
  • TextBoxTitleLeave() : Level9::ScriptForm
  • textColor : Level9::Config
  • TextColor : Level9::Config
  • TextForm() : Level9::TextForm
  • TextFormFormClosing() : Level9::TextForm
  • TextFormKeyDown() : Level9::TextForm
  • TextPosition() : Level9::TextPosition
  • textRenderer : Level9::GamePanel
  • textViewerSize : Level9::Config
  • TextViewerSize : Level9::Config
  • ThreadProc() : Level9::GameThread
  • threadStopSignal : Level9::GameGraphics
  • timer : Level9::ScriptForm
  • timerBitmap : Level9::GamePanel
  • timerRenderer : Level9::GamePanel
  • timerString : Level9::GamePanel
  • TimerTick()
: Level9::GamePanel
, Level9::ScriptForm
  • Timestamp : Level9::InputModeEventArgs
  • timestamp : Level9::InputModeEventArgs
  • Title : Level9::Script
  • title : Level9::GamePanel , Level9::Script
  • TITLE_BAR_TEXT : Level9::MainForm
  • TITLE_ERROR : Level9::GamePanel
  • TitleBarBackColor : Level9::BitmapFontPanel
  • titleBarBackColor : Level9::BitmapFontPanel
  • TitleBarForeColor : Level9::BitmapFontPanel
  • titleBarForeColor : Level9::BitmapFontPanel
  • titleBarText : Level9::BitmapFontPanel
  • TitleBarText : Level9::BitmapFontPanel
  • titleBitmap : Level9::GamePanel , Level9::BitmapFontPanel
  • titleRenderer : Level9::BitmapFontPanel , Level9::GamePanel
  • ToolbarButtonClickedEventArgs() : Level9::ToolbarButtonClickedEventArgs
  • toolbarButtonDictionary : Level9::MainForm
  • ToolbarButtonEnabledChanged() : Level9::SimpleToolBar
  • toolbarButtonFullscreen : Level9::MainForm
  • toolbarButtonL9Cut : Level9::MainForm
  • toolbarButtonLoadGame : Level9::MainForm
  • toolbarButtonRestorePos : Level9::MainForm
  • toolbarButtons : Level9::SimpleToolBar
  • toolbarButtonSavePos : Level9::MainForm
  • toolbarButtonScripts : Level9::MainForm
  • toolbarButtonScrollback : Level9::MainForm
  • toolbarButtonSettings : Level9::MainForm
  • ToolTip : Level9::SimpleToolBarButton
  • toolTip : Level9::SimpleToolBar , Level9::SimpleToolBarButton
  • ToSize() : Level9::Config::WindowSize
  • ToString()
: Level9::AttributedText
, Level9::TextPosition
  • TrimEnd() : Level9::AttributedText
  • TS_FORMAT : Level9::Logger
  • type : Level9::BitmapFont
  • Type : Level9::BitmapFont


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- u -

  • UpdateButtons() : Level9::ScriptForm
  • UpdateRecentFiles() : Level9::MainForm
  • UpdateScreen() : Level9::GamePanel
  • UpdateScript() : Level9::ScriptForm
  • UpdateScriptPreview() : Level9::ScriptForm
  • UpdateTextBitmap() : Level9::BitmapFontRenderer
  • user_palette : Level9::ConfigXML
  • UserPalette : Level9::Config
  • userPalette : Level9::Config


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- v -

  • V_SPACING : Level9::SimpleListView , Level9::SimpleToolBar


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- w -

  • WATCHDOG_TIMEOUT : Level9::DictionaryProgressForm
  • watchdogTimer : Level9::DictionaryProgressForm
  • WatchdogTimerTick() : Level9::DictionaryProgressForm
  • Width : Level9::BitmapFont
  • width : Level9::Config::WindowSize , Level9::Interpreter::L9BITMAP
  • Width : Level9::Config::WindowSize
  • width : Level9::BitmapFont
  • WindowSize() : Level9::Config::WindowSize
  • WriteSettings() : Level9::Config


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- x -

  • x : Level9::OsFillEventArgs , Level9::OsShowBitmapEventArgs
  • X : Level9::OsShowBitmapEventArgs , Level9::OsFillEventArgs
  • x1 : Level9::OsDrawLineEventArgs
  • X1 : Level9::OsDrawLineEventArgs
  • X2 : Level9::OsDrawLineEventArgs
  • x2 : Level9::OsDrawLineEventArgs


Level9.Net: Class Members

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all documented class members with links to the class documentation for each member:

- y -

  • Y : Level9::OsFillEventArgs , Level9::OsShowBitmapEventArgs
  • y : Level9::OsShowBitmapEventArgs , Level9::OsFillEventArgs
  • y1 : Level9::OsDrawLineEventArgs
  • Y1 : Level9::OsDrawLineEventArgs
  • Y2 : Level9::OsDrawLineEventArgs
  • y2 : Level9::OsDrawLineEventArgs


Level9.Net: Class Members - Enumerations

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • Commands : Level9::Interpreter
  • GraphicsMode : Level9::GameGraphics
  • Palette : Level9::Config
  • Stock : Level9::Images


Level9.Net: Class Members - Events

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • ButtonClicked : Level9::SimpleToolBar
  • ConfigChanged : Level9::Config
  • EnabledChanged : Level9::SimpleToolBarButton
  • GameFileError : Level9::Interpreter
  • GraphicsOff : Level9::GameGraphics
  • InputFinished : Level9::Interpreter
  • InputMode : Level9::GamePanel
  • ItemClicked : Level9::SimpleListView
  • NewGameFile : Level9::Interpreter
  • OsClearGraphics : Level9::Interpreter
  • OsDrawLine : Level9::Interpreter
  • OsFill : Level9::Interpreter
  • OsFlush : Level9::Interpreter
  • OsGetGameFile : Level9::Interpreter
  • OsGraphics : Level9::Interpreter
  • OsInput : Level9::Interpreter
  • OsLoadFile : Level9::Interpreter
  • OsReadchar : Level9::Interpreter
  • OsSaveFile : Level9::Interpreter
  • OsSetColour : Level9::Interpreter
  • OsShowBitmap : Level9::Interpreter
  • PictureCreated : Level9::GameGraphics
  • ScriptChanged : Level9::Script


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- a -

  • AboutForm() : Level9::AboutForm
  • Add() : Level9::Dictionary
  • AddAttribute() : Level9::AttributedText
  • AddButton() : Level9::SimpleToolBar
  • AddEntry() : Level9::Script
  • AddInputRequest() : Level9::Interpreter
  • AddListViewItem() : Level9::SimpleListView
  • AddToRecentFiles() : Level9::Config
  • Append()
: Level9::AttributedText
, Level9::GameText
, Level9::AttributedText
  • AppendText() : Level9::TextForm
  • ApplicationExit()
: Level9::GameGraphics
, Level9::MainForm
  • AttributedText() : Level9::AttributedText


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- j -

  • Join() : Level9::GameThread


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- l -

  • L9_DecodeBitmap() : Level9::Interpreter
  • L9_DetectBitmaps() : Level9::Interpreter
  • L9_FreeMemory() : Level9::Interpreter
  • L9_GetPictureSize() : Level9::Interpreter
  • L9_LoadGame() : Level9::Interpreter
  • L9_RestoreGame() : Level9::Interpreter
  • L9_RunGame() : Level9::Interpreter
  • L9_RunGraphics() : Level9::Interpreter
  • L9_SetCallbackFunctions() : Level9::Interpreter
  • L9_StopGame() : Level9::Interpreter
  • L9CutForm() : Level9::L9CutForm
  • LabelLinkLinkClicked() : Level9::AboutForm
  • LabelTextColorPreviewClick() : Level9::ConfigForm
  • LabelUserColorClick() : Level9::ConfigForm
  • LexerError() : Level9::LexerError
  • ListViewItemClickedEventArgs() : Level9::ListViewItemClickedEventArgs
  • Load() : Level9::Script
  • LoadGame()
: Level9::Interpreter
, Level9::MainForm
  • Log() : Level9::Logger


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- m -

  • Main() : Level9::MainForm
  • MainForm() : Level9::MainForm
  • MainFormActivated() : Level9::MainForm
  • MainFormFormClosed() : Level9::MainForm
  • MainFormToolBarButtonClicked() : Level9::MainForm
  • MenuItemAboutClick() : Level9::MainForm
  • MenuItemClearClick() : Level9::ScriptForm
  • MenuItemCloseClick()
: Level9::ScriptForm
, Level9::TextForm
  • MenuItemCopyClick()
: Level9::ScriptForm
, Level9::TextForm
  • MenuItemDictionaryClick() : Level9::MainForm
  • MenuItemExitClick() : Level9::MainForm
  • MenuItemFullscreenClick() : Level9::MainForm
  • MenuItemIncludeCommentsClick() : Level9::ScriptForm
  • MenuItemL9CutClick() : Level9::MainForm
  • MenuItemL9netHelpClick() : Level9::MainForm
  • MenuItemLoadClick() : Level9::ScriptForm
  • MenuItemLoadGameClick() : Level9::MainForm
  • MenuItemOneEntryPerLineClick() : Level9::ScriptForm
  • MenuItemPlaybackClick() : Level9::MainForm
  • MenuItemRecentFileClick() : Level9::MainForm
  • MenuItemReloadCurrentGameClick() : Level9::MainForm
  • MenuItemRestorePosClick() : Level9::MainForm
  • MenuItemSaveClick()
: Level9::TextForm
, Level9::ScriptForm
  • MenuItemSavePosClick() : Level9::MainForm
  • MenuItemSaveScreenshotClick() : Level9::MainForm
  • MenuItemScriptRecordingClick() : Level9::MainForm
  • MenuItemScrollbackClick() : Level9::MainForm
  • MenuItemSettingsClick() : Level9::MainForm
  • MenuItemStatusBarClick() : Level9::MainForm
  • MenuItemTimerClick() : Level9::MainForm
  • MenuItemTitleBarClick() : Level9::MainForm
  • MenuItemToolBarClick() : Level9::MainForm


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- n -

  • NewGameFileEventArgs() : Level9::NewGameFileEventArgs


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- o -

  • OFDDataFiles() : Level9::FileUtils
  • OFDGameFiles() : Level9::FileUtils
  • OFDSavedGameFiles() : Level9::FileUtils
  • OFDTextFiles() : Level9::FileUtils
  • OnGotFocus() : Level9::GamePanel
  • OnKeyDown() : Level9::GamePanel
  • OnKeyPress() : Level9::GamePanel
  • OnLostFocus() : Level9::GamePanel
  • OnMouseDown()
: Level9::SimpleListView
, Level9::SimpleToolBar
  • OnMouseLeave() : Level9::SimpleToolBar
  • OnMouseMove() : Level9::SimpleToolBar
  • OnMouseUp() : Level9::SimpleToolBar
  • OnPaint()
: Level9::SimpleListView
, Level9::SimpleToolBar
, Level9::BitmapFontPanel
, Level9::GamePanel
  • OnPaintBackground() : Level9::GamePanel
  • OnSizeChanged() : Level9::GamePanel
  • OS_CLEARGRAPHICS() : Level9::Interpreter
  • os_cleargraphics() : Level9::Interpreter
  • os_drawline() : Level9::Interpreter
  • OS_DRAWLINE() : Level9::Interpreter
  • os_fill() : Level9::Interpreter
  • OS_FILL() : Level9::Interpreter
  • OS_FLUSH() : Level9::Interpreter
  • os_flush() : Level9::Interpreter
  • OS_GET_GAME_FILE() : Level9::Interpreter
  • os_get_game_file() : Level9::Interpreter
  • os_graphics() : Level9::Interpreter
  • OS_GRAPHICS() : Level9::Interpreter
  • OS_INPUT() : Level9::Interpreter
  • os_input() : Level9::Interpreter
  • OS_LOAD_FILE() : Level9::Interpreter
  • os_load_file() : Level9::Interpreter
  • OS_PRINTCHAR() : Level9::Interpreter
  • os_printchar() : Level9::Interpreter
  • os_readchar() : Level9::Interpreter
  • OS_READCHAR() : Level9::Interpreter
  • os_save_file() : Level9::Interpreter
  • OS_SAVE_FILE() : Level9::Interpreter
  • OS_SET_FILENUMBER() : Level9::Interpreter
  • os_set_filenumber() : Level9::Interpreter
  • OS_SETCOLOUR() : Level9::Interpreter
  • os_setcolour() : Level9::Interpreter
  • OS_SHOW_BITMAP() : Level9::Interpreter
  • os_show_bitmap() : Level9::Interpreter
  • OsClearGraphicsEventArgs() : Level9::OsClearGraphicsEventArgs
  • OsDrawLineEventArgs() : Level9::OsDrawLineEventArgs
  • OsFillEventArgs() : Level9::OsFillEventArgs
  • OsFlushEventArgs() : Level9::OsFlushEventArgs
  • OsGetGameFileEventArgs() : Level9::OsGetGameFileEventArgs
  • OsGraphicsEventArgs() : Level9::OsGraphicsEventArgs
  • OsLoadFileEventArgs() : Level9::OsLoadFileEventArgs
  • OsReadcharEventArgs() : Level9::OsReadcharEventArgs
  • OsSaveFileEventArgs() : Level9::OsSaveFileEventArgs
  • OsSetColourEventArgs() : Level9::OsSetColourEventArgs
  • OsShowBitmapEventArgs() : Level9::OsShowBitmapEventArgs


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- b -

  • BitmapFont() : Level9::BitmapFont
  • BitmapFontPanel() : Level9::BitmapFontPanel
  • BitmapFonts() : Level9::BitmapFonts
  • ButtonBrowseInputClick() : Level9::L9CutForm
  • ButtonBrowseOutputClick() : Level9::L9CutForm
  • ButtonCancelClick() : Level9::ConfigForm
  • ButtonCloseClick() : Level9::L9CutForm
  • ButtonExecuteClick() : Level9::L9CutForm
  • ButtonNextClick()
: Level9::ScriptForm
, Level9::TextForm
  • ButtonOKClick() : Level9::ConfigForm
  • ButtonPlaybackPlayClick() : Level9::MainForm
  • ButtonPlaybackStopClick() : Level9::MainForm
  • ButtonPreviousClick()
: Level9::TextForm
, Level9::ScriptForm
  • ButtonRecordClick() : Level9::ScriptForm
  • BytesToString() : Level9::Interpreter


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- c -

  • CaretBack() : Level9::GameText
  • CaretDelete() : Level9::GameText
  • CaretEnd() : Level9::GameText
  • CaretHome() : Level9::GameText
  • CaretIns() : Level9::GameText
  • CaretLeft() : Level9::GameText
  • CaretRight() : Level9::GameText
  • CheckExecuteExtract() : Level9::L9CutForm
  • CheckExecuteLists() : Level9::L9CutForm
  • CheckL9Cut() : Level9::L9Cut
  • Clear()
: Level9::GameText
, Level9::Script
, Level9::TextForm
, Level9::TextPosition
  • ClearCaretInParagraphs() : Level9::GameText
  • ComboBoxFontTypeSelectedIndexChanged() : Level9::ConfigForm
  • CompareTo() : Level9::TextPosition
  • Config() : Level9::Config
  • ConfigChanged()
: Level9::GameGraphics
, Level9::GamePanel
  • ConfigChangedEventArgs() : Level9::ConfigChangedEventArgs
  • ConfigForm() : Level9::ConfigForm
  • ConfigXML() : Level9::ConfigXML
  • ContextMenuStripScriptOpening() : Level9::ScriptForm
  • Copy() : Level9::TextPosition
  • Create() : Level9::Script
  • CreateBitmapImage() : Level9::GameGraphics
  • CreateLineDrawnImage() : Level9::GameGraphics
  • CreateOutput() : Level9::Dictionary


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- d -

  • DataGridViewScriptCellMouseDown() : Level9::ScriptForm
  • DataGridViewScriptCellValueNeeded() : Level9::ScriptForm
  • DataGridViewScriptCellValuePushed() : Level9::ScriptForm
  • DecodeBitmap() : Level9::Interpreter
  • DeleteRowToolStripMenuItemClick() : Level9::ScriptForm
  • DetectBitmaps() : Level9::Interpreter
  • Dictionary() : Level9::Dictionary
  • DictionaryProgressForm() : Level9::DictionaryProgressForm
  • Dispose()
: Level9::ScriptForm
, Level9::MainForm
, Level9::TextForm
, Level9::AboutForm
, Level9::BitmapFontPanel
, Level9::ConfigForm
, Level9::DictionaryProgressForm
, Level9::GamePanel
, Level9::L9CutForm
  • DomainUpDownFontScalingSelectedItemChanged() : Level9::ConfigForm
  • DomainUpDownInputDelayEnter() : Level9::MainForm
  • DomainUpDownInputDelaySelectedItemChanged() : Level9::MainForm
  • DomainUpDownLineSpacingSelectedItemChanged() : Level9::ConfigForm
  • DrawingThreadProc() : Level9::GameGraphics
  • DrawLineIf() : Level9::GameGraphics


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- e -

  • EntryMatch() : Level9::Script
  • Equals()
: Level9::BitmapFont
, Level9::AttributedText
, Level9::TextPosition
  • ExecL9Cut() : Level9::L9Cut
  • ExtractDatafile() : Level9::L9Cut


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- f -

  • FindText()
: Level9::Script
, Level9::ScriptForm
, Level9::TextForm
  • FireConfigChanged() : Level9::Config
  • FireInputModeEvent() : Level9::GamePanel
  • FireInputModeEventDelegate() : Level9::GamePanel
  • FireScriptChanged() : Level9::Script
  • FloodFillIf() : Level9::GameGraphics
  • FreeMemory() : Level9::Interpreter
  • FromSize() : Level9::Config::WindowSize


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- g -

  • GameFileErrorEventArgs() : Level9::GameFileErrorEventArgs
  • GameGraphics() : Level9::GameGraphics
  • GameGraphicsGraphicsOff() : Level9::GamePanel
  • GameGraphicsPictureCreated() : Level9::GamePanel
  • GamePanel() : Level9::GamePanel
  • GamePanelClick() : Level9::MainForm
  • GamePanelDragDrop() : Level9::MainForm
  • GamePanelDragEnter() : Level9::MainForm
  • GamePanelInputMode() : Level9::MainForm
  • GameText() : Level9::GameText
  • Get()
: Level9::BitmapFonts
, Level9::Images
  • GetActivePalette() : Level9::Config
  • GetAntlrPath() : Level9::Config
  • GetAppDataPath() : Level9::Config
  • GetButtonByPoint() : Level9::SimpleToolBar
  • GetButtonRect() : Level9::SimpleToolBar
  • GetCaptionWidth() : Level9::SimpleListView
  • GetClientSizeString() : Level9::GamePanel
  • GetClipboardText() : Level9::GamePanel
  • GetConfigFilePath() : Level9::Config
  • GetDetectedDatafiles() : Level9::L9Cut
  • GetEntriesCount() : Level9::Script
  • GetEntryAt() : Level9::Script
  • GetGameTitle() : Level9::L9Cut
  • GetHashCode()
: Level9::BitmapFont
, Level9::TextPosition
, Level9::AttributedText
  • GetHelpFilePath() : Level9::Config
  • GetInput() : Level9::GameText
  • GetItemByPoint() : Level9::SimpleListView
  • GetItemRect() : Level9::SimpleListView
  • GetL9CutPath() : Level9::Config
  • GetLength() : Level9::AttributedText
  • GetLevel9DLLPath() : Level9::Config
  • GetLogFilePath() : Level9::Config
  • GetMissingDatafiles() : Level9::L9Cut
  • GetMissingPatches() : Level9::L9Cut
  • GetNextInput() : Level9::Script
  • GetOpenFile() : Level9::FileUtils
  • GetOutput() : Level9::GameText
  • GetOutputLinesCount() : Level9::GameText
  • GetParagraphCount() : Level9::GameText
  • GetPictureSize() : Level9::Interpreter
  • GetRange() : Level9::AttributedText
  • GetSaveFile() : Level9::FileUtils
  • GetStatusString() : Level9::GamePanel
  • GetTextLength() : Level9::TextForm
  • GetTimerString() : Level9::GamePanel
  • GraphicsOffEventArgs() : Level9::GraphicsOffEventArgs


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- h -

  • Handle() : Level9::ErrorHandler
  • HideCaret() : Level9::GameText
  • HistoryDown() : Level9::GameText
  • HistoryUp() : Level9::GameText


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- i -

  • Images() : Level9::Images
  • InitializeComponent()
: Level9::AboutForm
, Level9::DictionaryProgressForm
, Level9::TextForm
, Level9::L9CutForm
, Level9::ConfigForm
, Level9::MainForm
, Level9::ScriptForm
  • InputFinishedEventArgs() : Level9::InputFinishedEventArgs
  • InputModeEventArgs() : Level9::InputModeEventArgs
  • Insert() : Level9::AttributedText
  • InsertEntry() : Level9::Script
  • InsertRowAfterToolStripMenuItemClick() : Level9::ScriptForm
  • InsertRowToolStripMenuItemClick() : Level9::ScriptForm
  • Interpreter() : Level9::Interpreter
  • InterpreterGameFileError()
: Level9::GamePanel
, Level9::MainForm
  • InterpreterInputFinished() : Level9::Script
  • InterpreterNewGameFile()
: Level9::MainForm
, Level9::Dictionary
, Level9::GameGraphics
, Level9::GamePanel
  • InterpreterOsClearGraphics() : Level9::GameGraphics
  • InterpreterOsDrawLine() : Level9::GameGraphics
  • InterpreterOsFill() : Level9::GameGraphics
  • InterpreterOsFlush()
: Level9::DictionaryProgressForm
, Level9::GamePanel
  • InterpreterOsGetGameFile() : Level9::MainForm
  • InterpreterOsGraphics() : Level9::GameGraphics
  • InterpreterOsInput()
: Level9::GamePanel
, Level9::GameGraphics
  • InterpreterOsLoadFile() : Level9::MainForm
  • InterpreterOsReadchar()
: Level9::GameGraphics
, Level9::GamePanel
  • InterpreterOsSaveFile() : Level9::MainForm
  • InterpreterOsSetColour() : Level9::GameGraphics
  • InterpreterOsShowBitmap() : Level9::GameGraphics
  • InvalidateButton() : Level9::SimpleToolBar
  • InvalidateItem() : Level9::SimpleListView
  • IsInitialized() : Level9::Config


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- p -

  • PictureCreatedEventArgs() : Level9::PictureCreatedEventArgs
  • PlaybackEndToolStripMenuItemClick() : Level9::ScriptForm
  • PlaybackPauseToolStripMenuItemClick() : Level9::ScriptForm
  • PlaybackStartToolStripMenuItemClick() : Level9::ScriptForm


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- r -

  • RadioButtonDetectedDatafilesCheckedChanged() : Level9::L9CutForm
  • RadioButtonMissingDatafilesCheckedChanged() : Level9::L9CutForm
  • RadioButtonMissingPatchesCheckedChanged() : Level9::L9CutForm
  • ReadSettings() : Level9::Config
  • RecallCommand() : Level9::GameText
  • RemoveAttribute() : Level9::AttributedText
  • RemoveControlMark() : Level9::Script
  • RemoveControlMarkToolStripMenuItemClick() : Level9::ScriptForm
  • RemoveEntry() : Level9::Script
  • RemoveRange() : Level9::AttributedText
  • RenderText() : Level9::BitmapFontRenderer
  • RestoreGame() : Level9::Interpreter
  • Resume() : Level9::GameThread
  • RunGame() : Level9::Interpreter
  • RunGraphics() : Level9::Interpreter


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- s -

  • SaveScreenshot() : Level9::GamePanel
  • ScaleBitmap() : Level9::GameGraphics
  • Script() : Level9::Script
  • ScriptChanged()
: Level9::MainForm
, Level9::ScriptForm
  • ScriptChangedEventArgs() : Level9::ScriptChangedEventArgs
  • ScriptEntry() : Level9::ScriptEntry
  • ScriptForm() : Level9::ScriptForm
  • ScriptFormFormClosing() : Level9::ScriptForm
  • ScriptFormKeyDown() : Level9::ScriptForm
  • ScriptTimerTick() : Level9::MainForm
  • SetCaretInParagraphs() : Level9::GameText
  • SetCaretPosition() : Level9::TextForm
  • SetCommentAt() : Level9::Script
  • SetConfigurationValues() : Level9::ConfigForm
  • SetGameFile() : Level9::Interpreter
  • SetInputAt() : Level9::Script
  • SetInputPosition() : Level9::GameText
  • SetMembers() : Level9::Config
  • SetPauseAt() : Level9::Script
  • SetSelectedItem() : Level9::SimpleListView
  • SetTextOffset() : Level9::GameText
  • SFDDataFiles() : Level9::FileUtils
  • SFDPngFiles() : Level9::FileUtils
  • SFDSavedGameFiles() : Level9::FileUtils
  • SFDTextFiles() : Level9::FileUtils
  • Show() : Level9::Dictionary
  • ShowCaret() : Level9::GameText
  • ShowScrollback()
: Level9::GameText
, Level9::GamePanel
  • SimpleListView() : Level9::SimpleListView
  • SimpleListViewButtonClicked() : Level9::ConfigForm
  • SimpleListViewItem() : Level9::SimpleListViewItem
  • SimpleToolBar() : Level9::SimpleToolBar
  • SimpleToolBarButton() : Level9::SimpleToolBarButton
  • SimulateKey() : Level9::GamePanel
  • SimulateKeys() : Level9::GamePanel
  • Sleep() : Level9::GameThread
  • SplitParagraph() : Level9::TextUtils
  • SplitParagraphs() : Level9::TextUtils
  • Start() : Level9::GameThread
  • StartDrawingThread() : Level9::GameGraphics
  • StartPlayback() : Level9::Script
  • StartRecording() : Level9::Script
  • Stop() : Level9::GameThread
  • StopDrawingThread() : Level9::GameGraphics
  • StopGame() : Level9::Interpreter
  • StopPlayback() : Level9::Script
  • StopRecording() : Level9::Script
  • StoreConfig() : Level9::ConfigForm
  • StringToBytes() : Level9::Interpreter
  • Substring() : Level9::TextUtils


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- t -

  • TextBoxCommentLeave() : Level9::ScriptForm
  • TextBoxFindTextChanged()
: Level9::ScriptForm
, Level9::TextForm
  • TextBoxInputTextChanged() : Level9::L9CutForm
  • TextBoxOutputTextChanged() : Level9::L9CutForm
  • TextBoxScriptStatusEnter() : Level9::MainForm
  • TextBoxTitleLeave() : Level9::ScriptForm
  • TextForm() : Level9::TextForm
  • TextFormFormClosing() : Level9::TextForm
  • TextFormKeyDown() : Level9::TextForm
  • TextPosition() : Level9::TextPosition
  • ThreadProc() : Level9::GameThread
  • TimerTick()
: Level9::ScriptForm
, Level9::GamePanel
  • ToolbarButtonClickedEventArgs() : Level9::ToolbarButtonClickedEventArgs
  • ToolbarButtonEnabledChanged() : Level9::SimpleToolBar
  • ToSize() : Level9::Config::WindowSize
  • ToString()
: Level9::TextPosition
, Level9::AttributedText
  • TrimEnd() : Level9::AttributedText


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- u -

  • UpdateButtons() : Level9::ScriptForm
  • UpdateRecentFiles() : Level9::MainForm
  • UpdateScreen() : Level9::GamePanel
  • UpdateScript() : Level9::ScriptForm
  • UpdateScriptPreview() : Level9::ScriptForm
  • UpdateTextBitmap() : Level9::BitmapFontRenderer


Level9.Net: Class Members - Functions

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- w -

  • WatchdogTimerTick() : Level9::DictionaryProgressForm
  • WindowSize() : Level9::Config::WindowSize
  • WriteSettings() : Level9::Config


Level9.Net: Class Members - Properties

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y

- a -

  • Active : Level9::InputModeEventArgs
  • AmigaPalette : Level9::Config
  • Attributes : Level9::AttributedText

- b -

  • BackColor : Level9::Config
  • BarBackColor : Level9::Config
  • BarTextColor : Level9::Config
  • Bitmap : Level9::BitmapFont
  • BitmapFont : Level9::BitmapFontPanel
  • Button : Level9::ToolbarButtonClickedEventArgs
  • Bytes : Level9::OsLoadFileEventArgs , Level9::OsSaveFileEventArgs

- c -

  • Character : Level9::OsReadcharEventArgs
  • ClientSize : Level9::Config
  • Colour : Level9::OsSetColourEventArgs
  • Colour1 : Level9::OsDrawLineEventArgs , Level9::OsFillEventArgs
  • Colour2 : Level9::OsDrawLineEventArgs , Level9::OsFillEventArgs
  • Column : Level9::TextPosition , Level9::LexerError
  • Command : Level9::OsFlushEventArgs
  • Comment : Level9::ScriptEntry , Level9::Script

- d -

  • DictViewerSize : Level9::Config

- e -

  • Enabled : Level9::SimpleToolBarButton
  • EndIndex : Level9::Script
  • Errors : Level9::Script

- f -

  • Filename : Level9::OsGetGameFileEventArgs
  • Font : Level9::Config
  • FontScaling : Level9::Config
  • FontScalings : Level9::BitmapFonts
  • FontTypes : Level9::BitmapFonts

- g -

  • GameFilePath : Level9::Interpreter
  • GameTitle : Level9::Interpreter

- h -

  • Height : Level9::BitmapFont , Level9::Config::WindowSize

- i -

  • Image : Level9::SimpleListViewItem , Level9::SimpleToolBarButton
  • ImageScaling : Level9::Config
  • ImageScalings : Level9::Config
  • Index : Level9::OsSetColourEventArgs
  • Input
: Level9::ScriptEntry
, Level9::OsInputEventArgs
, Level9::InputFinishedEventArgs
  • InputColor : Level9::BitmapFontPanel , Level9::Config
  • Instance
: Level9::Config
, Level9::Script
, Level9::Dictionary
  • IsPlaying : Level9::Script
  • IsRecording : Level9::Script
  • IsRunning : Level9::GameThread
  • IsSeparator : Level9::SimpleToolBarButton
  • IsSleeping : Level9::GameThread
  • Item : Level9::ListViewItemClickedEventArgs

- l -

  • Line : Level9::LexerError
  • LineSpacing : Level9::BitmapFontPanel , Level9::Config
  • LineSpacings : Level9::Config
  • LoggingEnabled : Level9::Config

- m -

  • MaxBytes : Level9::OsLoadFileEventArgs
  • Message : Level9::LexerError
  • Millis : Level9::OsReadcharEventArgs
  • Mode : Level9::OsGraphicsEventArgs
  • MoreLines : Level9::InputModeEventArgs

- n -

  • Number : Level9::OsShowBitmapEventArgs

- o -

  • Origin : Level9::AttributedText

- p -

  • PaletteSelection : Level9::Config
  • Paragraph : Level9::TextPosition
  • Paragraphs : Level9::GameText , Level9::BitmapFontPanel
  • Pause : Level9::ScriptEntry
  • Picture : Level9::PictureCreatedEventArgs
  • PlaybackPos : Level9::Script

- r -

  • RecentFiles : Level9::Config

- s -

  • ScriptEditorSize : Level9::Config
  • ScriptIncludeComments : Level9::Config
  • ScriptInputDelay : Level9::Config
  • ScriptInputDelays : Level9::Config
  • ScriptOneEntryPerLine : Level9::Config
  • Separator : Level9::SimpleToolBarButton
  • ShowScriptPlayback : Level9::Config
  • ShowStatusBar : Level9::Config
  • ShowTimer : Level9::Config
  • ShowTitleBar : Level9::Config
  • ShowToolbar : Level9::Config
  • Size : Level9::BitmapFont
  • SpectrumPalette : Level9::Config
  • StartIndex : Level9::Script
  • StopRequest : Level9::GameThread
  • Success
: Level9::OsLoadFileEventArgs
, Level9::OsGetGameFileEventArgs
, Level9::OsSaveFileEventArgs

- t -

  • Text
: Level9::BitmapFontPanel
, Level9::OsFlushEventArgs
, Level9::AttributedText
, Level9::SimpleListViewItem
  • TextColor : Level9::Config
  • TextViewerSize : Level9::Config
  • Timestamp : Level9::InputModeEventArgs
  • Title : Level9::Script
  • TitleBarBackColor : Level9::BitmapFontPanel
  • TitleBarForeColor : Level9::BitmapFontPanel
  • TitleBarText : Level9::BitmapFontPanel
  • ToolTip : Level9::SimpleToolBarButton
  • Type : Level9::BitmapFont

- u -

  • UserPalette : Level9::Config

- w -

  • Width : Level9::BitmapFont , Level9::Config::WindowSize

- x -

  • X : Level9::OsFillEventArgs , Level9::OsShowBitmapEventArgs
  • X1 : Level9::OsDrawLineEventArgs
  • X2 : Level9::OsDrawLineEventArgs

- y -

  • Y : Level9::OsFillEventArgs , Level9::OsShowBitmapEventArgs
  • Y1 : Level9::OsDrawLineEventArgs
  • Y2 : Level9::OsDrawLineEventArgs


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- a -

  • active : Level9::InputModeEventArgs
  • amigaPalette : Level9::Config
  • ANTLR_DLL : Level9::Config
  • ATTR_INPUT_CARET : Level9::AttributedText
  • ATTR_INPUT_END : Level9::AttributedText
  • ATTR_INPUT_START : Level9::AttributedText
  • attributes : Level9::AttributedText


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- k -

  • keys : Level9::Dictionary


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- l -

  • L9CUT_DETECTED_DATAFILES : Level9::L9Cut
  • L9CUT_EXE : Level9::Config
  • L9CUT_MISSING_DATAFILES : Level9::L9Cut
  • L9CUT_MISSING_PATCHES : Level9::L9Cut
  • L9CUT_NO : Level9::L9Cut
  • L9CUT_YES : Level9::L9Cut
  • LEVEL9_DLL : Level9::Config
  • line : Level9::LexerError
  • line_spacing : Level9::ConfigXML
  • lineSpacing
: Level9::BitmapFontPanel
, Level9::BitmapFontRenderer
, Level9::Config
  • lineSpacings : Level9::Config
  • listViewButtonColors : Level9::ConfigForm
  • listViewButtonFont : Level9::ConfigForm
  • listViewButtonGraphics : Level9::ConfigForm
  • listViewItems : Level9::SimpleListView
  • LOG_FILE : Level9::Config
  • loggingEnabled : Level9::Config


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- m -

  • MASK_FORECOLOR : Level9::BitmapFontRenderer
  • MASK_INPUTCOLOR : Level9::BitmapFontRenderer
  • MASK_INPUTCOLOR_INV : Level9::BitmapFontRenderer
  • MAX_COMMANDS_HISTORY : Level9::GameText
  • MAX_LENGTH_INPUT : Level9::GameText
  • MAX_RECENT_FILES : Level9::Config
  • maxBytes : Level9::OsLoadFileEventArgs
  • maxIconHeight : Level9::SimpleToolBar
  • message : Level9::LexerError
  • millis : Level9::OsReadcharEventArgs
  • mode : Level9::OsGraphicsEventArgs
  • moreLines : Level9::InputModeEventArgs , Level9::GamePanel


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- n -

  • npalette : Level9::Interpreter::L9BITMAP
  • number : Level9::OsShowBitmapEventArgs


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- o -

  • offsetPos : Level9::GameText
  • origin : Level9::AttributedText
  • osFlushHandler : Level9::DictionaryProgressForm
  • output : Level9::Dictionary , Level9::GameText
  • outputBuffer : Level9::Interpreter


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- b -

  • back_color : Level9::ConfigXML
  • backColor : Level9::Config
  • bar_back_color : Level9::ConfigXML
  • BAR_ELEMENT_SPACING : Level9::GamePanel
  • bar_text_color : Level9::ConfigXML
  • BAR_XY_SPACING : Level9::BitmapFontPanel , Level9::GamePanel
  • barBackColor : Level9::Config
  • barTextColor : Level9::Config
  • bitmap : Level9::BitmapFont , Level9::Interpreter::L9BITMAP
  • bitmapFont : Level9::BitmapFontPanel
  • bitmapFonts : Level9::BitmapFonts
  • bitmapNumber : Level9::GameGraphics
  • bitmapsDetected : Level9::GameGraphics
  • BORDER_SPACING : Level9::SimpleListView , Level9::SimpleToolBar
  • button : Level9::ToolbarButtonClickedEventArgs
  • bytes : Level9::OsSaveFileEventArgs , Level9::OsLoadFileEventArgs


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- c -

  • callbacks : Level9::Interpreter
  • CAPTION_SPACING : Level9::SimpleListView
  • caretPos : Level9::GameText
  • character : Level9::OsReadcharEventArgs
  • checkExecute : Level9::L9CutForm
  • client_height : Level9::ConfigXML
  • client_width : Level9::ConfigXML
  • clientSize : Level9::Config
  • colour : Level9::OsSetColourEventArgs
  • colour1 : Level9::OsDrawLineEventArgs , Level9::OsFillEventArgs
  • colour2 : Level9::OsDrawLineEventArgs , Level9::OsFillEventArgs
  • column : Level9::LexerError , Level9::TextPosition
  • command : Level9::OsFlushEventArgs
  • COMMAND_LINE_LOGGING : Level9::MainForm
  • commandHistory : Level9::GameText
  • commandHistoryPos : Level9::GameText
  • commands : Level9::Interpreter
  • comment : Level9::Script , Level9::ScriptEntry
  • components
: Level9::L9CutForm
, Level9::MainForm
, Level9::ConfigForm
, Level9::ScriptForm
, Level9::TextForm
, Level9::AboutForm
, Level9::DictionaryProgressForm
  • currentCommand : Level9::Interpreter


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- d -

  • DEFAULT_OUTPUT_FILE : Level9::L9CutForm
  • dialogSize : Level9::TextForm
  • dict_viewer_height : Level9::ConfigXML
  • dict_viewer_width : Level9::ConfigXML
  • dictionary : Level9::Dictionary
  • DICTIONARY_FLUSH : Level9::Interpreter
  • dictionaryView : Level9::Dictionary
  • dictViewerSize : Level9::Config
  • disposeOnClose : Level9::TextForm
  • drawingThread : Level9::GameGraphics
  • DUMMY_DAT : Level9::L9Cut


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- e -

  • empty : Level9::Dictionary
  • enabled : Level9::SimpleToolBarButton
  • endIndex : Level9::Script
  • entries : Level9::Script
  • errors : Level9::Script


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- f -

  • filename : Level9::OsGetGameFileEventArgs
  • FILTER_DATA_FILES : Level9::FileUtils
  • FILTER_GAME_FILES : Level9::FileUtils
  • FILTER_PNG_FILES : Level9::FileUtils
  • FILTER_SAVED_GAME_FILES : Level9::FileUtils
  • FILTER_TXT_FILES : Level9::FileUtils
  • fireEvents : Level9::Script
  • font : Level9::BitmapFontRenderer , Level9::Config
  • font_scaling : Level9::ConfigXML
  • font_type : Level9::ConfigXML
  • fontRenderer : Level9::BitmapFontPanel
  • fontScaling : Level9::Config
  • fontScalings : Level9::BitmapFonts
  • fontTypes : Level9::BitmapFonts


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- g -

  • gameFilePath : Level9::Interpreter
  • gameGraphics : Level9::GamePanel
  • gameStart : Level9::GamePanel
  • gameText : Level9::GamePanel
  • gameThread : Level9::GameThread
  • gameTimer : Level9::GamePanel
  • gameTitle : Level9::Interpreter
  • graphicsMode : Level9::GameGraphics
  • greyScaleMatrix : Level9::SimpleToolBar


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- h -

  • H_OFFSET : Level9::SimpleToolBar
  • H_SPACING : Level9::SimpleToolBar
  • height
: Level9::Interpreter::L9BITMAP
, Level9::Config::WindowSize
, Level9::BitmapFont
  • HELP_FILE : Level9::Config


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- i -

  • image : Level9::SimpleListViewItem , Level9::SimpleToolBarButton
  • image_scaling : Level9::ConfigXML
  • images : Level9::Images
  • imageScaling : Level9::Config
  • imageScalings : Level9::Config
  • index : Level9::OsSetColourEventArgs
  • input
: Level9::OsInputEventArgs
, Level9::InputFinishedEventArgs
, Level9::ScriptEntry
  • input_color : Level9::ConfigXML
  • inputArgs : Level9::GamePanel
  • inputColor : Level9::BitmapFontPanel , Level9::Config
  • inputMode : Level9::GamePanel
  • inputModeArgs : Level9::GamePanel , Level9::MainForm
  • inputPos : Level9::GameText
  • inputRequests : Level9::Interpreter
  • instance
: Level9::Dictionary
, Level9::Config
, Level9::Script
  • isplaying : Level9::Script
  • isrecording : Level9::Script
  • isRunning : Level9::GameThread
  • isSleeping : Level9::GameThread
  • item : Level9::ListViewItemClickedEventArgs


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- p -

  • palette : Level9::GameGraphics , Level9::Interpreter::L9BITMAP
  • palette_selection : Level9::ConfigXML
  • paletteSelection : Level9::Config
  • paragraph : Level9::TextPosition
  • paragraphs : Level9::BitmapFontPanel , Level9::GameText
  • pause : Level9::ScriptEntry
  • picture : Level9::PictureCreatedEventArgs , Level9::GamePanel
  • pictureSize : Level9::GameGraphics
  • pixels : Level9::GameGraphics
  • playbackPos : Level9::Script
  • pressed : Level9::SimpleToolBar
  • prevSize : Level9::MainForm
  • PROGRAM_NAME : Level9::Config
  • PROGRAM_VERSION : Level9::Config


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- r -

  • readcharArgs : Level9::GamePanel , Level9::Interpreter
  • recent_files : Level9::ConfigXML
  • recentFiles : Level9::Config
  • REGION_ALL : Level9::GamePanel
  • REGION_PICTURE : Level9::GamePanel
  • REGION_STATUS : Level9::GamePanel
  • REGION_TEXT : Level9::GamePanel
  • REGION_TIMER : Level9::GamePanel
  • REGION_TITLE_BAR : Level9::GamePanel
  • resources : Level9::Images , Level9::BitmapFonts


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- s -

  • screenBitmap : Level9::GamePanel
  • SCRIPT_COMMAND_BRACKET_BEGIN : Level9::Script
  • SCRIPT_COMMAND_BRACKET_END : Level9::Script
  • SCRIPT_COMMAND_SEPARATOR : Level9::Script
  • SCRIPT_COMMENT : Level9::Script
  • script_editor_height : Level9::ConfigXML
  • script_editor_width : Level9::ConfigXML
  • script_include_comments : Level9::ConfigXML
  • script_input_delay : Level9::ConfigXML
  • SCRIPT_LINE_LENGTH : Level9::Script
  • SCRIPT_NEWLINE : Level9::Script
  • script_one_entry_per_line : Level9::ConfigXML
  • SCRIPT_TITLE : Level9::Script
  • scriptChangedHandler : Level9::ScriptForm
  • scriptEditorSize : Level9::Config
  • scriptForm : Level9::MainForm
  • scriptIncludeComments : Level9::Config
  • scriptInputDelay : Level9::Config
  • scriptInputDelays : Level9::Config
  • scriptInputModeEventTs : Level9::MainForm
  • scriptOneEntryPerLine : Level9::Config
  • scriptTimer : Level9::MainForm
  • scrollbackView : Level9::GameText
  • selected : Level9::SimpleListView , Level9::SimpleToolBar
  • separator : Level9::SimpleToolBarButton
  • SEPARATOR_WIDTH : Level9::SimpleToolBar
  • SETTINGS_FILE : Level9::Config
  • show_script_playback : Level9::ConfigXML
  • show_status_bar : Level9::ConfigXML
  • show_timer : Level9::ConfigXML
  • show_title_bar : Level9::ConfigXML
  • show_toolbar : Level9::ConfigXML
  • showScriptPlayback : Level9::Config
  • showStatusBar : Level9::Config
  • showTimer : Level9::Config
  • showTitle : Level9::GameGraphics
  • showTitleBar : Level9::Config
  • showToolbar : Level9::Config
  • size : Level9::BitmapFont
  • sizeBitmap : Level9::GamePanel
  • sizeRenderer : Level9::GamePanel
  • sizes : Level9::BitmapFonts
  • spectrumPalette : Level9::Config
  • split : Level9::Dictionary
  • startIndex : Level9::Script
  • statusBitmap : Level9::GamePanel
  • statusRenderer : Level9::GamePanel
  • stopRequest : Level9::GameThread
  • success
: Level9::OsLoadFileEventArgs
, Level9::OsGetGameFileEventArgs
, Level9::OsSaveFileEventArgs
  • sw : Level9::Logger


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- t -

  • text
: Level9::OsFlushEventArgs
, Level9::SimpleListViewItem
, Level9::AttributedText
  • text_color : Level9::ConfigXML
  • text_viewer_height : Level9::ConfigXML
  • text_viewer_width : Level9::ConfigXML
  • TEXT_X_SPACING : Level9::GamePanel , Level9::BitmapFontPanel
  • TEXT_Y_SPACING : Level9::BitmapFontPanel , Level9::GamePanel
  • textBitmap
: Level9::BitmapFontPanel
, Level9::BitmapFontRenderer
, Level9::GamePanel
  • textColor : Level9::Config
  • textRenderer : Level9::GamePanel
  • textViewerSize : Level9::Config
  • threadStopSignal : Level9::GameGraphics
  • timer : Level9::ScriptForm
  • timerBitmap : Level9::GamePanel
  • timerRenderer : Level9::GamePanel
  • timerString : Level9::GamePanel
  • timestamp : Level9::InputModeEventArgs
  • title : Level9::GamePanel , Level9::Script
  • TITLE_BAR_TEXT : Level9::MainForm
  • TITLE_ERROR : Level9::GamePanel
  • titleBarBackColor : Level9::BitmapFontPanel
  • titleBarForeColor : Level9::BitmapFontPanel
  • titleBarText : Level9::BitmapFontPanel
  • titleBitmap : Level9::GamePanel , Level9::BitmapFontPanel
  • titleRenderer : Level9::BitmapFontPanel , Level9::GamePanel
  • toolbarButtonDictionary : Level9::MainForm
  • toolbarButtonFullscreen : Level9::MainForm
  • toolbarButtonL9Cut : Level9::MainForm
  • toolbarButtonLoadGame : Level9::MainForm
  • toolbarButtonRestorePos : Level9::MainForm
  • toolbarButtons : Level9::SimpleToolBar
  • toolbarButtonSavePos : Level9::MainForm
  • toolbarButtonScripts : Level9::MainForm
  • toolbarButtonScrollback : Level9::MainForm
  • toolbarButtonSettings : Level9::MainForm
  • toolTip : Level9::SimpleToolBar , Level9::SimpleToolBarButton
  • TS_FORMAT : Level9::Logger
  • type : Level9::BitmapFont


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- u -

  • user_palette : Level9::ConfigXML
  • userPalette : Level9::Config


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- v -

  • V_SPACING : Level9::SimpleListView , Level9::SimpleToolBar


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- w -

  • WATCHDOG_TIMEOUT : Level9::DictionaryProgressForm
  • watchdogTimer : Level9::DictionaryProgressForm
  • width
: Level9::Config::WindowSize
, Level9::BitmapFont
, Level9::Interpreter::L9BITMAP


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- x -

  • x : Level9::OsFillEventArgs , Level9::OsShowBitmapEventArgs
  • x1 : Level9::OsDrawLineEventArgs
  • x2 : Level9::OsDrawLineEventArgs


Level9.Net: Class Members - Variables

  • All
  • Functions
  • Variables
  • Enumerations
  • Properties
  • Events
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y

- y -

  • y : Level9::OsFillEventArgs , Level9::OsShowBitmapEventArgs
  • y1 : Level9::OsDrawLineEventArgs
  • y2 : Level9::OsDrawLineEventArgs


Level9.Net: Namespace List

Namespace List
Here is a list of all documented namespaces with brief descriptions:
Level9


Level9.Net: Level9 Namespace Reference

Classes | Functions
Level9 Namespace Reference

Classes

class | AboutForm
'About' dialog with credits and version information. More...
class | BitmapFontPanel
A panel that displays text with a bitmap font. More...
class | BitmapFonts
Manages bitmap font resources. More...
class | BitmapFont
Represents a bitmap font. More...
class | BitmapFontRenderer
Renders text with a bitmap fonts. More...
class | Config
Manages the Level9.Net configuration. More...
class | ConfigXML
Allows XML serialization of miscellaneous configuration options. More...
class | ConfigChangedEventArgs
Provides data for the ConfigChanged event. More...
class | ConfigForm
Configuration dialog for colors, fonts and graphics. More...
class | Dictionary
Handles dictionaries of Level 9 games. More...
class | DictionaryProgressForm
Displays a progress bar while reading the dictionary of a Level 9 game. More...
class | ErrorHandler
Error handler for Level9.Net. Displays error messages and appends error information to the application log file. More...
class | FileUtils
Utilities for file handling. More...
class | GameGraphics
Handles line drawn and bitmap graphics in a Level 9 game. More...
class | PictureCreatedEventArgs
Provides data for the PictureCreated event. More...
class | GraphicsOffEventArgs
Provides data for the GraphicsOff event. More...
class | GamePanel
Displays text and graphics provided by the Level 9 interpreter and handles user interaction. More...
class | InputModeEventArgs
Provides data for the InputMode event. More...
class | GameText
Manages a text buffer and provides methods necessary for text output and shell functionality in a Level 9 game. More...
class | GameThread
Controls the main loop which executes opcodes of a Level 9 game. More...
class | Images
Manages the application icons and bitmaps. More...
class | Interpreter
Callback and control functions of the Level 9 interpreter. More...
class | OsFlushEventArgs
Provides data for the OsFlush event. More...
class | OsInputEventArgs
Provides data for the OsInput event. More...
class | OsReadcharEventArgs
Provides data for the OsReadchar event. More...
class | OsSaveFileEventArgs
Provides data for the OsSaveFile event. More...
class | OsLoadFileEventArgs
Provides data for the OsLoadFile event. More...
class | OsGetGameFileEventArgs
Provides data for the OsGetGameFile event. More...
class | NewGameFileEventArgs
Provides data for the NewGameFile event. More...
class | OsGraphicsEventArgs
Provides data for the OsGraphics event. More...
class | OsClearGraphicsEventArgs
Provides data for the OsClearGraphics event. More...
class | OsDrawLineEventArgs
Provides data for the OsDrawLine event. More...
class | OsFillEventArgs
Provides data for the OsFill event. More...
class | OsSetColourEventArgs
Provides data for the OsSetColour event. More...
class | OsShowBitmapEventArgs
Provides data for the OsShowBitmap event. More...
class | GameFileErrorEventArgs
Provides data for the GameFileError event. More...
class | InputFinishedEventArgs
Provides data for the InputFinished event. More...
class | L9Cut
Controls the L9cut utility to extract datafiles and obtain the title of a game. More...
class | L9CutForm
Dialog frontend for the L9cut utility. More...
class | Logger
Simple logging functionality for Level9.Net. More...
class | MainForm
Main window of the Level9.Net application. More...
class | Script
Manages Level9.Net script files. More...
class | ScriptEntry
Represents a Level9.Net script entry that consists of user input and a comment. More...
class | LexerError
Represents a grammar error that occurs while parsing a Level9.Net script file. More...
class | ScriptChangedEventArgs
Provides data for the ScriptChanged event. More...
class | ScriptForm
A dialog to create, edit, load and save Level9.Net script files. More...
class | SimpleListView
Simple list view control with icons and captions. More...
class | ListViewItemClickedEventArgs
Provides data for the ListViewItemClicked event. More...
class | SimpleListViewItem
Represents a simple list view item. More...
class | SimpleToolBar
Simple toolbar with icons and tooltips. More...
class | ToolbarButtonClickedEventArgs
Provides data for the ToolbarButtonClicked event. More...
class | SimpleToolBarButton
Represents a simple toolbar button. More...
class | TextForm
Simple text viewer with search options. More...
class | TextUtils
Utilities for text handling. More...
class | TextPosition
Represents a text position defined via paragraph and column. More...
class | AttributedText
Represents text with attribute information. More...

Functions

delegate void | ConfigChangedEventHandler (ConfigChangedEventArgs e)
delegate void | PictureCreatedEventHandler (PictureCreatedEventArgs e)
delegate void | GraphicsOffEventHandler (GraphicsOffEventArgs e)
delegate void | InputModeEventHandler (InputModeEventArgs e)
delegate void | OsFlushEventHandler (OsFlushEventArgs e)
delegate void | OsInputEventHandler (OsInputEventArgs e)
delegate void | OsReadcharEventHandler (OsReadcharEventArgs e)
delegate void | OsSaveFileEventHandler (OsSaveFileEventArgs e)
delegate void | OsLoadFileEventHandler (OsLoadFileEventArgs e)
delegate void | OsGetGameFileEventHandler (OsGetGameFileEventArgs e)
delegate void | NewGameFileEventHandler (NewGameFileEventArgs e)
delegate void | OsGraphicsEventHandler (OsGraphicsEventArgs e)
delegate void | OsClearGraphicsEventHandler (OsClearGraphicsEventArgs e)
delegate void | OsDrawLineEventHandler (OsDrawLineEventArgs e)
delegate void | OsFillEventHandler (OsFillEventArgs e)
delegate void | OsSetColourEventHandler (OsSetColourEventArgs e)
delegate void | OsShowBitmapEventHandler (OsShowBitmapEventArgs e)
delegate void | GameFileErrorEventHandler (GameFileErrorEventArgs e)
delegate void | InputFinishedEventHandler (InputFinishedEventArgs e)
delegate void | ScriptChangedEventHandler (ScriptChangedEventArgs e)
delegate void | ListViewItemClickedEventHandler (Object sender, ListViewItemClickedEventArgs e)
delegate void | ToolbarButtonClickedEventHandler (Object sender, ToolbarButtonClickedEventArgs e)
delegate void | ToolbarButtonEnabledChangedEventHandler (SimpleToolBarButton sender, EventArgs e)

Function Documentation

delegate void Level9::ConfigChangedEventHandler ( ConfigChangedEventArgs e )

Represents the method that handles a ConfigChanged event.

delegate void Level9::PictureCreatedEventHandler ( PictureCreatedEventArgs e )

Represents the method that handles a PictureCreated event.

delegate void Level9::GraphicsOffEventHandler ( GraphicsOffEventArgs e )

Represents the method that handles a GraphicsOff event.

delegate void Level9::InputModeEventHandler ( InputModeEventArgs e )

Represents the method that handles an InputMode event.

delegate void Level9::OsFlushEventHandler ( OsFlushEventArgs e )

Represents the method that handles a OsFlush event.

delegate void Level9::OsInputEventHandler ( OsInputEventArgs e )

Represents the method that handles a OsInput event.

delegate void Level9::OsReadcharEventHandler ( OsReadcharEventArgs e )

Represents the method that handles a OsReadchar event.

delegate void Level9::OsSaveFileEventHandler ( OsSaveFileEventArgs e )

Represents the method that handles a OsSaveFile event.

delegate void Level9::OsLoadFileEventHandler ( OsLoadFileEventArgs e )

Represents the method that handles a OsLoadFile event.

delegate void Level9::OsGetGameFileEventHandler ( OsGetGameFileEventArgs e )

Represents the method that handles a OsGetGameFile event.

delegate void Level9::NewGameFileEventHandler ( NewGameFileEventArgs e )

Represents the method that handles a NewGameFile event.

delegate void Level9::OsGraphicsEventHandler ( OsGraphicsEventArgs e )

Represents the method that handles a OsGraphics event.

delegate void Level9::OsClearGraphicsEventHandler ( OsClearGraphicsEventArgs e )

Represents the method that handles a OsClearGraphics event.

delegate void Level9::OsDrawLineEventHandler ( OsDrawLineEventArgs e )

Delegate declaration of the OsDrawLine event handler.

delegate void Level9::OsFillEventHandler ( OsFillEventArgs e )

Represents the method that handles a OsFill event.

delegate void Level9::OsSetColourEventHandler ( OsSetColourEventArgs e )

Represents the method that handles a OsSetColour event.

delegate void Level9::OsShowBitmapEventHandler ( OsShowBitmapEventArgs e )

Represents the method that handles a OsShowBitmap event.

delegate void Level9::GameFileErrorEventHandler ( GameFileErrorEventArgs e )

Represents the method that handles a GameFileError event.

delegate void Level9::InputFinishedEventHandler ( InputFinishedEventArgs e )

Represents the method that handles a InputFinished event.

delegate void Level9::ScriptChangedEventHandler ( ScriptChangedEventArgs e )

Represents the method that handles a ScriptChanged event.

delegate void Level9::ListViewItemClickedEventHandler | ( | Object | sender,
 |  | ListViewItemClickedEventArgs | e
 | ) |  |

Represents the method that handles a ListViewItemClicked event.

delegate void Level9::ToolbarButtonClickedEventHandler | ( | Object | sender,
 |  | ToolbarButtonClickedEventArgs | e
 | ) |  |

Represents the method that handles a ToolbarButtonClicked event.

delegate void Level9::ToolbarButtonEnabledChangedEventHandler | ( | SimpleToolBarButton | sender,
 |  | EventArgs | e
 | ) |  |

Represents the method that handles a ToolbarButtonEnabledChanged event.


Level9.Net: Namespace Members

  • All
  • Functions
Here is a list of all documented namespace members with links to the namespaces they belong to:
  • ConfigChangedEventHandler() : Level9
  • GameFileErrorEventHandler() : Level9
  • GraphicsOffEventHandler() : Level9
  • InputFinishedEventHandler() : Level9
  • InputModeEventHandler() : Level9
  • ListViewItemClickedEventHandler() : Level9
  • NewGameFileEventHandler() : Level9
  • OsClearGraphicsEventHandler() : Level9
  • OsDrawLineEventHandler() : Level9
  • OsFillEventHandler() : Level9
  • OsFlushEventHandler() : Level9
  • OsGetGameFileEventHandler() : Level9
  • OsGraphicsEventHandler() : Level9
  • OsInputEventHandler() : Level9
  • OsLoadFileEventHandler() : Level9
  • OsReadcharEventHandler() : Level9
  • OsSaveFileEventHandler() : Level9
  • OsSetColourEventHandler() : Level9
  • OsShowBitmapEventHandler() : Level9
  • PictureCreatedEventHandler() : Level9
  • ScriptChangedEventHandler() : Level9
  • ToolbarButtonClickedEventHandler() : Level9
  • ToolbarButtonEnabledChangedEventHandler() : Level9


Level9.Net: Namespace Members

  • All
  • Functions
  • ConfigChangedEventHandler() : Level9
  • GameFileErrorEventHandler() : Level9
  • GraphicsOffEventHandler() : Level9
  • InputFinishedEventHandler() : Level9
  • InputModeEventHandler() : Level9
  • ListViewItemClickedEventHandler() : Level9
  • NewGameFileEventHandler() : Level9
  • OsClearGraphicsEventHandler() : Level9
  • OsDrawLineEventHandler() : Level9
  • OsFillEventHandler() : Level9
  • OsFlushEventHandler() : Level9
  • OsGetGameFileEventHandler() : Level9
  • OsGraphicsEventHandler() : Level9
  • OsInputEventHandler() : Level9
  • OsLoadFileEventHandler() : Level9
  • OsReadcharEventHandler() : Level9
  • OsSaveFileEventHandler() : Level9
  • OsSetColourEventHandler() : Level9
  • OsShowBitmapEventHandler() : Level9
  • PictureCreatedEventHandler() : Level9
  • ScriptChangedEventHandler() : Level9
  • ToolbarButtonClickedEventHandler() : Level9
  • ToolbarButtonEnabledChangedEventHandler() : Level9


Level9.Net: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented,
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};

This will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled gray box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.

The arrows have the following meaning:

  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.